• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 785
  • Last Modified:

Sys is undefined only for the buffered site

Hi.
My website is running without any error, but when i look at the buffered site of it ( Google, Yahoo )I get a sys is undefined error.
URL for buffered page: http://www.google.no/search?hl=no&q=din%20startside
Best regards
0
dinstartside
Asked:
dinstartside
  • 6
  • 5
1 Solution
 
b0lsc0ttIT ManagerCommented:
Seems to work for me.  Please try again and see if your result was just a temporary problem.

bol
0
 
dinstartsideAuthor Commented:
Well, the website is almost doing fine in all browsers exept IE7, it still gives me the errors on the snapshot page from google. I have upgraded from asp.net Framework 3.5 to asp.net AJAX enabled website Framework 3.5. That seems to have killed this issue for all browsers exept IE7.
I also find it weird that if you try to make a search on my site (from the snapshot of any search engine in any browser) it gives an error. It seems like there is a postback problem with the index.aspx
My config file as attachement.

Best regards.
<?xml version="1.0"?>
<configuration>
  <configSections>
    <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
      <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
        <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication"/>
        <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
          <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="Everywhere" />
          <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
          <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
        </sectionGroup>
      </sectionGroup>
    </sectionGroup>
  </configSections>
 
  <system.web>
    <pages>
      <controls>
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      </controls>
    </pages>
    <!--
          Set compilation debug="true" to insert debugging
          symbols into the compiled page. Because this
          affects performance, set this value to true only
          during development.
    -->
    <compilation debug="false">
      <assemblies>
        <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
        <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
        <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
 
      </assemblies>
    </compilation>
 
    <httpHandlers>
      <remove verb="*" path="*.asmx"/>
      <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>
      <add verb="GET" path="ScriptResource.axd" type="Microsoft.Web.Handlers.ScriptResourceHandler" validate="false"/>
    </httpHandlers>
 
    <httpModules>
      <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    </httpModules>
  </system.web>
 
  <system.web.extensions>
    <scripting>
      <scriptResourceHandler enableCompression="false" enableCaching="true" />
    </scripting>
  </system.web.extensions>
 
  <system.webServer>
    <validation validateIntegratedModeConfiguration="false"/>
    <modules>
      <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    </modules>
    <handlers>
      <remove name="WebServiceHandlerFactory-Integrated" />
      <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode"
           type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode"
           type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
      <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
    </handlers>
  </system.webServer>
</configuration>

Open in new window

0
 
b0lsc0ttIT ManagerCommented:
It seems like this has moved on to a new issue.  Did you post the above in the wrong question?

Maybe I misunderstood but it seems like you were asking about the page Google shows when clicking Cached (see image below).  I had no problem seeing a result page when I clicked it.  However you almost certainly can't use that page like a normal web page.

Please clarify the last comment or what you are asking here.

bol
Buffered-NL.png
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
dinstartsideAuthor Commented:
Hi again.

You are getting me right. The cached (snapshot from Google as showed on image) site seems to have problems with the script handler. I just dont get it, its running fine when I open the website in all browsers, but get the sys& error in cached. So my question is why does the cached page generate this error in IE7? And how can I fix it? And dos this error infect my ranking in any way?
0
 
b0lsc0ttIT ManagerCommented:
I'm glad I understood you correctly. :)  Thanks for the follow up.

>> why does the cached page generate this error in IE7? <<

I can't tell you an exact reason but I am sure it has to do with how Google caches the page and what it actually stores or where.  Remember that a cached version isn't hosted on your server or run on your site.  It is a saved version of the page.  Their purpose in doing that is so you can see content (basically static) not for you to be able to use the page.  Possible reasons are they disable some script and content, don't cache or have access to some external file needed for that part of the page, or just don't let it run.  It may even be a combination of those reasons.

>> And how can I fix it? <<

For the specific cached page there is NO way to fix it.  You don't even have access to the page code anymore.  You can just see it in your browser like everyone else.  Honestly I wouldn't even spend time trying to fix it but maybe I am not aware of some reason or need you have to run your site like that.  If it is a problem that makes the cache useless then you could look at the html and script for that area.

Keep in mind the cache isn't meant to be used so you can run something on your site, fill out a form, etc.  Think of it like an image taken of your page some hours or days ago.  That image won't change and can't be used to dynamically do something on "your site."  If the error makes the image look bad then that is one thing but it sounds like you are trying to do something on the page.  There is probably no way to fix that for the reasons I mentioned above.

>> And dos this error infect my ranking in any way? <<

Search engine rankings and optimization isn't really my expertise anymore.  It has also changed some since it was so maybe there is some negative effect I can't think of.  However I would be really surprised if your ranking were affected.  I am not real clear if this error occurs right when you view the page (which I have not been able to duplicate) or as you try to do something on it.  If the latter then I can say with almost 100% certainty it would not affect your ranking.  There is no reason to try to fix it, even if you could.

If the error occurs right when the cached page is viewed (so the "image" is messed up or incomplete) then there may be an effect.  If Google is not able to read part of the page then it may miss some content that would affect (may be positively) your ranking.  I am not saying they are penalizing you but they just may not be "seeing" everything on the page.

I hope all of that is clear. :)  Let me know how it helps or if you have a question.

bol
0
 
b0lsc0ttIT ManagerCommented:
I'm glad I could help.  Did you still have a question or need some help with this?  I noticed the B grade and was a little surprised and confused.  I thought my comments were pretty timely and complete.

If you still need help then let me know.  I will be happy to do what I can to give you the complete answer and get the A.  If the grade was a mistake or you have a question about what grading means on this site then let me know.

Thanks for the fun question.

bol
0
 
dinstartsideAuthor Commented:
Nope, you´re answers where fine thanks!
The B was just because I´m new here, and I just went trough the check boxes in two seconds. Sorry for that!

Best regards
0
 
b0lsc0ttIT ManagerCommented:
Thanks a lot for the response.  I'm glad I didn't overlook something and leave you needing more.  I hadn't taken the time to look to see when you joined (or forgotten).  Welcome!  I hope we continue to see you around and you enjoy this site.  Let me know if you have a question using it.

If you would've assigned an A and this deserves one then let me know how you feel about me changing it.  The grade does affect how it appears as a solution to others.  If there is a complete answer and useful info then an A will make it so others will look at it too.  Also the grade does affect the expert points so there is a little "selfish" motivation too. ;)

Since I am a zone advisor I can actually make the change for you if you agree.  Otherwise you can always get help like this (i.e. reopen a question, grade change, unaccept a comment when you chose the wrong one, need attention from other experts, etc) by clicking on the Request Attention link/button.  It is located in the bottom, right of the question body (so at the top of the page) near the Translate pull down list.  You don't have to use it in this case but I wanted you to know of the useful feature.

Thanks again for the response and letting me know it was intentional.  Let me know if you have a question about any of this.

bol
0
 
dinstartsideAuthor Commented:
Hi again Bol.

It seems like I have some problem with one of the script resource handlers in my config file.
In Goole toolbar it tries to index some scriptresource.axd sites:
(It says that this is pages that it cant reach)

Ive tried to stop that by using the following text in robots.txt, can you please confirm if this is the correct way of doing it, or do I have to look up whats wrong in the config file?

Disallow: */.axd

My config file is attached in earlier post, and I´m using ASP.NET Ajax enabled website Framework 3.5
I believe this problem is also related to the sys is undefined issue too.

Best regards


sraxd.jpg
0
 
b0lsc0ttIT ManagerCommented:
That seems like a different issue from what we worked on here (Google's cached pages).  It needs to be posted in a new question if that is the case.  If you would like my help with it then feel free to post a comment here with the new question's URL.  I will look at it and see if I can help.  I am not an ASP.NET expert though so I will probably not be able to help with questions on it.  Let me know if you have a question about this.

Did you want the grade to stay as a B or do you want it to be an A?  You can look at http://www.experts-exchange.com/help.jsp#hi97 for a good guide on the difference and to get an idea of which fits here.  If you did make a mistake and mean to give an A grade then I would like to fix this.

bol
0
 
dinstartsideAuthor Commented:
np. I will drop a new post, and yes you can upgrade it to A
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now