How to modify OWA internal and external addresses and other settings

Ok here's what I need to do. I need to modify the OWA external and internal addresses and make them the same. I want to make them something like http://mail.domain.com I believe you would change the address in the EMC under server configuration > Client Access > OWA > General tab. But when I modify the default address then try and test it I don't hit OWA. Also I want to make sure users can access it using http. If they use https they get prompted with that security screen and i want to make it as easy as i can for them. Also is there a way only to have OWA ask for just their user name and password when logging on and get rid of all the other options like default language, time zone, and security for public or private computer?? Thanks a bunch!!
LVL 1
Abacus ITAsked:
Who is Participating?
 
LeeDerbyshireConnect With a Mentor Commented:
The first problem sounds like a name resolution issue.  If mail.domain.com resolves internally to your public IP address, then you will never reach it, since the router won't know how to reflect the traffic back inside.  You'd need to configure internal A records to point to a private IP address.

If you wan to get rid of all those OWA choices, the easiest way is to disable Forms-based Authentication.
0
 
Abacus ITAuthor Commented:
ok I have the external URL configured as http://mail.domain.com I am going to leave the internal to it's default for right now. question is I can hit it from the outside using https://mail.domain.com even though I have it configured as http://mail.domain.com If i hit it I get a Under Construction page??? Do I have to change something else to point it to OWA? Also is it possible to take off the https and just use http?

Also I switched from Forms-based Authentication to Use one or more standard authentication methods and selected Intergrated Windows Authentication but when I log on internaly to test I get an error about not finding the users mailbox? Thanks again for your help!
0
 
LeeDerbyshireConnect With a Mentor Commented:
Do you have an ISA server?  If so, then it sounds like you are getting the site contents for the external URL from the /exchange Virtual Directory.  Internally, you would not be going through ISA, so you see the Default Web Site instead.

To get rid of the https, just go into IIS Manager, and tell it that SSL is no longer required on the Exchange VDir.
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
Abacus ITAuthor Commented:
No we don't have an ISA server and everything else should be the installed defaults. The only thing I have changed is the external URL.

Sorry but when I open IIS manager where do I find the Exchange VDir and how do I disable SSL? Sorry new to this thing ;)
0
 
LeeDerbyshireConnect With a Mentor Commented:
Look for the Web Sites container.  Expand it until you see Exchange.  Right-click it to look at its properties, and look for Require Secure Channel.  Uncheck it, and you will no longer need to use HTTPS.  You should be aware, though, that without SSL, the traffic is no longer encrypted, and is therefore less secure.
0
 
Abacus ITAuthor Commented:
I understand.. Is it hard to get the certificate to work so users aren't prompted at that screen?
0
 
Abacus ITAuthor Commented:
ok so I found the Exchange entry and deselected Require Secure Channel under directory security tab the > edit secure comunications. After I apply it I tried to hit http://mail.domain.com from the outside and I receive a page that says this page needs to be viewed using https . I tried to edit the security on the OWA entry under IIS default web site as well but no luck... still wants to use IIS??
0
 
LeeDerbyshireConnect With a Mentor Commented:
You may also have it required on the exchweb Virtual Directory, which contains all the images and some supporting .js scripts.
0
 
Abacus ITAuthor Commented:
ok I got the http to work! I got the basic authenrication to work!! now heres my last issue... when I hit it externaly i want to hit it using http://mail.domain.com if I do so I get an "under construction message" but if I hit it going to http://mail.domain.com/owa I can access it! how can I be able to access it just using http://mail.domain.com??  =)
0
 
LeeDerbyshireCommented:
So, to establish that I understand the situation correctly:  If you go to http://mail.domain.com internally, it goes straight to OWA?  And you don't have an ISA server?
0
 
Abacus ITAuthor Commented:
No sorry. I left the internally the default because internal clients will more then likely be using outlook. The only one I changed was the external I made that http://mail.domain.com now from outside of my network when I test. If i use the link http://mail.domain.com I hit an underconstruction page (like it doesn't know how to find OWA. But it I use the link http://mail.domain.com/owa it finds the OWA and I can access my mailbox. How can I get just http://mail.domain.com to work? Thanks again!
0
 
LeeDerbyshireConnect With a Mentor Commented:
Try this, but use /owa instead of /exchange
http://support.microsoft.com/kb/319878
0
 
Abacus ITAuthor Commented:
Thanks again for all your help! Everything is working the way we want it to now!! CHEERS
0
All Courses

From novice to tech pro — start learning today.