Solved

"Email" icon in word 2003 grayed out and I do have an email account set up through Outlook.

Posted on 2008-06-17
12
1,777 Views
Last Modified: 2012-05-05
When using Word 2003 the "email icon" is grayed out. I looked up similar problems and they all say you need to have your email account set up and we do. I also tried going to see if Outlook is set as a defualt email program and it is. Same with default access.

Last time I had this problem I just re-installed Office and it seemed to fix what ever registry edit we needed to fix, but I dont want to do that everytime this happens. The user didnt do anything different (so they say). I didnt notice anything different.

Also, In outlook the users profile doesnt have "use microsoft word 2003 to edit...." checked and this user has never had that checked and it has always worked.

Any help would be appriciated.

Thanks
Dm
0
Comment
Question by:amait
  • 7
  • 5
12 Comments
 
LVL 12

Expert Comment

by:alikaz3
ID: 21805758
0
 
LVL 12

Expert Comment

by:alikaz3
ID: 21805764
more specifically, here is the microsoft KB:
http://support.microsoft.com/kb/918792
0
 

Author Comment

by:amait
ID: 21806413
Word 2003 not 2007. This KB specifically applies to 2007 software.
0
 
LVL 12

Expert Comment

by:alikaz3
ID: 21806467
I realize that. The "Method 2" portion applies to 2003 as well, I know this because it worked for me, with an office 2003 machine. it's those mapi.dll and mapi32.dll settings in the registry that are the issue. here it is:

Method 2: Verify the registry settings
Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows
1.      Close all programs.
2.      Click Start, click Run, type regedit in the Open box, and then click OK.
3.      Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Messaging Subsystem
4.      Locate the following registry values. Typically, these values are listed in the Windows Messaging Subsystem key.
Name      Type      Data
MAPI      REG_SZ       1
CMC      REG_SZ       1
CMCDLLNAME       REG_SZ       Mapi.dll
CMCDLLNAME32      REG_SZ       Mapi32.dll
MAPIX      REG_SZ       1
MAPIXVER      REG_SZ       1.0.0.1
OLEMessaging      REG_SZ       1
5.      If any of these registry values are missing, follow these steps to add the values:
a.       Click the Windows Messaging Subsystem subkey, point to New on the Edit menu, and then click String Value.
b.       Type the name of the missing value, and then press ENTER.
c.       Click the new value, and then click Modify on the Edit menu.
d.       In the Edit String dialog box, type the correct value for the missing string value in the Value data box.
e.       Repeat steps 6a - 6d for each value that is missing from the table that is in step 4.
6.      On the File menu, click Exit.
Typically, Excel 2007, PowerPoint 2007, and Word 2007 display the correct e-mail options automatically when the required registry keys are present. If these programs do not display the e-mail options after you use the methods described here, add the e-mail options to these programs. To do this, follow these steps:
1.      On the File menu, click Program Name Options.
2.      Click Customization, and then click All commands in the Commands list.
3.      Click the command that you want, and then click Add to add the command to the Quick Access toolbar. For example, click Send for Review, and then click Add to add the Send for Review command to the toolbar.
4.      Click OK.

Back to the top
0
 
LVL 12

Expert Comment

by:alikaz3
ID: 21806492
basically, the office button asks windows what program is used for emailing (via those .dll files pointed to by the registry). When you install full office (with outlook), these settings won't be present until you create an email account in outlook. If for some reason outlook doesn't make those settings, the association between word - windows - and outlook is not complete, and these registry entries must be manually entered. This also applies when you are using a non-outlook email program (like thunderbird). Adding the .dlls make this function work with TB as well.
0
 

Author Comment

by:amait
ID: 21806504
OK, I will give it a shot. Thanks for the explanation, that makes sense.

Dm
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:amait
ID: 21806689
Ok, I looked at all the registry settings, and they are all correct. Everything you had me looked at is correct.

I did try and click on (in Word) File-SendTO-Mail recipient (or review) and (as attachment). It spits out this...(see below) which makes me believe it IS something with the MAPI\Word connection. What do you think?

 
Details                
Product:      Office         
ID:      10092         
Source:      OfficeErrorMessages         
Version:      11.0         
Message:      Links to additional information about the error message you saw are available below.       
 
               
Currently there are no Office Assistance articles available for this error message.                
This error can occur if you attempt to send a Word document as an e-mail attachment in Word and the MAPI session was closed and Word is no longer able to connect to that MAPI session, or there is a problem with the fax configuration.
To correct a MAPI related error: restart the MAPI e-mail program (for example, Outlook) or save and close the document, and then restart Word after restarting your MAPI e-mail application.  Word will establish a new MAPI session, allowing the document to be sent.
To correct a problem with the fax configuration, review the configuration settings for your fax software and make the appropriate changes.
More information about this error message online.
0
 
LVL 12

Expert Comment

by:alikaz3
ID: 21806900
It sounds like you are on the right track... so in that Windows Messaging Subsystem folder in the registry, you have:

Name      Type      Data
MAPI      REG_SZ       1
CMC      REG_SZ       1
CMCDLLNAME       REG_SZ       Mapi.dll
CMCDLLNAME32      REG_SZ       Mapi32.dll
MAPIX      REG_SZ       1
MAPIXVER      REG_SZ       1.0.0.1
OLEMessaging      REG_SZ       1

-------------

also, i just found this:

Had the same issue. The answer was to go tools/options/mail format. UNcheck "Use Microsoft Office Word 2003 to edit e-mail messages"
0
 
LVL 12

Expert Comment

by:alikaz3
ID: 21806914
and this:

find the WIN.INI file in your Windows folder (typically
>>>>> >> c:\WINDOWS),
>>>>> >> make a backup copy of it, and open it in Notepad.
>>>>> >> b. ensure that the following text is in there, and add it if not
>>>>> >>
>>>>> >> [Mail]
>>>>> >> MAPI=1
>>>>> >> CMCDLLNAME32=mapi32.dll
>>>>> >> CMCDLLNAME=mapi.dll
>>>>> >> CMC=1
>>>>> >> MAPIX=1
>>>>> >> MAPIXVER=1.0.0.1
>>>>> >> OLEMessaging=1
>>>>> >>
>>>>> >> You will need to close all copies of Word before this change has a
>>>>> >> chance
>>>>> >> of
>>>>> >> taking effect. It is probably safest to restart Windows to be
>>>>> >> completely
>>>>> >> sure.
0
 

Author Comment

by:amait
ID: 21807688
Ok. I read that stuff from the first two links that came up on google. Both methods are correct on our machine. Each step is correct and all the numbers and words are identical. I even blew out the profile in outlook and re-created it to see if that was it.

Also, like i said before, both boxes are unchecked when it comes to the mail editor. It always has been.



0
 
LVL 12

Accepted Solution

by:
alikaz3 earned 315 total points
ID: 21807836
Ok I would go for a repair installation of outlook next.
0
 

Author Comment

by:amait
ID: 21813563
I ended up un-installling Office 2003, and the access 2000 that was installed (this might have had something to do with it?) and re-installed and it is back and working fine now.

0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Suggested Solutions

I'm writing to share my clumsy experience in using this elegant tool so you can avoid every stupid mistake I made. (I leave it to the authorities to decide if this deserves a place in the Knowledge archives.)  Now that I am on the other side of my l…
I would like to show you some basics you can do with Mailings in MS Word. It´s quite handy feature you can use for creating envelopes, labels, personalized letters etc. First question could be what is this feature good for? Mailing can really he…
This video shows the viewer how to set up and create Footnotes in their document. Click on the References tab: Select "Insert Footnote": Type in desired text:
Office 365 is currently available in five editions. Three of them are for business use: Office 365 Business Essentials, Office 365 Business, and Office 365 Business Premium. Two of them are for home/personal use: Office 365 Home and Office 365 Perso…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now