Solved

After SMS recovery - > Unable to get package distribution or advertisements to work

Posted on 2008-06-17
2
994 Views
Last Modified: 2013-11-21
Have one SMS Server Primary Site on a Windows 2003 R2 Server.  All Clients are Advanced (WinXP).  The server have been experiencing some random STOP errors due to some hardware problems, so we recently put together a different server to run SMS on.  We backed up the old SMS server copied of all the source files, disjoined the domain, and removed it from the network.  On the new server we installed SMS and SQL, (with the same versions as old server), joined the domain with the same name and IP as old server, recovered the site, restored source files, and all seemed to be recovered correctly (smspkgc$ directory was repopulated also).

However now... When attempting to install applications it says "Searching for Program Files..." and any new advertisements  do not reach the clients.  I have checked the security assignments and the SMS account on both the new and the old server... they appear to be the same.  SMS is set to use the local system account.

The old server is still available and once it is restored everything works again.

Any help is appreciated,

Thanks,
0
Comment
Question by:tahlequahitguy
  • 2
2 Comments
 

Author Comment

by:tahlequahitguy
ID: 21813506
Added some error logs... seems to be a MP problem (3 continuous errors)

1. MP could not write out CCM setting to WMI. The operating system reported error 2147942406: The handle is invalid.

2. MP could not update its settings to the new values. The operating system reported error 2147942406: The handle is invalid.

3. SMS Executive detected that this component stopped unexpectedly.

Possible cause: The component is experiencing a severe problem that caused it to stop unexpectedly.
Solution: Refer to your SMS documentation or the Microsoft Knowledge Base for further troubleshooting information.



0
 

Accepted Solution

by:
tahlequahitguy earned 0 total points
ID: 21813848
Issue is resolved now... For some reason BITS was not installed.  Installed it and everything seems to be working fine.  Thanks.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found listed in my profile here: http:…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now