Camera does not appear as a drive in Windows Explorer

Why does my Olympus 840 U not appear as a drive letter on my XP computer in Windows explorer. It appears in Device manager under Disk Drives, and also as Mass Storage Device under USB devices. I don't see it in Disk Manager. This camera has worked on this pc at one point. It works on 3 other pc's in the shop with no problem. Can anyone tell me what I need to do to see it as a drive again in "My Computer"?

I've tried uninstalling both the disk drive and the mass storage device from My Computer and then scanned for devices and let it be picked up by Windows XP again, but it still doesn't show as a drive in My Computer"
bwierzbickiAsked:
Who is Participating?
 
PUNKYConnect With a Mentor Commented:
I need to ask this, did you turn on camera when plug it in PC? And have you installed driver for the camera yet?
0
 
PUNKYCommented:
In Control Panel > Administrative Tools > Computer Management > Storage > Disk Management > if you see the drive there, right click on it and assign drive letter.
0
 
bwierzbickiAuthor Commented:
No, it's not disk manager.
0
 
Nick DennyCommented:
Do you have many mapped drives, optical drives, virtual drives or partitions.
Often USB drives struggle to obtain a drive letter after about G: I think.
0
 
bwierzbickiAuthor Commented:
ok, thanks punky you put me in the right direction.

There was a mapped drive, "E".  I removed the "E" mapping because basically it was the next drive after the pc's c and d drive, which are hard drive and cdrom.  For whatever reason it must have been trying to grab E and couldn't. I changed the mapping to M and it worked.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.