Solved

IIS 6 SMTP service has emails building up in drop folder.

Posted on 2008-06-17
8
2,102 Views
Last Modified: 2013-11-30
Hello,

We have several web sites with forms on them that send emails.  They use the SMTP service on IIS.  We have just added a catcha and it has stopped loads of spam however I have now noticed a few genuine emails in the drop folder.  i don't believe these emails are getting through to their destination.  Here is one of the emails:

x-sender: websiteuser@somewhere.com
x-receiver: 0@myserver
Received: from myserver.mydomain.com ([127.0.0.1]) by myserver.mydomain.com with Microsoft SMTPSVC(6.0.3790.1830);
       Wed, 18 Jun 2008 12:45:21 +0100
Subject: 0
Sender: websiteuser@somewhere.com
From: websiteuser@somewhere.com
Date: Wed, 18 Jun 2008 12:45:21 +0100
To: client@theirdomain.com
CC: "0" <0>
X-Priority: 3
X-MSMail-Priority: Normal
Content-Transfer-Encoding: Quoted-Printable
MIME-Version: 1.0
X-Mailer: JMail 4.4 by Dimac
Content-Type: text/plain;
      charset="iso-8859-1"
Return-Path: websiteuser@somewhere.com
Message-ID: <WAIKAWAUIEAOeIiGXix0000001a@myserver.mydomain.com>
X-OriginalArrivalTime: 18 Jun 2008 00:45:21.0796 (UTC) FILETIME=[96979C40:01C8D0DC]

Message body...

---

The first thing I find odd is the "x-receiver: 0@myserver".  Should this be like this or is this field incorrect?
Does anyone know why these emails are ending up in the drop folder?  Are the clients email servers rejecting them because of spam filtering?  Why do emails end up in the drop folder?  All the email addresses are correct as I can take the .eml file out of the folder and send it using Outlook on my machine.

Thank you
Tom
0
Comment
Question by:TomMonkey
  • 5
  • 3
8 Comments
 
LVL 23

Expert Comment

by:debuggerau
ID: 21810137
that quite normal that the servers name is inserted here, however is it an alias address?

http://www.bellaonline.com/articles/art27166.asp

You could drag drop them into the pickup folder again and they should be resent, but ensure the aliases are removed.
0
 

Author Comment

by:TomMonkey
ID: 21810195
Hi debuggerau,

Thanks for the quick response.

I don't think any of the addresses are aliases.  There certainly isn't one for 0@myserver.

I read the article and it makes sense.  The problem I have is that the websiteuser@somewhere.com is always going to be different depending on who fills out the form on the website.  Is the article implying that I need to set up and alias for every domain that they could be sending from?

Should I just change the default domain's drop directory to be the pickup folder?

Cheers
Tom
0
 

Author Comment

by:TomMonkey
ID: 21810212
Also I tried dragging the emails in the pickup folder but they instantly appear in the drop folder again.
0
 
LVL 23

Expert Comment

by:debuggerau
ID: 21818325
otherwise were they test emails to its own domain maybe?
http://www.windowsitlibrary.com/Content/141/09/1.html
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 

Author Comment

by:TomMonkey
ID: 21819448
I definitely think the problem has something to do with "x-receiver: 0@myserver".  That seems to make it think it's destined for myserver rather than the actual domain.  The default rule for myserver, defined under 'Default SMTP Virtual Server > Domains > myserver' is to put it in the drop folder.  Is there a way to make it forward these on to the smarthost?  Can I stop this x-header appearing in the first place?

Cheers
Tom
0
 

Author Comment

by:TomMonkey
ID: 21819463
Another one just came in and I altered the x-receiver to match the to field and dragged it to the pickup folder.  The email seemed to disappear after that.  Is there anyway to stop this x-header from appearing or correct it?

Cheers
Tom
0
 
LVL 23

Accepted Solution

by:
debuggerau earned 500 total points
ID: 21819688
you need the header, and your the action is normal.
Since the drop folder is the delivery location for your server, if the server name was used as the destination, thats where emails will go.
so your x-receiver file will be the destination domain address and needs to be accessible from your DNS server..

0
 

Author Comment

by:TomMonkey
ID: 21862752
Thanks for the help.  In the end we changed the settings in Jmailer to use the smart host directly instead of going through IIS.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

First of all, clustering IIS is something you should rarely consider doing. In almost all cases, Microsoft Network Load Balancing (NLB) (http://technet.microsoft.com/en-us/library/cc758834(WS.10).aspx) is a much better solution when you need to p…
Hello Friends, My friends and relatives always ask me how to delete all the various types of emails at once in our g-mail  or windows live account.  So I researched this topic to find a unique solution to this query.  Here it is for those who do …
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now