Solved

configuring etherchannel

Posted on 2008-06-18
51
5,849 Views
Last Modified: 2008-07-07
hi

we currently have 4 100mb cisco 3500 48 port switches. i am changing them to 4 cisco 2960 48 port gig switches shortly. i want to connect the switches to each other via 2 port etherchannel. am i right in saying then that this will give me 2 Gig links between the switches. is it easy to configure this ?? can you help me with it? and also what speed does fibre connect at?
0
Comment
Question by:mikeleahy
  • 23
  • 18
  • 8
  • +1
51 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21811817
>am i right in saying then that this will give me 2 Gig links between the switches.

Simply put, yes (assuming that you are using the gig ports). There are some caveats though.

>and also what speed does fibre connect at?

The fiber gig ports connect at 1 gigabit.

conf t

int range g0/1 -2

 channel-group 1 mode desirable

Open in new window

0
 
LVL 21

Expert Comment

by:from_exp
ID: 21811863
hi!
it is rather easy to configure, and yes, you can archive 2gig performance with etherchannel.

to configure, let's assume you have both switches to connect using gi0/1, gi0/2 ports

conf on 3500
conf t
int gi0/1 - 2
switchport
channel-group 1 mode active
end
int po1 ! this is you etherchannel virtual interface where you should define trunk or access vlans
description eth_channel
switchport
switchport mode trunk
switchport trunk allowed vlan 1,2 ! or any other vlans
end

conf 2960

conf t
int gi0/1 - 2
switchport
channel-group 1 mode passive
end
int po1 ! this is you etherchannel virtual interface where you should define trunk or access vlans
description eth_channel
switchport
switchport mode trunk
switchport trunk allowed vlan 1,2 ! or any other vlans
end
0
 

Author Comment

by:mikeleahy
ID: 21812479
what do you mean by caveats??

im not linking 3500 to 2960. im installed 4 new 2960 so the etherchannels will be between the 2960's. whats the channel group active/ passive about
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21812555
channel group - shows that port belongs to particular etherchannel
passive/active specify LACP master/slave mode.

btw, I would recommend connecting switches not in daisy-chain, but in star, so the first switch will have etherchannels to all other switches.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21813004
>what do you mean by caveats??

The load distribution algorithm will not result in more bandwidth between two specific devices. So if you have an etherchannel group made up of two 1 gig links, all the traffic between device A on switch 1 going to device B on switch 2 will cross only one of the links. So total bandwidth between the two devices is still 1 gig. However, traffic between other devices may use the other link so availability will improve.  
0
 

Author Comment

by:mikeleahy
ID: 21813219
so im never getting the two gigs?

from_exp = can you explain a little more about ur star idea. whats the other advantages of this, will i use less ports by doing it this way.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21813367
about two gigs:
etherchannel can aggregate several links together. it will use some hash function to load balance traffic between number of links. so if you have many MAC on one side of etherchannel talking to many macs one other side of etherchannel, you can utilize the cumulative bandwidth. but if you have only one MAC on one side and one MAC on the other side, then only one gig can be utilized because switches can do load balancing per MAC or per IP base.

as for star topology, when you connect all switches in row you will have more links between first and the last switch, so performance and fault tolerance are affected. you will also have configuration overhead (imaging configuring new vlan from first switch to the last)

when you chose one switch as root switch and connect all other switches to it you can improve your scenario. the only problem is your root switch. if it fails, you will lose your connectivity.



0
 

Author Comment

by:mikeleahy
ID: 21813734
ok. i have a very simple setup. i have only one vlan. is it just as good to daisy chain the switches using a standard cable and get 1gig througput. will i notice any difference by configuing etherchannel especially taking into account the port loss

can you get a fibre gbic for the 2960 switch??
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21815276
yepp
you can connect all switches in star or in daisy chain with one gig and monitor the performance.
and if you will see that one gig is not enough, just create ether channel

as for fibre, yes you can get fiber mini-gbics(SFPs) from cisco (or not even from cisco, they will work and there is special command to allow 3rd party SFPs)
but if you have all switches within the single room I'd recommend using copper cables, they are not so fragile.
0
 

Author Comment

by:mikeleahy
ID: 21829530
you see at present i have one of the older switches connecting by fibre to a switch in our warehouse. i didnt know this until the other day. now i need to keep that link, whats my best option

1. get electric guys to run a cat 5 cable all the way from the other switch
2. leave old switch there for fibre connection
3. can i get a new gbic to work with new switch and also connect to older bigger fibre connector?
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21829581
I would bet for the 3rd, but you have to check the fiber. how old is it? is it working at 1Gbps or 100Mbps?
If it is not that old and can do 1Gbps, you can get SFPs for your new switch and use your fiber line.

If not, choose between 1 and 2, where 2nd does not require additional installation works, so basically cheaper.
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21836290
You will need to understand fiber between the warehouse and switch to determine correct SFP.   In question is, fiber type (Single mode or multimode, short haul long haul and connector types) SFP will most likely be a LC connector terminated to a fiber patch panel with SC connectors but I would verify single mode vs multimode.  Its not worth the headache trying to mix and match gbics/sfp modules as the DONT all work.  Stick with same vendor gbics to be sure this is not a problem only to save a 50-100 dollars

Also, Cisco makes a WS-C2960-48-TC-L which has 48 10/100 UTP ports and 2 combo ports 1000 (SFP module and 2 fixed copper.  Only one or the other can be used)

What I would do is purchase a WS-C2960-48-TC-L  and connect the warehouse switch to it then on the other copper combo port I would run a copper cable to a WS-C2960-48-TT-L which is half the price and then daisy chain the other 2.  I try to keep daisy chain switches to 3-4 or less.    Unless you are streaming multicast traffic or video, 1 gig of throughput is plenty on a typical LAN.  You do have the option to do rate limiting on the 2960 edge ports.

0
 

Author Comment

by:mikeleahy
ID: 21844871
buying another switch is not an option im afraid. i had a look there and it just says 8 core fibre to new warehouse on it. standard fibre cable. what are LC and SC connectors. id rather get rid of the old switches so step one will probably be the way i will go

we wudnt be doing video etc so ill daisy chain the switches alrite.
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21846041
LC and SC are different type of fiber connections
wikipedia can help you to understand the difference ;)
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21849102
LC and SC are just connector types for fiber.  You can tell the difference simply by looking at them and comparing vs wikipedia or what ever.  SC is square connectors and LC are alot smaller.  The gbic would matter if its multimode or single mode fiber.  If you look at the fiber module being used now, you can look up the part number.

If its a Cisco it would be somthing like GLC-SX-MM  etc.

0
 

Author Comment

by:mikeleahy
ID: 21908718
last question guys. i am going to connect the switches via daisy chain. do i have to configure uplinkfast on the ports connecting the switches or create trunk ports etc??
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21910536
Hi!
what is uplinkfast? if your talking about spanning tree bpdu portfast, then answer is NO. portfast should be enabled on endports only.
as for trunks, yes, I recommend configuring uplink ports as trunks even if there is only single vlan needed at present time. it is possible, that you will need additional vlans later and it will make additional problems converting access ports to trunked in a production network.
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21912900
You can configure as trunk with dot1q encapsulation. its also best practice to specify 802.1Q VLAN tag traffic to go over that trunk interface:

Description trunk
switchport mode trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan x,x,x
0
 

Author Comment

by:mikeleahy
ID: 21914227
you never heard of uplinkfast?

http://www.cisco.com/warp/public/473/51.html

and you call yourself an expert?
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21914359
hmmm

new feature for me, because it is cisco proprietary.

and experts also learn new things ;)
0
 

Author Comment

by:mikeleahy
ID: 21914589
i know,. im only joking. it has been out for a long time. whats the beneift of configuring the ports as trunk ports rather than not doing it
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21914648
to my mind, the benefit is the following:
when upgrading your network, you can allow downtime to configure/reconfigure different settings.
Then you lunch you network in production. At this point reconfiguration, if it involves connectivity loss, is very painful, requires maintenance hours, etc.
So I would recommend configuring uplink ports as trunked during initial installation process and later on add additional vlans (very simple procedure) to existing infrastracture.
0
 

Author Comment

by:mikeleahy
ID: 21917100
i have two switches configured and the ports that connect the two switches together as trunk ports with dot1q and all vlans allowed thru. i have attached a laptop to switch 1 and can ping the management ip but cant ping the management IP of the other switch or a device on the other switch? any idea?
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21917517
Your laptop may not support 802.1q tagging.  Configure a interface on switch 1 as:

Description Laptop
switchport mode access
switchport access vlan x (where x is the mgmt VLAN you are using on those switches)
spanning-tree portfast

Configure yourself with a static IP in the same subnet then try again.

0
 

Author Comment

by:mikeleahy
ID: 21917632
im not even gettling lights on the ports on the switch that are connected to the other switch. does it have to be a crossover cable
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 3

Expert Comment

by:RTh0037
ID: 21917753
Few questions:

Are they connected by fiber or copper?
Are the fiber modules (if applicable) from same vendor?
Both switches are Cisco?

Look at the interfaces and see if one is in a error disable state for some reason.

show interface status

If its in a err-disable state that can be caused from a few things.  Bad fiber module, incompaitible modules, bad cable.

0
 

Author Comment

by:mikeleahy
ID: 21917849
the pots are ethernet ports !!!! nothing to do with fibre
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21918547
Hi

try also to plug your laptop to uplink ports in order to get leds blinking.
if you are successful with laptop, try using crossover cable.
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21920091
well Cisco makes modular ports that are combo ports (fiber or copper) and In your previous post, you mentioend they were interconnected via fiber.  So i was just making sure i understood your physical hareware before making any recommendations.

So I understand you have 2 switches interconnected via gig copper and you can not get link.  

Did you check the interfaces to see what state they may be in?

issue the command: show interface status

and look for the uplinks between the 2 switches on both sides and check status

You may want to also issue command:
show interface gig 0/1 (or what ever interface it is) and check line and link

what kind of cable are between the 2?  If its cat5 you will have problems with gig over copper.  Need cat5e or better.  What cabling standard on both ends? T568A T568B?
0
 

Author Comment

by:mikeleahy
ID: 21923596
cables are cat5e or cat 6

i have 2 switches connected by straigth thru cable to trunk ports. no shutdown has been issued etc. i have put in the command to allow all vlans through the trunk port but when i go sh int gig 0/48 trunk

it says none for all the trunk information being passed over links etc
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21923650
hmm...
I'm confused right now.
can you describe your problem now?
have you managed to connect switches with crossover?
0
 

Author Comment

by:mikeleahy
ID: 21923886
ok. i have two gig switches. port 47 on switch 1 is connected to port 48 on switch 2. both are configured as trunk ports allowing all vlans. if i open a console session to switch 1i cant ping switch the vlan IP of switch 2 and vice versa?
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21923909
ok, can you provide the following:
show int gi0/47 and int gi0/48
show run  from both switches

0
 

Author Comment

by:mikeleahy
ID: 21924046
ok switch ones config and sh int are here.

Barrys1#sh run              
Building configuration...                        

Current configuration : 3360 bytes                                  
!
version 12.2            
no service pad              
service timestamps debug uptime                              
service timestamps log uptime                            
no service password-encryption                              
!
hostname Barrys1                
!
enable secret 5 $1$fcZd$rLJ9sTShmUakAPF4R98kH/                                              
enable password Pyramid2                        
!
no aaa new-model                
system mtu routing 1500                      
ip subnet-zero              
!
!
!
!
no file verify auto                  
spanning-tree mode pvst                      
spanning-tree extend system-id                              
!
vlan internal allocation policy ascending                                        
!
interface GigabitEthernet0/1                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/2                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/3                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/4                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/5                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/6                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/7                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/8                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/9                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/10                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/11                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/12                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/13                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/14                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/15                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/16                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/17                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/18                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/19                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/20                            
 spanning-tree portfas                    
!
interface GigabitEthernet0/21                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/22                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/23                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/24                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/25                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/26                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/27                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/28                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/29                            
 spanning-tree portfast                      
!
interface GigabitEth                  
 spanning-tree portfast                      
!
interface GigabitEthernet0/31                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/32                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/33                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/34                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/35                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/36                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/37                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/38                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/39                            
 spanning-tree portfas                    
!
interface GigabitEthernet0/40                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/41                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/42                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/43                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/44                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/45                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/46                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/47                            
 description Connection to Switch 5                                  
 switchport mode trunk                      
!
interface GigabitEthernet0/48
 description Connection to Barrys2
 switchport mode trunk
!
interface Vlan1
 ip address 193.1.200.194 255.255.255.0
 no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
 password Pyramid1
 login
line vty 5 15
 password Pyramid1
 login
!
end





Barrys1#sh int gigabitEthernet 0/48                                  
GigabitEthernet0/48 is down, line protocol is down (notconnect)                                                              
  Hardware is Gigabit Ethernet, address is 001f.2730.67b0 (bia 001f.2730.67b0)                                                                              
  Description: Connection to Barrys2                                    
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,                                              
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex, Auto-speed, link type is auto, media type is Not Present
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


here is switch 2

Barrys2#sh run              
Building configuration...                        

Current configuration : 3360 bytes                                  
!
version 12.2            
no service pad              
service timestamps debug uptime                              
service timestamps log uptime                            
no service password-encryption                              
!
hostname Barrys2                
!
enable secret 5 $1$VAKo$kFzSyojbc.lcIiOxMoyzi.                                              
enable password Pyramid2                        
!
no aaa new-model                
system mtu routing 1500                      
ip subnet-zero              
!
!
!
!
no file verify auto                  
spanning-tree mode pvst                      
spanning-tree extend system-id                              
!
vlan internal allocation policy ascending                                        
!
interface GigabitEthernet0/1                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/2                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/3                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/4                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/5                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/6                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/7                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/8                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/9                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/10                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/11                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/12                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/13                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/14                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/15                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/16                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/17                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/18                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/19                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/20                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/21                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/22                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/23                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/24                            
 spanning-tree portfast                      
!
interface GigabitEther                    
 spanning-tree portfast                      
!
interface GigabitEthernet0/26                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/27                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/28                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/29                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/30                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/31                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/32                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/33                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/34                            
 spanning-tree portfas                    
!
interface GigabitEthernet0/35                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/36                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/37                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/38                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/39                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/40                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/41                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/42                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/43                            
 spanning-tree portfast                      
!
interface GigabitEth                  
 spanning-tree portfast                      
!
interface GigabitEthernet0/45                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/46                            
 spanning-tree portfast                      
!
interface GigabitEthernet0/47                            
 description Connection to Barrys1                                  
 switchport mode trunk                      
!
interface GigabitEthernet0/48
 description Connection to Barrys 3
 switchport mode trunk
!
interface Vlan1
 ip address 193.1.200.195 255.255.255.0
 no ip route-cache
!
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
 password Pyramid1
 login
line vty 5 15
 password Pyramid1
 login
!
end

Barrys2#     sh int gig                      
Barrys2#     sh int gigabitEthernet 0/47                                        
GigabitEthernet0/47 is down, line protocol is down (notconnect)                                                              
  Hardware is Gigabit Ethernet, address is 0021.5610.4e2f (bia 0021.5610.4e2f)                                                                              
  Description: Connection to Barrys1                                    
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,                                              
     reliability 255/255, txload 1/255, rxload 1/255                            
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex, Auto-speed, link type is auto, media type is Not Present
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Barrys2#


port 48 on switch one is connected to port 47 on switch 2
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21924159
have you tried to connect both switches with crossover?
configs look fine, however I would not recommend using real IPs for management
0
 

Author Comment

by:mikeleahy
ID: 21924290
havent tried with crossover, this switches are brand new, i thought it wall all straight thru now. how do you mean REAL IPs for mgt/
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21924406
please check the connectivity with a crossover cable

as for real ips - i mean internet route-able. I would suggest using private addresses like 172.16.0.0/12, 192.168.0.0/16 or 10.0.0.0/8
0
 

Author Comment

by:mikeleahy
ID: 21924485
oh yeah i know that .dont get me started. i took over this job 12 months ago and the whole company is using 193.1.200.x addresses. why it was setup that way i have no idea. ill check with a cross over cable and get back to you
0
 

Author Comment

by:mikeleahy
ID: 21925355
no good with a crossover cable. when i log into the switch 2 by console cable i cant even ping 193.1.200.195 which is its own mgt ip. i presume it should pint this??
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21925842
ok, let's clarify some things.
when you connect the switches, do you see, that both ports are up and running?

you should see in show log:
that port is up
that vlan1 is up

if ports are down, i suppose you are dealing with cabling problem
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21926580
the port can be in a err disabled state which would cause this.   Have you tried to issue the command
show interface status?  This will provide the status of all interfaces.  Its also not best practice in a enterprise solution to use the default VLAN 1.

Try plugging in a your laptop direct to interface GigabitEthernet0/48
with both cross and straight cable to see if you can get a link.  If you do not get a link then the interface is not running. I would do a shut no shut on both sides but shold check the status of the interface first.

Some Cisco switches set the encapsulation to dot1q automatically as they do not support both ISL and dot1q so i would specify that in the config.  Below are how my trunks are configured on a 3560G-24TS-S

 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 3,4
 switchport mode trunk
0
 

Author Comment

by:mikeleahy
ID: 21926683
vlan1 only comes up when i cable two normal ports together  , when i connect the trunk ports i get no lights and vlan1 goes down
0
 
LVL 21

Accepted Solution

by:
from_exp earned 500 total points
ID: 21927530
hi
I think, i got your problem
for uplink interfaces, issue:
media-type rj45
0
 

Author Comment

by:mikeleahy
ID: 21931749
i will try this later and let you know
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21931832
I suppose this really should help.
I have faced similar problem with 3750 with combo ports some time ago.
0
 

Author Comment

by:mikeleahy
ID: 21933111
full marks to from_exp

working fine thanks
0
 

Author Comment

by:mikeleahy
ID: 21933336
i have one issue. it will only work with cat 5 cables, not cat53 or cat 6. why is this and will it affect anything?
0
 

Author Comment

by:mikeleahy
ID: 21933352
actually it has nothing to do with the media type command. its the cat 5 3 and cat6 that wont work
0
 
LVL 21

Expert Comment

by:from_exp
ID: 21934532
rather strange actually, cat6 is not much better than cat 5.
the difference is in shielding.
however it is possible, that shielded jacks are bigger and not all contacts are connected...
0
 
LVL 3

Expert Comment

by:RTh0037
ID: 21935717
The difference is more then just the shielding.  Cat5 is not rated for gig etherent as i mentioned in my last post and you may have problems with that.  If bandwidth requirement is low and applications are not mission critical you could give it a try and see how it makes out.  If you have problems, you may want to investigate further.

Is there any thing between these devices in regards to 110 blocks, patch panels a mix of different cable types?  You may want rule out as much cabling as possible and try to cable direct
0
 

Author Comment

by:mikeleahy
ID: 21943360
the switches are sitting on top of each other on my desk. they are connected directly. if i daisy chain them it will work with cat 5e or cat 6 no problem. but with trunk ports they will only work with cat 5. and when i go show int gig 0/xx then it shows that the trunk ports are connected at 1gbps
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Nexus and catalyst 2 34
Enterasys QoS setup 2 34
Best sims for HP switches 4 30
EIGRP on point-to-point vlan 14 24
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
I eventually solved a perplexing problem setting up telnet for a new switch.  I installed a new Cisco WS-03560X-24P switch connected to an existing Cisco 4506 running a WS-X4013-10GE Sup II-Plus. After configuring vlans and trunking,  I could no…
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now