• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 686
  • Last Modified:

XP computers very slow loading desktop when logging into domain

I have roughly 50 computers joined to my domain all running Win XP SP2.  The Dell hardware is all fairly new (duo-core processors 1-2GB memory, etc).  Domain is Windows Server 2000 environment with 2 domain controllers, the primary handling DNS and DHCP traffic.

When any user from almost any computer logs into the domain, the desktop background will appear but it takes up to 2-3 minutes for the icons to appear.  The only login script I have is a simple net use map drives that are all available through a gigabit based LAN.

Once the desktop finally loads, everything runs great.  I checked msconfig and disabled some random startup items.  We have Symantec endpoint protection loading at startup but I've disabled that for testing and they still load slow.  Also, it is not every single computer every single time.  The slow load seems to be intermittent and I can't seem to pinpoint any startup services that may be causing it.  Sometimes the desktop will load almost instantly.

Seems to me that it may be the way computers authenticate with the domain controllers, but that area is a little above my head.   Any troubleshooting ideas would be much appreciated.

Thanks,

Kevin
0
KevinITadmin
Asked:
KevinITadmin
1 Solution
 
alikaz3Commented:
I had this problem, and to fix it on most machines, I made links to my domain name, and to the DC, in my HOSTS file on all workstations. My theory was that dns was not resolving the IP of the server, because the LAN card was not online/ready, at the point that the dns request is sent out. I came up with this idea after observing weird activity with the LAN card upon boot. I would log in, wait the 2-3 minutes it took, then once I saw the desktop and taskbar, I would get the "limited or no connectivity" for a split second, then it would right itself. Adding the HOSTS file entries completely wiped this out.

I would also like to note that I did replace our server, and one machine was overlooked in the remove/rejoin process. This made that computer also get the long lag (even longer, 5-10 mins) upon login. The HOSTS file did not help. I then found on the server security logs that there were trust account errors showing up for that machine. Removal/rejoin of the computer to the domain fixed the issue. All my workstations login in less than 15 secs now.
0
 
KevinITadminAuthor Commented:
Sounds like it is worth a try.  Can you please provide instructions on what/how to edit my host file?
0
 
Nyah247Commented:
I also had this problem and it was resolved by restarting the domain controller off-hours.  When was the last restart?

Do you have any group policy errors on the clients?

Is IPSEC or Auto Enrollment enabled with a GP?

Is DNS correctly resolving the DCs and is the client's DNS info correct on your DNS servers?

Any errors on the DCs?  Are they replicating properly?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
alikaz3Commented:
the HOSTS file is locatd:

c:\windows\system32\drivers\etc\hosts

note that the file has no extension, open it with notepad. Once you have it open, notice the localhost link on the bottom. You want to add entries just like that, each on their own line, but don't mess with the localhost line. After localhost, type in your domain name, and the primary DC's IP instead of 127.0.0.1 with. Do this on another line, with the server's name this time instead of the domain's name. If you have more servers on your network, add them as well, with their corresponding IPs.
0
 
alikaz3Commented:
should look like this:

# Copyright (c) 1993-1999 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

127.0.0.1       localhost
192.168.1.2     domainname.local
192.168.1.2     server1
192.168.1.3     printserver
0
 
alikaz3Commented:
Oh BTW adding the other servers is totally optional, but I figure if you are going to do this on all workstations, might as well add it. It may shave some time off file sharing delays/printing delays.
0
 
bkdragon23Commented:
One other possibility:  I would check the user profiles and see if you have roaming profiles set up on the server. This slowed my network down to a crawl during boot, but once it was up on the network, things worked great.  Shutting down also took forever.  Not to mention I am running a Gigabit network, so if one were to use them on a 10/100 network, I could only imagine how slow it would be.  Hope this helps!
0
 
alikaz3Commented:
Good call bkdragon, roming profiles of large size REALLY bog the server I/O.
0
 
KevinITadminAuthor Commented:
We are not using roaming profiles at all, I've had bad experiences in the past with them.  I've edited my HOSTS file on a few computers that I will be monitoring over the next few days.  I will post feedback when I know more.

Thanks for the replies.
0
 
alikaz3Commented:
No prob we'll stay tuned in
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now