Solved

Disappearing Optical Drive CD/DVD

Posted on 2008-06-18
10
1,188 Views
Last Modified: 2013-11-17
I have a Toshiba laptop (A105-S4211) with a missing optical drive.  I followed the instructions for removing upperfilters and lower filters and voila, the drive reappeared after I restarted the computer.  On the next restart it was gone again.  I opened the registry and viewed the settings again to make sure I had followed it properly and I did.  Next reboot, there it was.  Puzzling.  After further reading I found other references to similar problems and tried those solutions such as removing and reinstalling any CD/DVD applications (Sonic RecordNow!, WinDVD, etc..) and reinstalling them and every time I would make a significant change to the computer the optical drive would reappear but on the next restart it would be missing again.  I then remove the device from the device manager and again it reappeared after windows redetected it and reinstall it.  Sure enough on the next restart it's gone again.  I also discovered that even when the CD/DVD drive is present Sonic RecordNow says it cannot find any compatible devices.  Lastly, just to make sure you're aware of this, I did test to make sure when the drive is visible in My Computer that it reads CD's and it does so I don't believe the drive has malfunctioned.
0
Comment
Question by:axp275
  • 5
  • 4
10 Comments
 
LVL 39

Expert Comment

by:PUNKY
ID: 21819190
Try to remove all dvd/cd software and see if the problem gone?
0
 
LVL 92

Accepted Solution

by:
nobus earned 250 total points
ID: 21820276
it can be due to several things : a bad cd drive, or a corrupt OS
you can try running from alive cd, or installing another OS in a separate partition to test :
ftp://ftp.uni-kl.de/pub/linux/knoppix/KNOPPIX_V5.1.0CD-2006-12-30-EN.iso

post back what you want to do..
0
 

Author Comment

by:axp275
ID: 21820588
Only problem with reloading OS is that the operating system CD's were not created and the RDC.EXE (Recovery Disk Creator) is part of the Sonic RecordNow! software which I did uninstall (I removed all CD/DVD related software including WMP) and now the Recovery Disc's can't be created unless I can get that file reinstalled properly.  I tried copying it from another Toshiba Laptop (similar model) to no avail.  I agree that an OS reload would probably solve it but I'm positive the drive is working from a read standpoint (DVD and CD) when it shows up.  If you re-read my original message if I remove something or make any significant enough system changes and restart the CD drive will show up in My Computer and will read CD's without any problem.  Restart again and it's gone.  I was hoping there might be a way to resolve this without reloading the OS because all other functions of the machine are working fine and performance is good.
0
ScreenConnect 6.0 Free Trial

Check out the updates in one game-changing release, ScreenConnect 6.0, based on partner feedback. New features include a redesigned UI that improves session organization and overall user experience. See the enhancements for yourself!

 
LVL 92

Expert Comment

by:nobus
ID: 21821015
you do NOT need to install the same OS, you can try win98, ME win2000, XP, vista in a separate partition - without wiping the actual OS
or try the live cd.
0
 

Author Comment

by:axp275
ID: 21829484
I am aware of using a live CD but since I was able to read CD's w/o any difficulty (when the drive actually appears in explorer) I didn't think booting from a live CD was going to provide much more than confirmation of what I already know.  I don't have any SPARE partitions (and most consumer PC's don't have one) so that suggestion is sorta pointless, but, I did use one of my Ubuntu Linux live CD's and it does boot and it does read and yada yada yada, and my problem still exists.  No recovery CD because now the Sonic RecordNow has been removed along with the RDC (recovery disc creator) file.  I was hoping someone had some idea how to FIX IT w/o reloading the OS.  Anyone else have a clue how to fix this?  TIA
0
 
LVL 92

Expert Comment

by:nobus
ID: 21829785
>>   I don't have any SPARE partitions (and most consumer PC's don't have one) so that suggestion is sorta pointless  <<   No, it is not; you can always make other partitions and  install another software on it

What os is this ? XP, or vista ?
also it can be due to  the sony software that had some time ago a kind of rootkit in it :
http://en.wikipedia.org/wiki/2005_Sony_BMG_CD_copy_protection_scandal
http://www.mgshareware.com/community/index.php?topic=524.msg2434
for rootkits : http://technet.microsoft.com/en-us/sysinternals/bb897445.aspx
0
 

Author Comment

by:axp275
ID: 21946690
I reloaded the OS (XP Home Ed) and didn't change anything and it still comes and goes.  I looked for firmware updates for the DVR-K16A super multi drive and for the computers BIOS and didn't find any firmware updates or any BIOS updates that indicated any fixes related to this problem.  I'm getting a new drive to see if that fixes it.  It's the only thing I can think of that makes sense.  Thanks to all who tried to help on this one.
0
 
LVL 92

Expert Comment

by:nobus
ID: 21951289
as  i suggested in my first post also
0
 

Author Comment

by:axp275
ID: 21951760
I didn't want to spend $150 on a new drive if another solution was available and I wasn't convinced the drive was bad because when it appeared, it worked.  Your original post was nothing more than an educated guess which I had already surmised was one of the choices.  The last one obviously.  I appreciated the suggestions none-the-less.  The fact that it boots ubuntu, XP, etc... was puzzling, which led me to look for something other than a hardware malfunction.  I solidified the problem by tracking down another laptop with a compatible drive and tested it and it never disappeared.  This is the first time I've ever seen this behavior.  Something learned. :)
0
 

Author Closing Comment

by:axp275
ID: 31468491
Thanks for responding to my request for assistance.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Laptops screen 6 77
Compromised PC? 17 219
New battery will not charge 100% 8 58
BIOS update failed, laptop dead. Any options to revive the system? 19 78
I recently purchased an HP EliteBook 2540p notebook/laptop. It has two video ports on it – VGA and DisplayPort. HP offers an optional docking station for the 2540p that also has both a VGA port and a DisplayPort. There are numerous online reports do…
The Samsung SSD 840 EVO and 840 EVO mSATA have a well-known problem with a drop in read performance. I first learned about this in an interesting thread here at Experts Exchange: http://www.experts-exchange.com/Hardware/Storage/Hard_Drives/Q_2852…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question