Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2293
  • Last Modified:

Padding for tables in report ignored

Hi.

I'm experiencing a frustrating problem with SSRS.

I have a SSRS report with several tables, each one butting up one on
top of the other with no white space between them in the designer.
Most of these tables have an expression for their Visibility property
that determines whether the text and data within the table is shown
when the report renders.  This is to create a report with sometimes-
there-sometimes-not data elements.  This part works fine.

The problem is my settings for the tables' Padding properties are
being ignored.  I can set the Bottom Padding for a table to 100pt and
when the report renders, there's no padding; it's like it's ignored
completely.  I can set a table to page break, that's working, but I
can't add padding to make the report look better.

Please advise and thanks.
0
query_squidier
Asked:
query_squidier
  • 3
  • 2
1 Solution
 
YurichCommented:
Try putting your tables into rectangles and toggling visibility of the rectangles. You can have a rectangle bigger than a table, but it will not render if it's not visible. May work just fine; I can't check it any earlier than tomorrow morning (that's about in 15-16 hours here).

Cheers,
Yurich
0
 
query_squidierAuthor Commented:
I created a rectangle and dropped one of the tables into it.  I made the width of the rectangle the same as the table but added some whtie space at the bottom of the rectangle until the rectangle butts up against the top of the next table.

I played with the visibility of the rectangle and, while setting its Hidden property to True does indeed cause the rectangle and its contained table not to be rendered, the space for the rectangle is still taken.  So the report ends up with a big blank spot where the rectangle and table would've been.

Any ideas?
0
 
YurichCommented:
:(,

I'll create a test report and see if I can figure out something...
0
 
YurichCommented:
OK :) figured out.

Drop a table on your report. Remove details and footer of this table and leave only the header. Add enough rows to your header to have one for each of your tables. Drop your tables INTO the header rows of the table you just created (each table into a separate row). You then can set visibility of the rows of this table. The gap between tables can be set with the footer of your inner tables and when they're not visible, you won't have then taking any space up. Ant that's exactly what you want.

There is a chance of having it done without an outer table, but just with manipulating extra rows in footer, but I didn't check that as the one above will work for sure and it's not very hard to do.

Good luck,
Yurich
0
 
query_squidierAuthor Commented:
That sounds nearly crazy enough to work.  I'll give it a go.  If it works I'll Accept the Solution.

Thanks for your effort, Yurich.
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now