Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

DVD Playback is black & white (with hint of blue) not full colour

Posted on 2008-06-18
10
Medium Priority
?
1,293 Views
Last Modified: 2012-05-05
I had a number of problems getting some video files to play in full colour and after raising a question (http://www.experts-exchange.com/Apple/Software/Q_23484778.html) I eventually solved it by turning of DirectD in Quicktime.
I haven't played DVDs for a while, last time I played them they were fine (full colour) but playing them now they look the same as the videos did (black and white with a hint of blue, but no other colours).
Alas system restore wasn't turned on on the machine (it is now) so I can't go back to see if recent codecs etc have caused this.
I had a number of codec packs, but I have uninstalled them all and now just have the Vista Codec Pack (4.7) installed but nothing else.  Uninstalling all my codecs and reinstalling just Vista Codec Pack didn't change the black & white DVD playback problem.
Any suggestions about how to fix this?
0
Comment
Question by:hedgert
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 5

Expert Comment

by:manferg
ID: 21817020
0
 
LVL 1

Author Comment

by:hedgert
ID: 21817732
I think it has to be a codec issue.  I've tried changing saturation but that has no effect.  I can't change hardware acceleration - the NVIDIA driver doesn't allow it.

Everything is full colour except when playing DVDs - which with all players are B&W - but with all players plenty of other video files play perfectly.

I tried ripping the DVD to disk and then viewing it using FFplay and then it plays in full colour.

So I think it has to be a codec that somehow FFplay uses but the other players don't.  But I can't find any information on the codecs that FFplay uses.
0
 
LVL 8

Expert Comment

by:tonsofpcs
ID: 21818354
What software are you using to play the dvd?  It is likely using directdraw, if you can't figure out how to change this, might I suggest using VLC or Media Player Classic to play the DVD.  
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 1

Author Comment

by:hedgert
ID: 21819551
Every media player I have found has the same problem.  I have tried Windows Media Centre, Windows Media Player, VLC, Media Player Classic, all have the issue of black & white playback.

The only way I have found of playing in full colour is to rip the dvd and then play with FFplay, which is hardly convenient!
0
 
LVL 1

Expert Comment

by:safetykids
ID: 21819758
It sounds like it is something that is set when it plays a dvd, and just a dvd. Could you post the players you use/tried?
0
 
LVL 1

Author Comment

by:hedgert
ID: 21820095
Previous posts lists the players I've tried Windows Media Centre, Windows Media Player, VLC and Media Player Classic.
0
 
LVL 1

Expert Comment

by:safetykids
ID: 21820373
sorry for not seeing that. Have you tried using a clean install of the programs, as that should reset the settings back to defaults?
0
 
LVL 1

Author Comment

by:hedgert
ID: 21829325
I've taken them all off (except the ones built into Windows) and put them back on again.
I also took off Real Player completely as I'd read that could muck up other settings.  Also tried putting it back on again - no change.

My problem turns out to be wider than I had thought - it isn't just DVDs.  I'm having problems playing back some API files as well.  I have a number of APIs that I've taken with my camera that I have played perfectly before, but which now only play with colour in QuickTime (where in response to the original colour problem I mentioned above in a link in the first post I have turned off DirectShow).  In Windows Media Player, Windows Media Centre, RealPlayer, GOM Player, VLC and Media Player Classic they play in black and white (or sometime black and white with a little of one colour only).
0
 
LVL 1

Author Comment

by:hedgert
ID: 21829628
Sorry - for API files - should have read I'm having trouble playing some AVI files.
0
 
LVL 1

Accepted Solution

by:
hedgert earned 0 total points
ID: 21841026
I have solved the problem by rolling back my NVIDIA display driver.  I hadn't consciously updated it, having had a lot of trouble finding a version that worked properly with my HDMI connected LCD TV.  However, I had HP update turned on and I think that had installed an updated version of the driver with some kind of colour issue in it.  Having rolled back the display driver DVD playing is back to full colour as are the AVI files I had taken with my digital camera and previously played successfully in colour.
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Keep your audience engaged and get the most out of your next presentation with these quick Prezi tips.
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
The viewer will learn how to search for and apply Apple Loops, as well as create their own in Logic Pro X. Record a region in the tracks area: Select the region: Go to File > Export > Region to Loop Library: Select the appropriate search terms…
Viewers will learn the basics of creating custom device Racks in Ableton Live. Place instrument(s) and effects onto a track, and select them all by holding the Shift key and clicking on the device title bars: Group them by typing Command-G (Ctrl-G…

609 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question