Solved

Upstream on new T3/DS3 maxes out at 250kbps per connection... but still able to have concurrent connections all maxing out at 250kbps.

Posted on 2008-06-18
12
563 Views
Last Modified: 2012-08-14
We just had a T3/DS3 full 45mbps data line turned up in our organization. It is an XO circuit coming in on Verizon's last mile. Verizon's MUX provides a BNC hand off, and the BNC cable is running into my Cisco 7204 with a DS3/T3 module. The Cisco then sends all traffic out the FastEthernet port 0, which goes into my firewall.

When XO was doing final testing before turning up the circuit, everything checked out 100% alright and no data loss was detected indicating the physical connections are all good between me and them. However, after doing speed tests I was able to obtain about a 40mbps downstream but could never obtain anything higher than 14mbps upstream. I opened a trouble ticket with XO, who did intrusive tests to find nothing wrong.

I setup a test system which bypassed the firewall, which provided no improvement.

I did some troubleshooting with a tech from XO yesterday. Of course his line speed matched mine. I placed a 200MB file in a FTP location on my network for him to download. The transfer speed maxed out on average of 250kbps. He initiated five more concurrent transfers for a total of six downloads happening simultaneously. All six download speeds were at 250kbps.

So this tells me some interesting information... the entire bandwidth of my T3 seems to work, but no one can initiate a transfer greater than 250kbps for any single connection when pulling files from us. They are thinking that it has something to do with my router configuration, but nothing in the Cisco is configured to partition bandwidth like that. Does anyone have any ideas or suggestions? I'm stumped on this one. I've included my router's show run, show ver, and show ip interface for both the FastE and Serial ports.
Cisco7204#show ver
Cisco IOS Software, 7200 Software (C7200-IPBASEK9-M), Version 12.4(15)T1, RELEAS
E SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Wed 18-Jul-07 13:29 by prod_rel_team
 
ROM: System Bootstrap, Version 12.2(4r)B, RELEASE SOFTWARE (fc1)
BOOTLDR: 7200 Software (C7200-KBOOT-M), Version 12.2(15)T10,  RELEASE SOFTWARE (
fc2)
 
Cisco7204 uptime is 1 week, 6 days, 3 hours, 18 minutes
System returned to ROM by reload at 11:20:43 UTC Wed Jun 4 2008
System restarted at 15:13:40 UTC Wed Jun 4 2008
System image file is "disk0:c7200-ipbasek9-mz.124-15.T1.bin"
Last reload reason: Reload Command
 
 
 
This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.
 
A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html
 
If you require further assistance please contact us by sending email to
export@cisco.com.
 
Cisco 7204VXR (NPE400) processor (revision A) with 114688K/16384K bytes of memor
y.
Processor board ID 30506849
R7000 CPU at 350MHz, Implementation 39, Rev 3.3, 256KB L2 Cache
4 slot VXR midplane, Version 2.8
 
Last reset from power-on
 
PCI bus mb0_mb1 (Slots 0, 1, 3 and 5) has a capacity of 600 bandwidth points.
Current configuration on bus mb0_mb1 has a total of 400 bandwidth points.
This configuration is within the PCI bus capacity and is supported.
 
PCI bus mb2 (Slots 2, 4, 6) has a capacity of 600 bandwidth points.
Current configuration on bus mb2 has a total of 100 bandwidth points
This configuration is within the PCI bus capacity and is supported.
 
Please refer to the following document "Cisco 7200 Series Port Adaptor
Hardware Configuration Guidelines" on Cisco.com <http://www.cisco.com>
for c7200 bandwidth points oversubscription and usage guidelines.
 
 
2 FastEthernet interfaces
1 Serial interface
125K bytes of NVRAM.
 
47040K bytes of ATA PCMCIA card at slot 0 (Sector size 512 bytes).
8192K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102
 
Cisco7204#
 
 
 
 
 
 
Cisco7204#show ip interface Serial 2/0
Serial2/0 is up, line protocol is up
  Internet address is XXX.XXX.XXX.XXX/30
  Broadcast address is 255.255.255.255
  Address determined by non-volatile memory
  Peer address is XXX.XXX.XXX.XXX
  MTU is 4470 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP fast switching on the same interface is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP Fast switching turbo vector
  IP Normal CEF switching turbo vector
  IP multicast fast switching is disabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
Cisco7204#
 
 
 
Cisco7204#show interface fa 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is i82543 (Livengood), address **removed for Experts-Exchange**
  Internet address is XXX.XXX.XXX.XXX/28
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 4/255, rxload 2/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 150
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1062000 bits/sec, 170 packets/sec
  5 minute output rate 1869000 bits/sec, 190 packets/sec
     75118543 packets input, 1196001574 bytes
     Received 53260 broadcasts, 0 runts, 0 giants, 7 throttles
     45 input errors, 0 CRC, 0 frame, 0 overrun, 45 ignored
     0 watchdog
     0 input packets with dribble condition detected
     68641951 packets output, 2904433628 bytes, 0 underruns
     8 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     8 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cisco7204#
 
 
 
 
Cisco7204#show run
Building configuration...
 
Current configuration : 1166 bytes
!
! NVRAM config last updated at 14:05:14 UTC Fri Jun 6 2008
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco7204
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jEkL$ENwRVNYUuM9HUtLPuDWSp.
enable password **removed for Experts-Exchange**
!
no aaa new-model
ip cef
!
!
!
!
ip name-server XXX.XXX.XXX.XXX
ip name-server XXX.XXX.XXX.XXX
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
 ip address XXX.XXX.XXX.XXX 255.255.255.240
 duplex auto
 speed auto
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address XXX.XXX.XXX.XXX 255.255.255.252
 encapsulation ppp
 dsu bandwidth 44210
 framing c-bit
 cablelength 4
 serial restart-delay 0
!
ip default-gateway XXX.XXX.XXX.XXX
ip route 0.0.0.0 0.0.0.0 Serial2/0
no ip http server
no ip http secure-server
!
!
logging alarm informational
!
!
!
control-plane
!
!
!
!
!
!
gatekeeper
 shutdown
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 password **removed for Experts-Exchange**
 login
!
!
end
 
Cisco7204#

Open in new window

0
Comment
Question by:alan2938
12 Comments
 
LVL 6

Expert Comment

by:raptorjb007
ID: 21817532
Your config looks pretty basic to me, nothing that would limit outbound traffic to 14mbs. The FTP 250KBs ftp download limit however sounds like there may be a rate limit set on the FTP server.
0
 
LVL 1

Author Comment

by:alan2938
ID: 21817547
No, the tech from XO was downloading from me, meaning that I am uploading the file to him. It's my upstream that's effected, not the downstream.
0
 
LVL 6

Expert Comment

by:raptorjb007
ID: 21817620
Yes, but you host the FTP server and many FTP servers can apply a rate limit per connection. I'm not saying that is the case here, but it certainly possible. It would explain why each ftp download from your ftp server to the XO tech is limited at the same rate of 250KBs.

Your config is proper as far as I can tell, nothing that would limit your upstream to 14mbs.
0
Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

 
LVL 1

Author Comment

by:alan2938
ID: 21817637
I understand what you are saying. I figured this is the same problem since I get the same rate of about 10-14kbps on upload tests no matter which online test I use or from what desktop or server machine. We were just using an FTP connection since it was the easiest way to directly transfer an extremely large file from my network to his.
0
 
LVL 6

Expert Comment

by:raptorjb007
ID: 21834138
Have you checked the physical links or layer 2 devices between the router and client device, in this case the ftp server?
0
 
LVL 6

Accepted Solution

by:
raptorjb007 earned 500 total points
ID: 21834452
If there is nothing wrong with the cabling or layer 2 connections, as I suspect there isn't. Most likely the next step would be to get an ISP engineer on-site with a data tester, however that is not usually a fast process, especially since XO does not always own the line and has to go through a telecomm for this.
0
 
LVL 1

Author Comment

by:alan2938
ID: 21834559
Ya, all cables and layer connections are fine. The last mile is owned by Verizon, so I know this won't get resolved quickly if we are waiting on their techs to come out. On Monday XO will research how to get a more accurate speed test. Apparently they have no current method of doing an accurate speed test.
0
 

Expert Comment

by:stielinc
ID: 21848049
Please post what you find, Im having a similiar issue with a DS3....consistent 40Mbps down, 25 up.  Checked everything I could think of, finding no issues.
0
 
LVL 1

Author Comment

by:alan2938
ID: 21946833
I eliminated all possible causes of slowdown on my end and am now on hold with several VP's of Airespring and XO to try and figure out what's going on. They tell me these speeds are normal for my area (Midtown Manhattan). If this is what we're stuck with we will have to modify our contract accordingly to reflect the actual bandwidth available to us.
0
 
LVL 1

Author Comment

by:alan2938
ID: 22113903
It is like pulling teeth to get XO to do further testing. I am staying on top of this and will post the solution once I find one, but I will close this question and award points to those who have contributed.
0
 
LVL 2

Expert Comment

by:Paresh Patel
ID: 22834887
Have you involved Verizon?  We ahve three separate DS-3's, two going to different locations in Illinois and one in Valhalla, NY.  When we try FTP from Valhalla to location close by, we get about 20 Mbps.  The same stands for both locations in Illinois.   BUT, when we try to FTP the same file between Valhall and any of Illinois locations, transfer rates fall to between 4.5 mto 5.5 Mbps.   The same over Level-3 or Sprint yields about 35 Mbps.  It seems that Verizon is rate-limiting traffice in their backbone.
0
 
LVL 1

Author Comment

by:alan2938
ID: 22835250
Verizon came out to physically test the connectivity on their line but never speed a speed test. Verizon themselves just owns the last mile, so if this is the problem they didn't accurately test for it. Any idea how to get them to take some ownership over this?
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Guest Wi-Fi Time out 3 28
Cisco ASA 5512-X Active/Standby HA 4 28
EIGRP Bandwidth 9 21
Configure BGP 22 14
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question