Solved

how to deploy classic ASP on XP with IIS 5.1

Posted on 2008-06-18
24
2,226 Views
Last Modified: 2009-04-01
Hi,

I have old classic ASP pages set up and run fine on the test server.  I want to bring the ASP pages down to my local machine and set it up to run.  Can someone tell me how to set up classic ASP pages on IIS 5.1?

Thanks,
OneCorner.
0
Comment
Question by:OneCorner
  • 12
  • 9
  • 3
24 Comments
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21818361
IIS 5.1 should support classic ASP natively i.e. installing it from Add/Remove Windows Components will make ASP available.

http://www.microsoft.com/windowsxp/evaluation/features/iis.mspx
0
 

Author Comment

by:OneCorner
ID: 21818587
I already have IIS 5.1 installed and set up.  I am asking if someone can tell step by step how to create a web site in IIS
0
 
LVL 36

Expert Comment

by:Loganathan Natarajan
ID: 21820258
0
 
LVL 36

Expert Comment

by:Loganathan Natarajan
ID: 21820266
0
 
LVL 36

Expert Comment

by:Loganathan Natarajan
ID: 21820269
0
 

Author Comment

by:OneCorner
ID: 21841977
I went thru all the links you recomemded above.  However,  It is still not working.  
0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21842644
Ok, what exactly is not working?

Once you have installed IIS (without modifying the website settings within IIS admin), you get an Inetpub folder, within which is wwwroot.  The wwwroot folder is basically the root of your website.  Within here you can put asp and html files, and then browse to them in your web-browser using http://localhost/file.htm (in this case, file.htm would be located in the wwwroot folder).

ASP files should be processed automatically as ASP, you don't need to configure this.

Please elaborate on the exact problem you have.
0
 

Author Comment

by:OneCorner
ID: 21851756
This is what and why it is not working.

1) On the Windows 2003 server, we have IIS 6.0.  In the virtual directory where all the ASP pages live, it is called c:\inetpub\wwwroot\ASP_Pages\lib1\asp_page1_lib1.asp,
..\..\ASP_Pages\lib1\OpenConn.inc,....so on and ...
2) In the .asp, .inc and .fnc files, these files were referencing to as follows:
<!-- #include virtual = "lib1/OpenConn.inc" -->
<!-- #include virtual = "lib1/CommonFunctions.inc" -->
<!--#include virtual = "lib2/SessionConfirm.inc" -->
<!--#include virtual = "lib2/Transactions_new.fnc" -->
<!--#include virtual = "lib3/Products.fnc" -->

3) In the IIS 6.0, I created a new website and pointed to the cirtual directory, c:\inetpub\wwwroot\ASP_Pages.

Everything work just fine.  However, when I copy the ASP_Pages folder down to my laptop with XP and IIS 5.1.  I did the followings:

1) On my laptop, I copied ASP_Pages folder to c:\inetpub\wwwroot.
2) Open up the IIS 5.1, Web Sites, Default Web Sites.  The ASP_Pages folder is shown under Default Web Sites.
3) Right mouse click on the folder, Properties, Click on the "Create" button, set the "Execute Permission" to "Scripts Only", clicked on "Document" tab and set the "Default.asp" to be first.
4) Open up the IE browser and type in "http://localhost/Intralock/login.asp"
5) It displayed that the page can not be displayed.  

I did the followings to fix it:

1) In all the files with the followings, I have to add "ASP_Pages" in infront of "lib1"
<!-- #include virtual = "ASP_Pages/lib1/OpenConn.inc" -->
<!-- #include virtual = "ASP_Pages/lib1/CommonFunctions.inc" -->
<!--#include virtual = "ASP_Pages/lib2/SessionConfirm.inc" -->
<!--#include virtual = "ASP_Pages/lib2/Transactions_new.fnc" -->
<!--#include virtual = "ASP_Pages/lib3/Products.fnc" -->

WHY DO I HAVE TO ADD "ASP_Pages"?  I DO NOT WANT TO DO THIS.  THE REASON IS THAT I HAVE TO SEARCH EVERY SINGLE FILE TO INSERT "ASP_Pages" INTO.  WHAT CAN I DO TO NOT TO INSERT IT IN?

Thanks!

0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21851875
The VIRTUAL tag you are using means that the path is relative to the base folder of the website.  In your case, this appears to be c:\inetpub\wwwroot.  So the current behaviour is correct.

When you browse to http://localhost/Intralock/login.asp, you are browsing to a page in the default website - not the one you have created.  The easiest way to overcome the problem would be to change the default website root folder to c:\inetpub\wwwroot\ASP_Pages.  Or, change the port for the website you have created (e.g. make it port 81) and browse to the site including port number, e.g. http://localhost:81/Intralock/login.asp
0
 

Author Comment

by:OneCorner
ID: 21852077
In IIS 5.1, To change the port to 81 has to be done at the Default Web Sites level.  Then all the virtual directories created under the default web sites will be using port 81.  Please make me understand this.  I don't quite get it.  It is clear and easier to understand with IIS 6.0 than 5.1 to me.
0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21853790
Point 3 above, you said you create a new WEBSITE.  Did you mean virtual directory, or website?  Each website in IIS 5 or 6 can have it's own port.  Have you got more than one website, or are all your folders under the default website?
0
 

Author Comment

by:OneCorner
ID: 21856230
In IIS 6.0, I created individual web site.  In 5.1, all my folders under the default website.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 

Author Comment

by:OneCorner
ID: 21856265
By the way,  I looked into the IIS 5.1 and 6.0.  In 5.1, ti does not allow you to create individual website.  Everything is under default website.  In 6.0, you can create individual website.
0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21856720
Really?  Haven't got IIS5.1 to hand to check, but am surprised, I'm sure I've created new websites in the past - though having said this, the XP version of IIS has been limited (and I have mainly dealt with server versions), so maybe the server version is different.

If everything is under the default website, you need to ensure that the links work in relation to the site root.  In this case, it would mean changing the site root to c:\inetpub\wwwroot\ASP_Pages, as then your include links are valid.
0
 

Author Comment

by:OneCorner
ID: 21856927
You meant to say changing the site root to c:\inetpub\wwwroot\ASP_Pages at the Default website level and in the "Home Directory" tab.  If that the case, what about other folders are not belonged to ASP_Pages?  What will be their "Home Directory"?  Again all folders are under the same default website level.

0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21857375
The point I am making is that your include statements are this:
<!--#include virtual = "lib3/Products.fnc" -->

This means that the folder references (i.e. lib3) must reside in the root directory.  Which is c:\inetpub\wwwroot.  To not have to include the ASP_Pages reference, you need to either change your site root or move the lib3 etc. folders.  Either of these solutions will of course have knock on effects, as you mention.

One thing I have just looked up and checked is that IIS5.1 is ONLY available on Windows XP Pro.  The version I was thinking was the Win2k server version - but this is actually 5.0 - so there may be differences.

I will install IIS5.1 on a virtual machine when I have the time (maybe later on today) and see what options there are.  The only other solution to your problem is if you are able to specify an includes folder that IIS will look in for ASP include files.  I do not know if this is an available option, so will have to check.
0
 

Author Comment

by:OneCorner
ID: 21857621
Let me know once you have a chance to check it.  I don't think that I want to move the lib3 and other folders out to the root folder.
0
 

Author Comment

by:OneCorner
ID: 21861649
Any more ideas?  Thanks!
0
 

Author Comment

by:OneCorner
ID: 21868341

Ok! What I did was that I copied the project folder of the ASP pages in d:\inetpub\wwwroot\Test_MMS.  I then changed the home directory of the virtual path in IIS to point to d:\inetpub\wwwroot\Test_MMS instead of c:\inetpub\wwwroot.  However, it is still not working.  It is still complainning that a function file is not found, but the function file is there.
0
 

Author Comment

by:OneCorner
ID: 21868870

Good news!  I got it to work.  However, I have questions.  They are:

1) In IIS 6.0, I would be able to name the Host Header Value for each website.  How do I do that in IIS 5.1?

2) In IIS 6.0, I have to switch back and forward in the properties of the websites if I want to use the http://localhost/... for different website.  I just need to delete the "IP address: Default, TCP port:80" in the Advanced WebSite Identification(AWSI) in the Properties in one website and add the "Default 80" in AWSI in the Properties of another website.  In IIS 5.1, how would I do that?

0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21868997
Sorry for not getting back to you - still haven't managed to check on a virtual machine.  However, should be able to do that now so will post back shortly.
0
 
LVL 24

Expert Comment

by:purplepomegranite
ID: 21873064
In IIS5.1 you can add the host header value in the same way as 6.0:
- right-click default website, properties
- under website tab, click Advanced
- click Add.  You can add another (or the same) port with a different Host Header value.

This of course will still point to the same website.  To create new websites in IIS5.1 (MS have hidden the functionality from the MMS console), there is a good article here: http://andreineculau.wordpress.com/2006/01/23/multiple-websites-using-iis-51-on-windows-xp/

Once the new websites are added, you can adjust them accordingly.

2.  The same way, once you have more than one website (as opposed to just virtual directories).

I think the guide on adding more than one website above will solve most of your issues now.
0
 

Author Comment

by:OneCorner
ID: 21886551
I'll read the link to send to me regarding IIS 5.1 with multiple websites as active localhost as http://localhost/Test1/....  and http://localhost/Test2/....  .  I still don't get it how you can create multiple web sites in 5.1.  Even in IIS 6.0, I still have to switch back and forward on localhost.  

Any other ideas, please update me!  Thanks!
0
 
LVL 24

Accepted Solution

by:
purplepomegranite earned 500 total points
ID: 21886634
The link explains exactly how to create multiple websites in 5.1.  Microsoft have (in their wisdom), not enabled this facility from within the management console, but it is available (by commandline though).

You probably will have to switch back and forth though once done, as you are essentially testing to websites with the same address.  The other option would be different ports (so one is http://localhost:81/).
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Author Note: Since this E-E article was originally written, years ago, formal testing has come into common use in the world of PHP.  PHPUnit (http://en.wikipedia.org/wiki/PHPUnit) and similar technologies have enjoyed wide adoption, making it possib…
Envision that you are chipping away at another e-business site with a team of pundit developers and designers. Everything seems, by all accounts, to be going easily.
Viewers will get an overview of the benefits and risks of using Bitcoin to accept payments. What Bitcoin is: Legality: Risks: Benefits: Which businesses are best suited?: Other things you should know: How to get started:
The viewer will learn how to dynamically set the form action using jQuery.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now