?
Solved

Autodiscover service on Exchange 2007 filed from internet

Posted on 2008-06-18
5
Medium Priority
?
697 Views
Last Modified: 2008-06-19
Hi!
I'm running exchange 2007 sp1 on top of windows 2008 (SP1). I wonder why my autodiscover service is not working from outside (for non domain joined computer). Using internal Ms SAN certificate

My netbios name is mars while the fqdn is mars.stempeutics.com.my. my external name will be mail.stempeutics.com.my. I have this result when doing test-outlookwebservices : fl command from EMS
when trying connected using outlook 2007, the messsage 'outlook must be online.. etc.. etc.." and after that the excahnge dialog box "=SMTP:exch1@stempeutics.com.my"  appear
FYI, my https://mail.stempeutics.com.my/owa is working both internally and externally


Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address Administrator@stempeutics.com.my.

Id      : 1007
Type    : Information
Message : Testing server mars.stempeutics.com.my with the published name https://mars.stempeutics.com.my/EWS/Exchange.asmx & https://mail.stempeutics.com.my/EW
          S/Exchange.asmx.

Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://mars.stempeutics.com.my/autodiscover/autodiscover
          .xml.

Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://mars.stempeutics.com.my/autodiscover/autodiscover.xml.

Id      : 1016
Type    : Success
Message : [EXCH]-Successfully contacted the AS service at https://mars.stempeutics.com.my/EWS/Exchange.asmx. The elapsed time was 731 milliseconds.

Id      : 1015
Type    : Success
Message : [EXCH]-Successfully contacted the OAB service at https://mars.stempeutics.com.my/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

Id      : 1014
Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://mars.stempeutics.com.my/UnifiedMessaging/Service.asmx. The elapsed time was 780 milliseconds.

Id      : 1016
Type    : Success
Message : [EXPR]-Successfully contacted the AS service at https://mail.stempeutics.com.my/EWS/Exchange.asmx. The elapsed time was 15 milliseconds.

Id      : 1015
Type    : Success
Message : [EXPR]-Successfully contacted the OAB service at https://mail.stempeutics.com.my/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

Id      : 1014
Type    : Information
Message : [EXPR]-The UM is not configured for this user.

Id      : 1017
Type    : Success
Message : [EXPR]-Successfully contacted the RPC/HTTP service at https://mail.stempeutics.com.my/Rpc. The elapsed time was 31 milliseconds.

Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.



0
Comment
Question by:aihaiai
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
5 Comments
 
LVL 16

Accepted Solution

by:
LegendZM earned 2000 total points
ID: 21819267
AH, you said Server 2008, correct?

There is a bug, refer to this blog: http://blog.aaronmarks.com/?p=65

it will help you disable ipv6 and guide you through getting up and running with Outlook Anywhere.
0
 

Author Comment

by:aihaiai
ID: 21819736
Yes it is windows 2008. But it actually running on IPv4 only. I've disable it on tcpi/ip settings. Any way I did not read the article yet.
0
 

Author Comment

by:aihaiai
ID: 21819751
FYI, previously when running the test-outlookwebservices cmdlet it appears two errors id 1013 and id 1016 which related two my external url of EWS but i was fixed it by following the method 1 on article kb 896861
0
 

Author Comment

by:aihaiai
ID: 21819902
Yes, I was read the article but not yet doing it on my server. it seems like the diagnose part is about the same when I check it. my question now is, I've already open the port 25 and 443 only at my firewall site. do I need to open port 6001,6002 1nd 6004 as well.

Actually my problem is only when outlook2007 connecting from external. my outlook failed on the logon to the server part only. the previous two steps is OK .Internally the autodiscover service is OK
0
 

Author Comment

by:aihaiai
ID: 21819980
Thanks. It solved my problem. and confirmed that only port 443 need to be open as well as 25 for mail flow (if directly received mail from internet)
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question