Solved

can`t figure out what`s wrong with this configuration

Posted on 2008-06-19
21
399 Views
Last Modified: 2010-04-21
Hi everyone, is there someone who could take a look on the configuraitons below. We are talking about 4 routers (lab test), the primary router is R0, all another routers are connected to this router, their names are R1, R2 and R4 all these 3 routers are connected to R0. All of these routers uses OSPF.

The problem is that I can`t ping the routers (each other) I am not able to ping the routers at all, never mind from which router I try to ping, but I am almost 100 % sure that config is right. Wired......
Something I missed ? configuration is below:
______________________________________________________________
Configuration R0:

Using 2225 out of 57336 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R0_2691_SW
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$KwIe$szlJPLka0cEKyh1AHBKXt0
!
aaa new-model
!
aaa session-id common
memory-size iomem 5
ip cef
!
no ip domain lookup
!
username admin password 7 1404131F0908233F
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description TRUNK_LINK_TO_NIC
 switchport trunk allowed vlan 1,2,1002-1005
 switchport mode trunk
!
interface FastEthernet1/1
 description TRUNK_LINK_TO_R1
 switchport trunk allowed vlan 1,2,20,1002-1005
 switchport mode trunk
!
interface FastEthernet1/2
 description TRUNK_LINK_TO_R2
 switchport trunk allowed vlan 1,2,30,1002-1005
 switchport mode trunk
!
interface FastEthernet1/3
 description TRUNK_LINK_TO_R4
 switchport trunk allowed vlan 1,2,40,1002-1005
 switchport mode trunk
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 description WAN_INT_ACCESS
 ip address 10.20.14.17 255.255.255.0
!
interface Vlan20
 description LINK_TO_R1
 ip address 10.50.50.1 255.255.255.252
!
interface Vlan30
 description LINK_TO_R2
 ip address 10.50.50.5 255.255.255.252
!
interface Vlan40
 description LINK_TO_R4
 ip address 192.168.10.2 255.255.255.252
!
router ospf 1
 log-adjacency-changes detail
 redistribute connected subnets
 redistribute static metric 1 subnets
 network 10.50.50.0 0.0.0.3 area 0
 network 10.50.50.4 0.0.0.3 area 1
 network 192.168.10.0 0.0.0.3 area 2
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.20.14.1
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 transport input telnet
!
!
end
______________________________________________________________
Config R1:

Using 1094 out of 129016 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1_7200
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$ofaI$kSgg9Ov27f249UKp2w8p41
!
aaa new-model
!
!
!
aaa session-id common
!
!
ip cef
no ip domain lookup
!
username admin password 7 111A1811121E0218
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 description LINK_TO_R0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1/0.20
 description LINK_TO_R0
 encapsulation dot1Q 20
 ip address 10.50.50.2 255.255.255.252
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes detail
 redistribute connected subnets
 redistribute static metric 1 subnets
 network 10.50.50.0 0.0.0.3 area 0
!
ip forward-protocol nd
!
no ip http server
!
!
!
!
!
!
control-plane
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 transport input telnet
!
!
end
______________________________________________________________
Config R2

Using 1058 out of 129016 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2_7200
!
boot-start-marker
boot-end-marker
!
no logging console
enable password 7 071C20584B051011
!
aaa new-model
!
!
!
aaa session-id common
!
!
ip cef
no ip domain lookup
!
username admin password 7 15010A1801262230
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1/0.30
 description LINK_TO_R0
 encapsulation dot1Q 30
 ip address 10.50.50.6 255.255.255.252
!
interface FastEthernet1/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes detail
 redistribute connected subnets
 redistribute static metric 1 subnets
 network 10.50.50.4 0.0.0.3 area 1
!
ip forward-protocol nd
!
no ip http server
!
control-plane
!
line con 0
 exec-timeout 0 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 transport input telnet
!
!
end

______________________________________________________________
Config R4

Using 1029 out of 57336 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R4_2691
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$NTsc$vYXOu//RTO3SJvtlQsQcA.
!
aaa new-model
!
aaa session-id common
memory-size iomem 5
ip cef
!
no ip domain lookup
!
username admin password 7 0017121201570212
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.10.1 255.255.255.252
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes detail
 redistribute connected subnets
 redistribute static metric 1 subnets
 network 192.168.10.0 0.0.0.3 area 2
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 transport input telnet
!
!
end
______________________________________________________________

I don`t understand why this ocnfig is not working, why I can`t ping any router.
I hope someone have an answer... thanks

Best regards
0
Comment
Question by:Shex_
  • 14
  • 5
  • 2
21 Comments
 
LVL 14

Expert Comment

by:plug1
ID: 21820784
Your ethernet interfaces are "shutdown" mate, you need to set them to "no shutdown"
0
 

Author Comment

by:Shex_
ID: 21820804
hello, thank you for reply, yes the interfaces that are not used are down "shutdown" but the interfaces that are in use ar not down.

Example R1:

interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface FastEthernet1/0
 description LINK_TO_R0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1/0.20
 description LINK_TO_R0
 encapsulation dot1Q 20
 ip address 10.50.50.2 255.255.255.252

the interface 0/0 is not used and it is down, while the interface 1/0 is used and it is not down, the same with Sub-Interface.

0
 
LVL 14

Expert Comment

by:plug1
ID: 21820816
Apologies, I thought it was a glaringly obvious mistake lol, clearly it isnt..
0
 

Author Comment

by:Shex_
ID: 21820838
hehe that`s happening when there is couple interfaces, the peoples eyes often looking first after "negative" things :) like "shutdown" in this case.

no problems at all dude, ..... any way, either is this wired or I am blind..
0
 

Author Comment

by:Shex_
ID: 21820843
first I was thinking to post only needed interfaces, but than I was thinking, there is a peoples who will ask for "whole" router config, so therfore I posted it as it is...
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 21821305
Problem seems to be the trunk links on the swtich to the routers
The switchport trunk allowed vlan 1,2,20,1002-1005 would only allow the WAN vlan 1 and VLAN20, link to R1 VLAN. The problem is this keeps the other routers as different VLANs and can't by design communicate with the other devices. You would need to add VLAN 20 - 40 to the allow statements of all trunks. That being said the Switch should be able to ping each router, if not post the output from show cdp nei and show vlans
0
 

Author Comment

by:Shex_
ID: 21821341
hm, but for example why I can`t ping from R0 to R4 ? these are on the same VLAN as you can see
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 21821383
I wasn't sure from your problem description if you couldn't reach the routers from the switch or not. In anycase its early morning and what I posted might need to be dealt with later depending on your design. As I said though, please post the output from show cdp nei and show vlans.
0
 

Author Comment

by:Shex_
ID: 21821448
my problem was:

I can`t ping from R0 to R4, I can`t ping from R4 to R0,
I can`t ping from R0 to R1 I can`t ping from R1 to R0

ans so on.... I tryed all combinations for ping testing but no success :(

but let me check it, so I`ll be back to You with show output...
I need to wait around 1 hour before I can log on to these routers, because I am not sitting on the same
location right now.

I am comming back to You........

Thank You for helping dude !!
0
 

Author Comment

by:Shex_
ID: 21824830
here is the sh output from R0:

R0_2691_SW#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R4_2691          Fas 1/3            134        R S I      2691      Fas 0/0
R1_7200          Fas 1/1            151          R        7206VXR   Fas 1/0
R2_7200          Fas 1/2            164          R        7206VXR   Fas 1/0
R0_2691_SW#



R0_2691_SW#sh vlans

No Virtual LANs configured.

R0_2691_SW#
No Virtual LANs configured.

CAN`T BELIVE that I got the message "No Virtual LANs configured." there is a VLAN hmm WIRED as it can be.

any suggestion ?
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:Shex_
ID: 21824873
but the worst thing is when I am loged on to R0 and trying to ping the ip address 192.168.10.2 which is located on R0 at VLAN40 I got no response from the ping.... I am being crazy really.
0
 

Author Comment

by:Shex_
ID: 21824892
here is the sh vlans output from R4:

R4_2691#sh vlans

Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0

 This is configured as native Vlan for the following interface(s) :
FastEthernet0/0

   Protocols Configured:   Address:              Received:        Transmitted:
        Other                                           0                 128

   70 packets, 10170 bytes input
   128 packets, 9595 bytes output

Virtual LAN ID:  40 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.40

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              192.168.10.1                 0                 109
        Other                                           0                  11

   0 packets, 0 bytes input
   120 packets, 11785 bytes output

R4_2691#
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 21824899
Do the following in config mode,
vlan 20,30,40
exit

It's possible to create VLAN interfaces without creating VLANs, which would cause this type of problem.
0
 
LVL 11

Expert Comment

by:donmanrobb
ID: 21824915
In fact if you check show ip interface brief on the Switch the VLAN interfaces will probably be down.
0
 

Author Comment

by:Shex_
ID: 21824918
I think that problem may be on R0, because when I log on to all other routers except R0 I can ping their own ip addresses, but when I log on to R0 I am not able to ping its ip addresses on its own interfaces.

0
 

Author Comment

by:Shex_
ID: 21824936
I tryed,

R0_2691_SW(config)#vlan 20,30,40
                        ^
% Invalid input detected at '^' marker.

0
 

Author Comment

by:Shex_
ID: 21824948
R0_2691_SW#sh ip interface brief
Interface                  IP-Address      OK? Method Status                Prot
ocol
FastEthernet0/0            unassigned      YES NVRAM  administratively down down

FastEthernet0/1            unassigned      YES NVRAM  administratively down down

FastEthernet1/0            unassigned      YES unset  up                    up

FastEthernet1/1            unassigned      YES unset  up                    up

FastEthernet1/2            unassigned      YES unset  up                    up

FastEthernet1/3            unassigned      YES unset  up                    up

FastEthernet1/4            unassigned      YES unset  up                    down

FastEthernet1/5            unassigned      YES unset  up                    down

FastEthernet1/6            unassigned      YES unset  up                    down

FastEthernet1/7            unassigned      YES unset  up                    down

FastEthernet1/8            unassigned      YES unset  up                    down

FastEthernet1/9            unassigned      YES unset  up                    down

FastEthernet1/10           unassigned      YES unset  up                    down

FastEthernet1/11           unassigned      YES unset  up                    down

FastEthernet1/12           unassigned      YES unset  up                    down

FastEthernet1/13           unassigned      YES unset  up                    down

FastEthernet1/14           unassigned      YES unset  up                    down

FastEthernet1/15           unassigned      YES unset  up                    down

Vlan1                      10.20.14.17     YES NVRAM  up                    up

Vlan20                     10.50.50.1      YES NVRAM  up                    down

Vlan30                     10.50.50.5      YES NVRAM  up                    down

Vlan40                     192.168.10.2    YES NVRAM  up                    down

R0_2691_SW#
0
 

Author Comment

by:Shex_
ID: 21824976
just for info, R0 is used as a "switch" so I am almost 100% that problem is on R0 but what ........?
0
 
LVL 11

Accepted Solution

by:
donmanrobb earned 500 total points
ID: 21825088
Yeah I noticed the model number a bit too late.

You can add the vlans on the router in privilege mode (# prompt) with:
vlan database
vlan 20
vlan 30
vlan 40
apply
---
Then the VLAN interfaces should come UP/UP after a bit.
0
 

Author Comment

by:Shex_
ID: 21825565
well now we found the problem, as you say I should add the vlans to the database WHICH I DID before I added and configured the vlan interfaces, BUT when you reminded me for vlan database, I did the following:

R0_2691_SW(vlan)#sh current

than I got only default VLANS in the database, but no VLANS 20,30 and 40, the vlans 20,30,40 was not in the database.

So I did as you told me I added them on to database again and applied them, and now everything is working fine.

BUT !!! when I RELOAD the router whole config is LOST, including VLANS in the database, so each time I reload the router I need to take a backup of the sh config and than restore it back after reboot, and than access the VLAN database so put the clans 20,30 and 40 back on to database.

Something is wrong with router or IOS conf-reg ? this is first time I am working on this router, so I have not noticed that config is lost before now, because I did an reload for to check if the config is saved or not.

So in short words, my problem is coming after router is restarted, I need to copy back the config AND add the VLANS 20,30 and 40 back to database ....

Any idea why the config is not saved even if I use wri mem ?
0
 

Author Closing Comment

by:Shex_
ID: 31468679
WELL DONE DUDE !!!

THANK YOU FOR ALL HELPING !!
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now