Error: You do not have access to this dhcp server

Posted on 2008-06-19
Last Modified: 2013-12-05
I setup a new windows 2003 R2 DC server. Old one was Windows 2000 SP4.
I moved the old dhcp server from windows 2000 to windows 2003, following

Now, when starting the DHCP server service with administrator credentials. I get a Access denied when viewing the server in dhcp manager. I get it on both old and new server.

I have tried uninstalling both DHCP servers, both it still gives me the error on my new server.
Question by:mathiesen-data
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3

Author Comment

ID: 21820369
And by the way, I have deleted HKLM\software\microsoft\dhcp server on both machines.
Deleted C.\windows\system32\dhcp on both machines also.
I am guessing its hiding in ad
LVL 10

Assisted Solution

Kieran_Burns earned 500 total points
ID: 21820390
Have you authorised the DHCP Server in AD?

Select Start, Programs, Administrative Tools, DHCP.

In the console, right-click DHCP and select Manage Authorize Servers.

Click Authorize in the Manage Authorized Servers window.

Enter the name or IP address of the DHCP server to be authorized, and click OK.

Author Comment

ID: 21820658
Yes its authorized
Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

LVL 10

Expert Comment

ID: 21820691
Do you get the error after you've installed the DHCP Service on the new Server and before you've tried importing the old database?

Author Comment

ID: 21820847
I don't know, because I do this often, so I didn't even check the old one to see.
I just used the commands to move it.
I would think I could start the "DHCP SERVER" service with localsystem, but it gives me an error 1079 when trying:

Could not start the DHCP Server service on Local Computer.

Error 1079: The account specified for this service is different from the account specified for other services running in the same process.
LVL 10

Expert Comment

ID: 21820862
You need an account in the local admins group to be able to start the Service and if I remember correctly an ENTERPRISE Admin to load up the database.

I'd try getting the service started without the imported database first, just to confirm that you can and then try and import the old database.

If you make enterrpise admins a member of the local admins group on the Server and use an Enterprise admin account you should have no problems.

Author Comment

ID: 21820971
It already is.
At this point I just want to configure a whole new DHCP server.
Forget about the old ones, and just get it up and running. However, I cant! :(
I keeps giving me access denied as per screenshot, even if I delete the mentioned registry keys, and delte the dhcp folder after uninstalling dhcp.

Accepted Solution

mathiesen-data earned 0 total points
ID: 21821418
I don't know which thing fixed it.
I read somewhere that I should put the server itself in the DHCPAdmin group.
I also completely uninstalled all traces of DHCP. I rebooted the server, and when i came up again, I used the "add server role" wizard to install DHCP. I dont know if this circumvented the error because it ask you to configure DHCP settings before it starts the service itself.

Author Comment

ID: 21821450
How Do i accept my own answer as solution and assgn you points for participating?

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Have you considered what group policies are backwards and forwards compatible? Windows Active Directory servers and clients use group policy templates to deploy sets of policies within your domain. But, there is a catch to deploying policies. The…
On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
If you’ve ever visited a web page and noticed a cool font that you really liked the look of, but couldn’t figure out which font it was so that you could use it for your own work, then this video is for you! In this Micro Tutorial, you'll learn yo…
Do you want to know how to make a graph with Microsoft Access? First, create a query with the data for the chart. Then make a blank form and add a chart control. This video also shows how to change what data is displayed on the graph as well as form…
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question