Solved

Unable to edit Email Entity

Posted on 2008-06-19
5
501 Views
Last Modified: 2013-11-24
Hi
we have MSCRM 4 running on Windows 2003 and SQL Server 2005, whenever we try to costomise certain enetities we have a problem. The Email entity is an example of this. The problem always occurs on the same entities and occurs everytime for every user on every machine. However we have successfully customised other entities.

The problem is you go into the Email entity to customise it and choose forms and views and then choose the Main Form to customise (note other email forms are ok) when you double click on the form to open it the screen appears as normal but in the bottom left hand corner it says Error on Page.  You can now not make any changes to the form (clicking add a section, etc does nothing) and when you close the form you get the Microsoft CRM has encountered an Error screen, do you want to send it to microsoft, etc I have attached the contents of this as a code snippet.

Thanks

Tim
Microsoft Dynamics CRM Error Report Contents
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;window.document.all&#40;...&#41;.style&#39; is null or not an object</Message>
	<Line>134</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>down&#40;oTab, bForce&#41;</Function>
	<CallStack>
	  <Function>down&#40;oTab, bForce&#41;</Function>
	  <Function>load&#40;&#41;</Function>
	  <Function>function anonymous&#40;&#41;&#10;&#123;&#10;load&#40;&#41;&#10;&#125;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;window.document.all&#40;...&#41;.style&#39; is null or not an object</Message>
	<Line>134</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>down&#40;oTab, bForce&#41;</Function>
	<CallStack>
	  <Function>down&#40;oTab, bForce&#41;</Function>
	  <Function>load&#40;&#41;</Function>
	  <Function>function anonymous&#40;&#41;&#10;&#123;&#10;load&#40;&#41;&#10;&#125;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;tabs.firstChild&#39; is null or not an object</Message>
	<Line>199</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>window.onload&#40;&#41;</Function>
	<CallStack>
	  <Function>window.onload&#40;&#41;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;tabs.children.length&#39; is null or not an object</Message>
	<Line>313</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>GetTabName&#40;sTabId&#41;</Function>
	<CallStack>
	  <Function>GetTabName&#40;sTabId&#41;</Function>
	  <Function>GetCurrentTabName&#40;oActive&#41;</Function>
	  <Function>AddFields&#40;oActive&#41;</Function>
	  <Function>function anonymous&#40;&#41;&#10;&#123;&#10;AddFields&#40;_oActive&#41;&#59;&#10;&#125;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;tabs.children.length&#39; is null or not an object</Message>
	<Line>313</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>GetTabName&#40;sTabId&#41;</Function>
	<CallStack>
	  <Function>GetTabName&#40;sTabId&#41;</Function>
	  <Function>GetCurrentTabName&#40;oActive&#41;</Function>
	  <Function>AddSection&#40;oActive&#41;</Function>
	  <Function>function anonymous&#40;&#41;&#10;&#123;&#10;AddSection&#40;_oActive&#41;&#59;&#10;&#125;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;tabs.children.length&#39; is null or not an object</Message>
	<Line>313</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>GetTabName&#40;sTabId&#41;</Function>
	<CallStack>
	  <Function>GetTabName&#40;sTabId&#41;</Function>
	  <Function>GetCurrentTabName&#40;oActive&#41;</Function>
	  <Function>AddFields&#40;oActive&#41;</Function>
	  <Function>function anonymous&#40;&#41;&#10;&#123;&#10;AddFields&#40;_oActive&#41;&#59;&#10;&#125;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>
 
<CrmScriptErrorReport>
  <ReportVersion>1.0</ReportVersion>
  <ScriptErrorDetails>
	<Message>&#39;tabs.lastChild&#39; is null or not an object</Message>
	<Line>74</Line>
	<URL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</URL>
	<PageURL>/LarmerBrownConsulting&#47;tools&#47;formEditor&#47;formEditor.aspx&#63;formtype&#61;main&#38;objectTypeCode&#61;4202</PageURL>
	<Function>AddTabHtml&#40;oTabObj&#41;</Function>
	<CallStack>
	  <Function>AddTabHtml&#40;oTabObj&#41;</Function>
	  <Function>AddTab&#40;&#41;</Function>
	  <Function>function anonymous&#40;&#41;&#10;&#123;&#10;AddTab&#40;&#41;&#59;&#10;&#125;</Function>
	</CallStack>
  </ScriptErrorDetails>
  <ClientInformation>
	<BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 7.0&#59; Windows NT 5.1&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.04506.30&#59; InfoPath.2&#41;</BrowserUserAgent>
	<BrowserLanguage>en-us</BrowserLanguage>
	<SystemLanguage>en-us</SystemLanguage>
	<UserLanguage>en-gb</UserLanguage>
	<ScreenResolution>1024x768</ScreenResolution>
	<ClientName>Web</ClientName>
  </ClientInformation>
  <ServerInformation>
    <OrgLanguage>1033</OrgLanguage>
    <OrgCulture>2057</OrgCulture>
    <UserLanguage>1033</UserLanguage>
    <UserCulture>2057</UserCulture>
    <OrgID>&#123;D6B750D9-4494-4229-B011-3B0DAF6D94E4&#125;</OrgID>
    <UserID>&#123;6C57AB1F-449F-DC11-91EC-001B789811D6&#125;</UserID>
    <CRMVersion>4.0.7333.3</CRMVersion>
  </ServerInformation>
</CrmScriptErrorReport>

Open in new window

0
Comment
Question by:timpoynter
5 Comments
 
LVL 9

Accepted Solution

by:
Biffster007 earned 250 total points
ID: 21826338
Hi,

Have you made any changes to A.D. or the database directly since you installed CRM??

Did CRM install corrrectly without error??

Turn DevErrors on and you might get a more meaningful error message.

MH
0
 
LVL 11

Assisted Solution

by:rakeshAgarwal
rakeshAgarwal earned 250 total points
ID: 22650656
Hi  

 There is some  javascript error.  On load or on save can you check that.

If you dont have javascript  written.

I had the  same issue with account entity

 I did  this in my test environ ment.   I  too k backup of  everything  before trying this step.  Try this  step at your risk.
 I went to sql server

Got the rows for  account

select *  from filteredorganizationui
where objecttypecode like '1' // email 4202

There were three rows. One row was showing  in production is false.
Deleted the row inproduction   true
Updated the the row in production with true.
 and started working.  Client was really happy to see this

Regards
Rakesh Agarwal

www.dynamincsexchange.com 
www.mtccrm.com 
ra@mtccrm.com
 





0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

When CRM stops functioning propperly or mysteriously disappears then this is something you should always check. This can be useful when looking at an end users machine or your own machine if you are the end user. It may be fairly obvious to some but…
Get to know the ins and outs of building a web-based ERP system for your enterprise. Development timeline, technology, and costs outlined.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

785 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question