Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4490
  • Last Modified:

How do I generate plug-in?

I have generated the plugin-cfg on the WAS-6 console for IHS.  The generated plugin-cfg seems to be incomplete (looks very few lines compared to my WAS-5).  Am I missing something? I am pasting the generated plugin-cfg below.
<?xml version="1.0" encoding="ISO-8859-1"?>
<!--HTTP server plugin config file for the webserver kmgwinsbs2003Node01Cell.webserver1_node.webserver1 generated on 2008.06.19 at 06:35:01 AM EDT-->
<Config ASDisableNagle="false" AcceptAllContent="false" AppServerPortPreference="HostHeader" ChunkedResponse="false" FIPSEnable="false" IISDisableNagle="false" IISPluginPriority="High" IgnoreDNSFailures="false" RefreshInterval="60" ResponseChunkSize="64" VHostMatchingCompat="false">
   <Log LogLevel="Error" Name="C:\Program Files\IBM\WebSphere\Plugins/logs/webserver1/http_plugin.log"/>
   <Property Name="ESIEnable" Value="true"/>
   <Property Name="ESIMaxCacheSize" Value="1024"/>
   <Property Name="ESIInvalidationMonitor" Value="false"/>
   <Property Name="ESIEnableToPassCookies" Value="false"/>
   <RequestMetrics armEnabled="false" loggingEnabled="false" rmEnabled="false" traceLevel="HOPS">
      <filters enable="false" type="URI">
         <filterValues enable="false" value="/snoop"/>
         <filterValues enable="false" value="/hitcount"/>
      </filters>
      <filters enable="false" type="SOURCE_IP">
         <filterValues enable="false" value="255.255.255.255"/>
         <filterValues enable="false" value="254.254.254.254"/>
      </filters>
      <filters enable="false" type="JMS">
         <filterValues enable="false" value="destination=aaa:topic=bbb"/>
      </filters>
      <filters enable="false" type="WEB_SERVICES">
         <filterValues enable="false" value="wsdlPort=aaa:op=bbb:nameSpace=ccc"/>
      </filters>
   </RequestMetrics>
</Config>
0
royrubio
Asked:
royrubio
  • 7
  • 3
1 Solution
 
HonorGodCommented:
I agree, the information there is much too sparse.

Do you have a stand alone (Base) application server, or are you working
with a Network Deployment environment?

0
 
royrubioAuthor Commented:
I have a standalone WAS6.  I started with 6.0.0.1 base.  When I noticed this problem, i decided to apply fix packs which brought it to version 6.0.2.27.  I hoped that it will generate correctly after applying the fix packs, but there was no improvement.  The IHS is also on the same machine.
0
 
HonorGodCommented:
ok, so from your stand-alone (base) application server,
you are accessing the Administration Console.  Right?

What steps are you using to generate the plugin?  I have a 6.1 server on my
machine at the moment, so it might be slightly different.

From the Admin Consolem
- Expand the Environment section
- Select the "Update global Web server plug-in configuration"
- Click the "OK" button.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
royrubioAuthor Commented:
There is no 'Update global Web server plug-in...' in 6.0.  I found a template in the Plugins directory and I am now thinking of manually coding the missing things.  Shall I just do this and leave the problem as it is?  I guess no one is using 6.0 anymore but it's the only one I've got.
0
 
HonorGodCommented:
I bet I know what happened.  I'm guessing that what you did, during
application deployment is that you didn't map the application to your
webserver.  When this step is skipped, the plugin-cfg.xml tends to be
quite small/short.

We can verify that this is the case by:

point your browser to the WebSphere Application Server port (i.e.,
bypass the webserver), and include the resource information. If you
get to your application fine, then it is deployed, and started.

If you then, try accessing the same resource through the webserver,
and get an error (e.g., 404, or resource not found kind of thing), then
it is highly likely that you didn't map your application/resource to you
webserver.  Let me get to a 6.0 AdminConsole, and find the exact
steps.
0
 
HonorGodCommented:
If you access your AdminConsole, and

- Select/expand the "Applications" section
- Select the "Enterprise Applications" section
- Select (click on) the Application link
- Click on the Target mappings link

I bet that you will only see the name of the server (most likely "server1").
If this is the case, I'm pretty sure that you need to redeploy the application,
this time making sure to specify that the application should be mapped to
both the application server (which happens by default), as well as the web
server.
0
 
HonorGodCommented:
As far as your comment "Update global Web server plug-in..." is concerned,

- Select/expand the Guided Activities section
- Select the "Routing requests from a Web server to an application server "

and start reading...

Good luck
0
 
HonorGodCommented:
btw, this page has some excellent information

http://www.IBM.com/support/docview.wss?rs=180&uid=swg21207587
0
 
royrubioAuthor Commented:
You hit the right spot.  I missed mapping the app to the web server.  The plugin-cfg looked good after that and everything works.  Thanks.
0
 
HonorGodCommented:
Excellent!  Glad to hear that it was of help to you.

Thanks for the grade & points.

Good luck & have a great day
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 7
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now