[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 242
  • Last Modified:

Can't Seem to receive email via POP3 from external email adresses ' outside my domain

i have a exchange server 2003 that came with (MS SBS) Microsoft Small Business Server 2003 R2. I have a registered domain that i will refer to as "mydomain.com". i have a linux box as my firewall that i have opened up all the ports for testing purposes until i get the exchange email system working (the linux box's internal ip is 192.168.1.243). I seem to be able to send email  just fine BOTH "internally (within the domain)" and "externally (outside the domain)". I have my registrar  DNS for email  pointing to my external ip address at 69.x.x.x and for the name "mail.mydomain.com" The SBS server with exchange is called "SERVER001.MYDOMAIN.LAN with an internal ip adress of 192.168.1.235" gateway of 192.168.1.243 and a DNS of 192.168.1.235. (i used the ". LAN"  because thats what MS SBS recommended during setup instead of using a .COM for "security purposes", dont ask my why, i just did what they recommended, i hope this doesnt turn out to be the problem)

Now on to my problem......i seem to be able to send email just fine to both internal and external emails both inside and outside the domain. However i cant seem to receive email via POP3 from people outside the domain. Within the domain i can send email just fine.  i am trying to have the exchange server handle the email directly from the internet. the exchange clients are using outlook and are using 192.168.1.235 as the IP for both SMTP and POP3. anyone have any ideas what i am doing wrong?
0
xeonox
Asked:
xeonox
  • 4
  • 3
1 Solution
 
Taurus042Commented:
You need to set up port forwarding on your firewall if you haven't done so allready.
It needs to listen on port 25 and forward those requests to port 25 on your Exchange Server.
The same needs to be done for port 110 and/or 143 if you need access to POP3 and/or IMAP from the outside. (However please consider using SSL/TLS on SMTP/POP/IMAP for your clients or set up VPN for them. Otherwise you are sending username and password in clear text over the internet.)
0
 
xeonoxAuthor Commented:
thanks taurus, i think that solved my problem, i completely overlooked that. i just had my linux box forward the ports and it worked like a charm. i also pointed my registrar email record and cname record to point to SERVER001.MYDOMAIN.COM and it seemed to have worked fine. thanks hope this helps other people out. ill keep this open for 2/3 days but ill give you the points taurus, i just wanna fine tune it a little with the SSL you are taking about.

i am very concerned about the following, how do i prevent outside people (spammers) from using my smtp exchange server?
0
 
Taurus042Commented:
If you haven't changed any settings regarding to relaying your server should be OK already.

I do not have an Exchange 2003 machine right now so I cannot check exactly where the setting is but you should right click your SMTP virtual server and select Properties. Look for Relay Restrictions. Make sure that it looks like this example. You may add networks or IP addresses that you trust in the list as well.
relaying.gif
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
xeonoxAuthor Commented:
what concerns me is the little check box at the bottom that says "allow all computer wich authenitcate sucessfully to realay, regardless of the ist above"

From what i understand (correct me if i'm wrong), if that is checked, all they need to do i guess the username, and obviously the username is gonna be the email address. Does that sound right to you?
0
 
Taurus042Commented:
The username is not the same as the email address. In addition to the username they would also need the password associated with the user to be able to relay messages to other domains.
0
 
xeonoxAuthor Commented:
i think i may have gotten it working correctly, do these settings look right and secure to you?


New-Bitmap-Image--2-.JPG
New-Bitmap-Image--3-.JPG
New-Bitmap-Image--4-.JPG
New-Bitmap-Image.JPG
0
 
xeonoxAuthor Commented:
is that the right config?
0

Featured Post

[Webinar] Cloud and Mobile-First Strategy

Maybe you’ve fully adopted the cloud since the beginning. Or maybe you started with on-prem resources but are pursuing a “cloud and mobile first” strategy. Getting to that end state has its challenges. Discover how to build out a 100% cloud and mobile IT strategy in this webinar.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now