Synchronize Windows Server 2008 Domain Controller to GMT

Hi;

how can I sync my Windows Server 2008 domain controller to a atomic clock in internet to make sure all other server in the domain got the identical time and date?  Especially my Exchange 2007 server.  Please give me a step by step procedure?  I do not want to install any othr 3rd party software on my domain controller, I just want to use the feature in Windows 2008.

Thanks!
LVL 1
KANEWONGAsked:
Who is Participating?
 
tigermattCommented:
OK, try these commands instead. Just to note, I've just tried this myself, and found that even though that error is appearing, the time is still being updated!

Be sure to run these from an elevated command prompt:

net stop w32time
w32tm /unregister
w32tm /register
net start w32time
net time /setsntp:time.windows.com
w32tm /config /syncfromflags:MANUAL /manualpeerlist:time.windows.com,0x8
net stop w32time

(At this stage, change time so it is 5 minutes out)

net start w32time
w32tm /resync /rediscover

The time should go back - even if you get an error.

-tigermatt
0
 
tigermattCommented:
You must first enable the time service, if it is not already enabled. To do this, go to Start, Administrative Tools, Services. Find Windows Time in the list, double-click, select "Automatic" from the Startup Type list, then press OK.

Now, press Start, type cmd and press OK to pull up a command prompt. Execute the following commands, where a new line means you press enter. You can ignore any Access Denied error messages it throws.

net stop w32time
net start w32time
net time /setsntp:time.windows.com
w32tm /config /manualpeerlist:time.windows.com,0x8 /syncfromflags:MANUAL
net stop w32time && net start w32time
w32tm /resync /rediscover

That will get you synchronizing time with Microsoft's NTP servers. As a test, you could set the time out by a minute or two (but no more than about 5 minutes), then execute w32tm /resync and the time will jump back to the correct time at the present time.

-tigermatt
0
 
KANEWONGAuthor Commented:
Hi;

after I type the command "w32tm /resync /rediscover", I got the following message.

The computer did not resync because no time data was available.

For the command listed above, if the server rebooted, do I need to re-enter again, or how can I use a script to start it automatically?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
tigermattCommented:
Once the w32time service is up and running and configured to start automatically, everything will remain after each reboot.
0
 
KANEWONGAuthor Commented:
what is the meaning of "The computer did not resync because no time data was available."

I did not see the time sync to the correct time stamp.
0
 
tigermattCommented:
Did you run all the commands EXACTLY as I posted?
0
 
biggstrcCommented:
To jump in here, I am experiencing the same issue.  I can't find documentation anywhere for 2008.  I tried the solution above and I got the same error (The Computer did not resync because no time data was available).  I didn't rekey the instructions, I copied them into a bat file just to be sure I didn't do anything wrong.  I've looked at other instructions on the web, but I always get this error.  I've checked to be sure UDP port 123 is allowed (it is)

Any help would be appreciated.  Thanks.
0
 
biggstrcCommented:
I tried this exactly like you said.  It did not change the time back.  Are you sure you have your time protocol set to look to an NTP server (registry key setting)?  If you are on a domain and haven't changed this setting, the time will reset because the DC will pass the new time down.
0
 
tigermattCommented:
Yes, I'm fully aware of that. The PDCe is responsible for advertising itself as a time server and to push the time down. Running the /syncfromflags:MANUAL forces the server to use NTP as the time source, as opposed to NT5DS.
0
 
KANEWONGAuthor Commented:
I tried again but still not working, when I began to type those command, it was 1:09pm, when typing done, it was 1:10pm.  Therefore the time did not sync.

How can I test if my server can talk to the time.windows.com?
0
 
tigermattCommented:
Try pinging time.windows.com.

Also, try using time.nist.gov in place of time.windows.com - that might help.

Are you sure the time on the server is actually wrong?
0
 
biggstrcCommented:
That did it for me.  Changing to time.nist.gov was the trick.  I couldn't ping time.windows.com but I assumed they had blocked ICMP traffic.  Thanks for the help.
0
 
KANEWONGAuthor Commented:
Finally, it works for me when I sync to time.nist.gov.
0
 
tigermattCommented:
Sounds like you must be having a problem connecting to time.windows.com - I can get to it, but there have been issues using that NTP server in the past!

Thanks again
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.