Solved

Arabic charset working with PHP and mySQL

Posted on 2008-06-19
6
3,019 Views
Last Modified: 2012-05-05
Hi all,
Exact issue is failing to insert Arabic data into mySQL using PHP application.  Result appear as question marks ???????

1. The same code works fine on my local server.
2. The same mySQL query works fine using myPHPAdmin given by the hosting company.
3. Reading Arabic data from mySQL works perfect.

PHP code used to insert the data:


<?php
    session_start();
    require "Utils.php";
    $isloggedin = isset($_SESSION["isloggedin"]) && $_SESSION["isloggedin"];
    $user = false;
    $passord = false;
    if($isloggedin) {
        // TODO change to session vars
        $user = "*********";
        $passord = "*********";
    } else {
        $user = "********";
        $passord = "********";
    }
    $con = mysql_connect("database name",$user,$password);
    if (!$con) {
        // TODO redirect to error page
        die('Could not connect: ' . mysql_error());
        exit;
    }
    
    // building the sql columns
    $sql_columns["event_type"] = $_POST["ddl_event_type"]; // int value
    $sql_columns["description"] = "'"  . $_POST["txtbox_description"] . "'";
    $sql_columns["event_days"] = "'" . $_POST["txtbox_days"] . "'";
    $sql_columns["event_time"] = "'" . $_POST["txt_time"] . "'";
    $sql_columns["event_location"] = "'" . $_POST["txt_location"] . "'";
    $sql_columns["event_map_url"] = "'" . $_POST["txt_map_url"] . "'";
    $sql_columns["event_details_url"] = "'" . $_POST["txt_details_url"] . "'";
    $sql_columns["added_by"] = "'" . $_POST["txt_owner"] . "'";
    $now = date("Y-m-d H:i:s");
    $sql_columns["added_date"] = "'" . $now . "'";
    if($isloggedin) {
        $sql_columns["accepted_date"] = "'" . $now . "'";
        $sql_columns["accepted"] = "1"; // boolean
        $sql_columns["expiration_date"] = "'" . $_POST["txt_exp_date"] . "'";
    }
    mysql_query("SET NAMES 'utf8'");
    mysql_query('SET CHARACTER SET utf8'); 
    mysql_query("SET character_set_results='utf8'");
    mysql_select_db("burair_munasabat", $con);
    
    $query = "INSERT INTO munasabat_table (";
    foreach($sql_columns as $colName => $colValue) {
        $query .= $colName . ",";
    }
    // remove last comma
    $query = substr($query, 0, strlen($query) - 1);
    $query .= ") VALUES(";
    foreach($sql_columns as $colName => $colValue) {
        $query .= iconv("windows-1256", "utf-8", $colValue) . ",";
    }
    // remove last comma
    $query = substr($query, 0, strlen($query) - 1);
    $query .= ")";
    echo $query;
    mysql_query($query);
    if(mysql_error()) {
        echo mysql_error();
    }
    mysql_close($con);
?>
 
<html dir="rtl">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <head>
    </head>
<body> Submitted </body>
</html>

Open in new window

0
Comment
Question by:The14follower
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 9

Expert Comment

by:Rurne
ID: 21824707
Sounds like your table collation's off.  What you need is iso-8859-6 character set support.  What MySQL actually includes is cp1256, which is called 'Windows Arabic.'  It should work okay with the following update to your database:

ALTER DATABASE `database name` DEFAULT CHARACTER SET = cp1256;
ALTER DATABASE  `database name` DEFAULT COLLATION = cp1256_general_ci;
0
 
LVL 1

Expert Comment

by:webjema
ID: 21829260
Are your database, tables and fields UTF-8?
0
 

Author Comment

by:The14follower
ID: 21831740
Rurne,
Your suggestion didn't work.  Again it works only on my local machine but not on the hosting server.

webjema,
Yes, all using utf-8.
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 
LVL 1

Expert Comment

by:webjema
ID: 21833134
try remove convention
iconv("windows-1256", "utf-8", $colValue)
your data have been already utf-8!
0
 

Accepted Solution

by:
The14follower earned 0 total points
ID: 21833258
Thanks all,

I added these two lines and got it working:

mysql_query("SET character_set_connection='utf8'");
mysql_query("SET collation_connection='utf8_general_ci'");
0
 

Expert Comment

by:lowee81
ID: 22013355
I've faced the same problem
you can solve it by change it to utf-8 even in the html files

and even when you enter the Arabic words they will be stored exactly and all the words can be modified in all operating systems not only windows
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Load balancing is the method of dividing the total amount of work performed by one computer between two or more computers. Its aim is to get more work done in the same amount of time, ensuring that all the users get served faster.
This article shows the steps required to install WordPress on Azure. Web Apps, Mobile Apps, API Apps, or Functions, in Azure all these run in an App Service plan. WordPress is no exception and requires an App Service Plan and Database to install
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.
Learn how to set-up custom confirmation messages to users who complete your Wufoo form. Include inputs from fields in your form, webpage redirects, and more with Wufoo’s confirmation options.

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question