Emails sent by my SBS Exchange are being marked as SPAM by Yahoo, Google, MSN, SBC

I recently started having problems sending emails from my small business server 2003 Exchange. Contacts that have yahoo, msn, gmail, etc, are not receiving none of my emails or marking them as spam.
I host my own server and I use an MX record on my Registerer that points to my public ip address and everyting was working fine up until this Monday. I have not made any changes on my server. Also some contacts that do not have gmail or yahoo are getting my emails fine.
Any information is greatly appreciated.

Sam De La Cruz
sammydlcAsked:
Who is Participating?
 
tigermattCommented:
I expect you either have an SMTP banner issue or reverse DNS issue. Please work through http://www.amset.info/exchange/dnsconfig.asp exactly and check everything matches everywhere, including in reverse DNS at your ISP.

Please post more information also about the DNS setup you have if that doesn't help.

-tigermatt
0
 
Press2EscSystems IntegratorCommented:
What is you mail/domain name & who is you ISP??

If applicable, I recommend you post an email headr from a "typical" blocked email.

0
 
sammydlcAuthor Commented:
Made the changes and now they are being receuved on those accounts but are being marked as SPAM.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
tigermattCommented:
If all your DNS is flawless then there is something either in the message or at Yahoo which is marking them as spam. You'll have to contact Yahoo! Postmaster to see about whether this is the case, and have any restriction removed.

You might also need to wait for DNS propogation to take place - give it 24 hours and see if it gets better.

-tigermatt
0
 
sammydlcAuthor Commented:
My mail is mail.eaglewingstrans.com
My ISP is Time Warner
I have an MX record on my registar pointing to my static public IP, which is forwarded to my internal IP.
I host my own exchange
I can receive email ok. I can send emails ok now but are now being marked by yahoo, msn, gmail as spam.
0
 
sammydlcAuthor Commented:
Microsoft Mail Internet Headers Version 2.0
Content-Transfer-Encoding: 7bit
Received: from mail pickup service by msexchange2.samdelacruz.local with Microsoft SMTPSVC; Thu, 19 Jun 2008 13:15:13 -0500
Importance: normal
Priority: normal
Return-Path: <Administrator@eaglewingstrans.com>
Delivered-To: sdelacruz@samdelacruz.com
X-Spam-Checker-Version: SpamAssassin 3.2.4 (2008-01-01) on greatmail1.nmsrv.com
X-Spam-Level:
X-Spam-Status: No, score=0.6 required=3.0 tests=AWL,HTML_MESSAGE,RDNS_NONE      autolearn=disabled version=3.2.4
X-Spam-Report:       *  0.0 HTML_MESSAGE BODY: HTML included in message      *  0.1 RDNS_NONE Delivered to trusted network by a host with no rDNS      *  0.5 AWL AWL: From: address is in the auto white-list
Received: (qmail 6995 invoked from network); 19 Jun 2008 18:11:01 -0000
X-AntiVirus: Clean
Received: from unknown (HELO mail.eaglewingstrans.com) (24.153.168.214)  by greatmail1.nmsrv.com with SMTP; 19 Jun 2008 18:11:01 -0000
Content-Class: urn:content-classes:message
Subject: TEST 34
Date: Thu, 19 Jun 2008 12:32:17 -0500
MIME-Version: 1.0
Content-Type: multipart/alternative;
      boundary="----_=_NextPart_001_01C8D232.6B850AD8"
Message-ID: <A07D5389A329604AB05FC4CE2F2B3D6C01A55D@servereagle.eaglewings.local>
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.4133
Thread-Topic: TEST 34
Thread-Index: AcjSMmtJXT6TIXfVQeqDOR+0W9SlEg==
From: "Administrator" <Administrator@eaglewingstrans.com>
To: <samdelacruz@yahoo.com>,
      <sdelacruz@samdelacruz.com>
X-GFI-P2E: MSEXCHANGE2
X-OriginalArrivalTime: 19 Jun 2008 18:15:13.0820 (UTC) FILETIME=[6B2D6DC0:01C8D238]

------_=_NextPart_001_01C8D232.6B850AD8
X-EC0D2A8E-5CB7-4969-9C36-46D859D137BE-PartID: CD961D9A-16BE-4227-BFDB-A9E140150C29
Content-Type: text/plain;
      charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
------_=_NextPart_001_01C8D232.6B850AD8
X-EC0D2A8E-5CB7-4969-9C36-46D859D137BE-PartID: E22198F8-C5E2-4B30-BBE8-9E01FB132D60
Content-Type: text/html;
      charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
------_=_NextPart_001_01C8D232.6B850AD8--
0
 
tigermattCommented:
You've still got a RoadRunner Reverse DNS record configured. You will need to call Road Runner and request that they change the reverse DNS record for 24.153.168.214 pointing to mail.eaglewingstrans.com. With an RR RDNS record, you don't have a complete DNS setup.
0
 
sammydlcAuthor Commented:
Tiggermart thanks for your help.
how were you able to determine that Road runner does not have a Reverse DNS record from my email header above? I am calling them as I write this to request that change.
0
 
tigermattCommented:
A simple nslookup check against the internet nameservers. You could do it if you liked.

First of all, find the public IP address.

Start, run, cmd, OK
nslookup
set q=mx
eaglewingstrans.com

Note the MX Record IP address, then lookup reverse pointer record, being sure to reverse the order of the IP address's octets.

set q=ptr
214.168.153.24.in-addr.arpa
This returns an RDNS record for somewhere .rr.com - rr.com being road runner, of course.

Since they are authoritive for your IP address's reverse lookup zone, they have to add the reverse DNS.
0
 
sammydlcAuthor Commented:
OK I called Time Warner and they told me that they were not able to change any settings since they do not host my email or my domain.
0
 
tigermattCommented:
They don't need to - they are providing you with your public static IP address, and they must therefore be responsible for Reverse DNS changes since it is THEIR IP address range. Call them back and specifically ask them to set up Reverse DNS on 24.153.168.214 pointing towards mail.eaglewingstrans.com.

Everything else is not handled by them, but Reverse DNS is.
0
 
sammydlcAuthor Commented:
does it matter if they do not do my DNS?
0
 
tigermattCommented:
No, they don't do the forward lookup DNS - that is going from domain name to IP - but they are still hosting the zone for your public IP address since THEY own that address. They must therefore own the reverse lookup zone for that address.
0
 
sammydlcAuthor Commented:
The tech from Time Warner told me that since they do not host any services they cannot make that change. Since they do not do my DNS they said that they cannot do anything for me. MAn I am getting frustrated. Let me call them back again
0
 
tigermattCommented:
It sounds like a typical technical support department who are trying to confuse you and refuse to do it - when they must be able to do it.

Hmmm... I'm not familier with US ISPs (i'm the other side of the big pond!) - is Time Warner the same as Road Runner. The RDNS is registered as Road Runner on your IP address...
0
 
sammydlcAuthor Commented:
Yes. Time Warner is Road Runner.
0
 
tigermattCommented:
Right, if they're not willing to set up your Reverse DNS, the only work around is to configure Exchange to send your mail out through a smart host. You should have an SMTP server provided by your ISP or web host which you can use for this purpose.

Follow the guide at http://www.amset.info/exchange/smtp-connector.asp to configure Exchange to send all the mail through this SMTP server. If anything is going to mark it as spam then, it is a misconfiguration elsewhere.

Getting the RDNS correctly configured would have been nice, but it looks like that's the only remaining option.

-tigermatt
0
 
Press2EscSystems IntegratorCommented:
Sammy, escalate your call at TMC/RR to a person who understands rDNS.  Explain, to them - your domain is fine, however TWC/RR is responsible for deliverying your mail to your mail server which is being hosted on their network (24.153.168.214)..

Alternately, if still dont find any signs of intelligent life, email your rDNS request to the SPAM (?)a/o ABUSE (abuse@rr.com) dept requesting that they correct rDNS entry - they should definitely understand the prob & take care of your request...  cc: postmaster@rr.com.  In your email, provide them your name + phone contact info, TWC/RR acct info, domain (FQDN) name, and IP...


Pssss TigerMatt, nice explanation on the how2z, etc re: mx & ptr records...
0
 
sammydlcAuthor Commented:
Excellent support. I was able to solve my problem with all the help provided by the experts. Awesome.
0
 
sammydlcAuthor Commented:
Well finally my problem was solved. I finally got a Time Warner rep that understood what I was requesting. They were able to create a PRT RDNs record to point to my existing email IP address. Also I found this support site that help me with this issue.

http://www.nogeekleftbehind.com/2007/01/11/when-aol-blocks-your-sbs-email/

Thanks for all your help

Sam
0
 
tigermattCommented:
You're most welcome

:-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.