Windows Vista Print to XP Shared Printer

I see this is a recurring question, but I dont see the same scenario I have.

I am having difficulty printing from Vista to a printer shared off an Xp Pro PC. Based on other atricles on this site, I made the following mods:

- Install printer driver locally on Vista
- Set port to the network share
- disabled bi-directional printing

I am having 'some' success. I can print from vista but after 2 or 3 sucessful prints, a job will get stuck in the XP print spooler. When the look at the spooler the job has a status of 'Deleting' but never goes away. Attempts to print from XP results in the job getting stuck behind this one, printing from Vista coems back with a communications error.

If I reboot the XP machine the Deleted job goes away and the remainder of jobs will print out.

I think the easiest remedy is to purchase and install a wireless print server allowing me to avoid printhing through the XP machine. However I am unwilling to go out and spend more money on hardware because of XP (already had to replace my wireless NIC)

Any help would be appreciated.

Who is Participating?
michkoConnect With a Mentor Commented:
Actually, your problem isn't with XP - it's with Vista.  Vista just does not like printers, and it downright hates other operating systems (even XP).  In fact, pretty much anything that is not specifically designed to be "Vista compatible", won't be.

I know it's not what you want to do, but my recommendation would be to get the wireless print server (make sure it specifically says Vista compatible).  I haven't yet found a solution to your problem that lasts for very long.  Updated drivers, full permissions, same user IDs/passwords, the mods you did - they'll usually give limited success - exactly as you are describing.

If any other experts have a good, working, long term solution, please post it.

Best of luck.

Jared LukerCommented:
Can you go in and install vista specific drivers through the server properties with vist like you could do from XP to an NT server?
For accessing a XP shared printer from a Vista PC this article should help>

"Printer Sharing Problem in Windows Vista":
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

So with compliments to the previous article editor>

<Quote> Add the printer to the Windows Vista PC using the Control Panel and set up the printer (the one that you want to access as a network printer) as a local printer - Control Panel/Printers/Add a Printer/Add a Local Printer/Use the existing port LPT1:, etc.
Do not set up the new printer as a network printer yet.

After the driver in installed, go to Printers, right click on the new printer and select Properties/Ports/Add Port.
Make sure that Local Port is selected from the list and then select New Port.
When the Enter a Port Name field comes up, manually add a new Local Port as follows: \\computer_name\shared_printer_name as the port name.
For example, if the computer name for the Windows XP PC sharing the printer is "johnPC" and the shared printer is "HP LaserJet" enter \\johnPC\HP_LaserJet then select OK.

Now return to the port list and select the newly created post as the active port for the printer.   <unquote>
JDCamAuthor Commented:
Thanks for the quick replies.

Michko, I am sure you are right at the end of the day, but I refuse to give up and spend more money on hardware that quickly. there must be a workable solution.

Jonvee, you have quoted back my current setup.

Jared Luke, I dont follow what you are saying

JDCamAuthor Commented:
Assuming I will need to reaort to a print server, I began looking at options. I see nothing from dlink or linksys that says it is Vista certified.

When I google it, I get nothing but similar complaints of Print servers not working with vista.

Would a print server even fix this problem, or would I be no better off and a few dollars poorer?

Jonvee's solution is right on track.
I had a similar problem getting my VISTA laptop to recognize my XP Pro network printer. T

If you have an shared network printer connected to an XP computer
you may have a problem printing to it from a VISTA computer on your network.

Using the standard "add Printer" options in VISTA do not work. Although it
will appear you have added the network printer, any files sent to it seem to disappear
into space.

Follow the steps below and you should be able to set up a working connection.

1. On the XP computer go to "Control Panel", "System" and identify the Computer Name.You will need this later
2. On the XP computer go to "Start" button, "Settings","printers". Right click on your local printer and go to properties.
      Click the sharing tab and identify the share name. Again, write this down.
3. On the VISTA computer, go to the "Control Panel" (Classic view), click on "printers".
4. On the left hand folders pane, right click on printers and select "Run as Administrator", "Add printer"
5. If prompted for permission click on continue.
6. On the choose Local or Network screen click on "LOCAL PRINTER" option, NOT the Network Option.
7. On the Choose printer port screen  click on "Create a New Port", type of port is LOCAL
8. In the box that asks for the port name you will enter the following       \\XPComputer_Name\printer_share_Name
      where xpcomputer_name and printer_share_name are the names identified in steps 1 and 2 above.
9. Next select the printer make and model from the drop downs.and click next.
10. If you already have drivers installed then use drivers.
11. Change name,if desired, and make it your default if you need to.
12. There is no need to share the printer.
13. Print a test page and hopefully it has worked.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.