Solved

Configure ADSL Wic on Cisco 2800 Series

Posted on 2008-06-19
5
3,577 Views
Last Modified: 2008-07-16
I currently have a dsl connection with Verizon and we have a static ip address. The old Westell modem we have in place is set to bridge mode and all is fine. I am trying to install a new cisco 2800 series route with an ADSL wic. I have contacted Verizon and they were no help. They told me all I needed to do was assign my ip address to the WIC and I would be fine. Well as a CCNA I know that is just not the case I have followed every setup guide on the internet and tried this 20 different ways. No matter what I do I get the same error message in Debug ATM EVENTS:
 Received response: 0x22
*Jun 19 21:13:24.035: DSL(ATM0/1/0): Open failed: Protocol error received -- retrying

I nkow I have a layer one problem because the interface state is DOWN and DOWN.
Here is the current running config:
Building configuration...

Current configuration : 4582 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname VADER
!
boot-start-marker
boot system flash:c2800nm-advsecurityk9-mz.124-15.t5.bin
boot-end-marker
!
logging buffered 20000 informational
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
dot11 syslog
!
!
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip domain name mdgn.microdatagis.com
ip name-server 172.16.3.1
!
multilink bundle-name authenticated
!
!
crypto pki trustpoint TP-self-signed-1103396714
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1103396714
 revocation-check none
 rsakeypair TP-self-signed-1103396714
!
!
crypto pki certificate chain TP-self-signed-1103396714
 certificate self-signed 01
  30820253 308201BC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31313033 33393637 3134301E 170D3038 30363132 31393239
  31335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 31303333
  39363731 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100ABFA BBFE86DD 07131571 9507C1F8 E926B638 B537BFA1 14040FD9 39D9F9B8
  350E33F9 B97D1686 81B44E7A 14B5F971 68C91EE3 C4180B05 A54B3D83 CB6EB368
  3B7A1F81 89B7A684 6485B9D8 2A25D078 73F8DC16 41E46BDE 6AB427BF B888239B
  8D905AB7 61E7F27D 25E1BDE5 76CFEA14 2442F14C 24ECAA4B B2B0F2C0 A8E450A9
  6CD10203 010001A3 7B307930 0F060355 1D130101 FF040530 030101FF 30260603
  551D1104 1F301D82 1B564144 45522E6D 64676E2E 6D696372 6F646174 61676973
  2E636F6D 301F0603 551D2304 18301680 1476B9EE CA809111 26B48054 F07D6380
  B6C0AF3E 0F301D06 03551D0E 04160414 76B9EECA 80911126 B48054F0 7D6380B6
  C0AF3E0F 300D0609 2A864886 F70D0101 04050003 81810099 3F1B169D C0F14FA8
  D812B920 F1AA5D5C 255F5A29 1A36F999 C43337F9 CBAB71B5 B4E8E309 748DC9AA
  A75931F6 B2641549 EA9F1CBC 156A3996 1E4A4B37 DB70FF37 E08678F8 9620463F
  8E2E416B 5FC52281 A4F38C2B DF556462 7D421202 88757D5B E2804229 28C3265A
  C6B998E0 5677975F 7812A57A 5E78F05E A93D6D27 940CDB
        quit
!
!
username admin privilege 15 secret 5 $1$cww6$3YHgWV1zHpPdAtkPU6hs71
archive
 log config
  hidekeys
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.1.1.10 255.255.255.252
 ip access-group 100 in
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
!
interface ATM0/1/0
 ip address 64..X.X.X 255.255.255.0
 no atm ilmi-keepalive
 dsl operating-mode auto
 pvc 0/35
  encapsulation aal5snap
 !
!
router rip
 version 2
 network 10.0.0.0
 network 172.0.0.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM0/1/0
!
!
ip http server
ip http access-class 1
ip http secure-server
!
access-list 1 remark Auto generated by SDM Management Access feature
access-list 1 remark SDM_ACL Category=1
access-list 1 permit 172.0.0.0 0.255.255.255
access-list 100 remark Auto generated by SDM Management Access feature
access-list 100 remark SDM_ACL Category=1
access-list 100 permit udp host 172.16.3.1 eq domain any
access-list 100 permit tcp 10.0.0.0 0.255.255.255 host 10.1.1.10 eq telnet
access-list 100 permit tcp 172.0.0.0 0.255.255.255 host 10.1.1.10 eq telnet
access-list 100 permit tcp 10.0.0.0 0.255.255.255 host 10.1.1.10 eq 22
access-list 100 permit tcp 172.0.0.0 0.255.255.255 host 10.1.1.10 eq 22
access-list 100 permit tcp 172.0.0.0 0.255.255.255 host 10.1.1.10 eq www
access-list 100 permit tcp 172.0.0.0 0.255.255.255 host 10.1.1.10 eq 443
access-list 100 permit tcp 172.0.0.0 0.255.255.255 host 10.1.1.10 eq cmd
access-list 100 deny   tcp any host 10.1.1.10 eq telnet
access-list 100 deny   tcp any host 10.1.1.10 eq 22
access-list 100 deny   tcp any host 10.1.1.10 eq www
access-list 100 deny   tcp any host 10.1.1.10 eq 443
access-list 100 deny   tcp any host 10.1.1.10 eq cmd
access-list 100 deny   udp any host 10.1.1.10 eq snmp
access-list 100 permit ip any any
access-list 101 remark Auto generated by SDM Management Access feature
access-list 101 remark SDM_ACL Category=1
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 101 permit ip 172.0.0.0 0.255.255.255 any
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 access-class 101 in
 transport input telnet ssh
 transport output telnet ssh
!
scheduler allocate 20000 1000
!
end
Any help would be greatly appreciated.
0
Comment
Question by:jeremymjackson
  • 3
  • 2
5 Comments
 
LVL 5

Expert Comment

by:Melaleuca
ID: 21826280
I assume this ADSL is PPPoA right? if this is the case you will have to setup the dialer group. below is a dialer setup for pap authentication.

interface ATM0/1/0
 no ip address
 dsl operating-mode auto
 no atm ilmi-keepalive
 pvc 0/35
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1

!
interface Dialer1
 ip address 64..X.X.X 255.255.255.0
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username (username) password 7 (password)
0
 

Author Comment

by:jeremymjackson
ID: 21830319
Well see here is the problem. Verizon states that no user name or password is needed. So I am a little confused. It would help if verizon had tech support that was worth something.
0
 

Author Comment

by:jeremymjackson
ID: 21830736
I created the dialer group and I get the same error message that I have always recieved. which is:
 Received response: 0x22
*Jun 20 14:02:42.987: DSL(ATM0/1/0): Open failed: Protocol error received -- retry
0
 
LVL 5

Assisted Solution

by:Melaleuca
Melaleuca earned 500 total points
ID: 21898314
Ok sorry i haven't gotten back sooner I've been on vacation. Are you sure that this DSL is PPPoA from the looks of it i would say it's PPPoE so i would suggest you plug it into your ethernet port and assign the ip to that interface and see if you get link.
0
 

Accepted Solution

by:
jeremymjackson earned 0 total points
ID: 21956799
Well I finally went to Cisco's site and logged in and posted the same question in thier forum. It turns out the firmware for the card needed to be updated. Updated trhe firmware and changed the config back to my original and it worked great. Thanks for the help.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now