• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 575
  • Last Modified:

Instaling Php 5.2.6

Hi i already install apache  2.2.9 correctly and freetds 0.82 now i am tring to install php 5.2.6 and i am geting the following error
this are the steps that i am using
./configure --with-apxs2=/usr/local/Apache2/bin/apxs --with-mysql --prefix=/usr/local/Apache2/php --with-config-file-path=/usr/local/Apache2/php --enable-force-cgi-redirect --disable-cgi --with-zlib --with-gettext --with-gdbm --with-mssql=shared,/usr/local/freetds
no errors
make
no errors
make install
i am geting this error
...
Installing PEAR environment:      /usr/local/Apache2/php/lib/php/
make[1]: *** [install-pear-installer] Segmentation fault
make: *** [install-pear] Error 2

some one can help me

0
dentrita
Asked:
dentrita
  • 4
  • 2
1 Solution
 
http:// thevpn.guruCommented:
What distro are you using ?
0
 
Kamran ArshadIT AssociateCommented:
Hi,

In your ./configure line, "--with-mssql=shared,/usr/local/freetds" should not have a ',' after shared.It should be:

--with-mssql=shared/usr/local/freetds

0
 
dentritaAuthor Commented:
Fedora core 4
uetian1707:
i remove the ',' and now i get this error i am sure that this the path of instalation
configure: error: Directory shared/etc/freetds/ is not a FreeTDS installation directory
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
http:// thevpn.guruCommented:
try yum install php
0
 
dentritaAuthor Commented:
this error i get it when i try to configue the php with this comand

./configure --with-apxs2=/usr/local/Apache2/bin/apxs --with-mysql --prefix=/usr/local/Apache2/php --with-config-file-path=/usr/local/Apache2/php --enable-force-cgi-redirect --disable-cgi --with-zlib --with-gettext --with-gdbm --with-mssql=shared/usr/local/freetds

i remove the ',' and now i get this error i am sure that this the path of instalation
configure: error: Directory shared/etc/freetds/ is not a FreeTDS installation directory
i configure the freetds this this configuration

./configure --with-tdsver=8.0 --enable-msdblib --enable-dbmfix
--with-gnu-ld --enable-shared --enable-static --prefix=/usr/local/freetds

dentrita
0
 
dentritaAuthor Commented:
sorry
THIS IS THE ERROR
configure: error: Directory shared/usr/local/freetds is not a FreeTDS installation directory
NOT
configure: error: Directory shared/etc/freetds/ is not a FreeTDS installation directory
0
 
dentritaAuthor Commented:
I found the solution the solution is

http://marc.info/?l=php-general&m=121362535301549&w=2
and i congure php like this

./configure --with-apxs2=/usr/local/Apache2/bin/apxs --with-mysql --prefix=/usr/local/Apache2/php  --enable-force-cgi-redirect --disable-cgi --with-zlib --with-gettext --with-mssql=/usr/local/freetds --without-pear

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now