Exchange 2007 - Stripping Address

At random recipients don't receive emails due to Exchange stripping sender address.  The recipients email server receives the message correctly and no errors are recorded but the FROM field is blank. e.g.
SMTP connected OK, reading status
SMTP got good status line, send HELO to
SMTP delivery initiated with
SMTP delivery sending: MAIL FROM:<>
techstonarAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
LaserSpotConnect With a Mentor Commented:
I think you should have accepted comment #21839668 if it led you to a solution.
0
 
LaserSpotCommented:
Hi,
This could be caused by a problem with an SMTP proxy feature in your firewall, or an e-mail scanning feature in your antivirus software. What model firewall do you have? What AV software?
0
 
techstonarAuthor Commented:
Good point.

I discussed the problem with Sophos PureMessager Anti-virus Anti-spam product and it appears there are aware of a problem that can strip email addresses.  They do not have a fix at this time but are working on the problem.

Sophos suggest a work around that required me to modify my PureMeassager routing table and trusted named internal domains.

I will analyse SMTP traffic for a few days to find out if the work around does the job.
0
 
techstonarAuthor Commented:
Sophos suggest a work around that required me to modify my PureMeassager routing table and trusted named internal domains.
0
 
LaserSpotCommented:
.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.