Solved

Cisco switches with a crossover

Posted on 2008-06-20
40
1,323 Views
Last Modified: 2008-06-20
I'm trying to connect a 3560 8 port to a 3750 stack with a cross over. Every time I plug the 8 port into the stack the port flash like its communicating then goes to alternating amber-green.  On the 8 port, if I do a sho cdp neighbor, it see's the stack no problem. If I do the same on the stack it doesn't see the 8 port.

Help please!

The config for the 8 port:

Current configuration : 1078 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface GigabitEthernet0/1
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan28
 ip address 10.142.28.49 255.255.255.0
!
ip default-gateway 10.142.28.1
ip classless
ip http server
!
!
control-plane
!
!
line con 0
 login
line vty 0 4
 login
line vty 5 15
 login
!
end


Config for the stack *edit* using port 2/0/28:

version 12.2
no service pad
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
service password-encryption
!
hostname VEC-GRE-NCS21
!
enable secret 5
!
no aaa new-model
switch 1 provision ws-c3750g-16td
switch 2 provision ws-c3750g-48ps
switch 3 provision ws-c3750g-48ps
ip subnet-zero
ip routing
ip tcp synwait-time 5
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
!
interface Port-channel2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
!
interface Port-channel5
!
interface GigabitEthernet1/0/1

*snip*

interface GigabitEthernet2/0/28
 switchport access vlan 8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk


*snip*

interface Vlan1
 no ip address
 shutdown
!
interface Vlan16
 no ip address
!
interface Vlan28
 ip address 10.142.28.50 255.255.255.0
!
ip default-gateway 10.142.28.1
ip classless
no ip http server
!
logging 10.142.28.10
snmp-server community $$V@leo$$ RO
snmp-server community gbvaleo RW
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps cluster
snmp-server enable traps fru-ctrl
snmp-server enable traps entity
snmp-server enable traps cpu threshold
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps envmon
snmp-server enable traps MAC-Notification
snmp-server enable traps copy-config
snmp-server enable traps config
snmp-server enable traps hsrp
snmp-server enable traps rtr
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistenc
y
snmp-server enable traps syslog
snmp-server enable traps vlan-membership
snmp-server host 10.142.28.10 gbvaleo
!
control-plane
line con 0

 logging synchronous
 login
 transport preferred none
line vty 0 4

 logging synchronous
 login
 transport preferred none
line vty 5 15

 logging synchronous
 login
 transport preferred none
!
!
monitor session 1 source interface Gi1/0/13
monitor session 1 destination interface Gi3/0/47
ntp clock-period 36028691
ntp source Vlan28
ntp peer 10.142.28.4
0
Comment
Question by:drdingo21
  • 21
  • 19
40 Comments
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
hi!
i suppose you have some misconfiguration here
as you have said your port fa0/8 is within default first vlan and is in access mode

port gi2/0/28 is in trunk mode and has vlan 28 as native.
i suppose you have to configure ports accordingly.
if you want to connect them with vlan 28 tagged, then issue on 3560
interface fa0/8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
end
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Thanks for the effort, but port 1 on the 8 port switch is actually being used (and is configured) for the crossover.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
sorry for that
as for the light, your ports is functioning in 100 mbps mode so it is possible, that 3750 shows it as amber.
check if you can ping 10.142.28.49 from 3750
or can you see any mac addresses on gi1/0/28? (show mac-ad int gi1/0/28)
and check the show int fa0/1 and gi1/0/28. it is also possible that port goes in err-disabled state.
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
I have tried issuing a "Speed 100" and "duplex full" (as the 3750 is a gig and the 3560 is 100). But that did nothing except made the 8 port unable to see the stack via cdp.

I cannot ping anything from the 8 port. However as I said, cdp works and vtp worked.

As far as the alternating led cisco website says:

Alternating green-amber
      
Link fault. Error frames can affect connectivity, and errors such as excessive collisions, cyclic redundancy check (CRC) errors, and alignment and jabber errors are monitored for a link-fault indication.


a sho spanning-tree blocked ports shows nothing.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
please provide me with
show int gi1/0/28
show int fa0/1

show run int gi1/0/28
show run int fa0/1

show log (ports up down should be there) from both swithes

please.
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Well, the running config is above and the sho int is

gig 2/0/28
VEC-GRE-NCS21#sho int gig 2/0/28
GigabitEthernet2/0/28 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0017.0eb3.561c (bia 0017.0eb3.561c)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 168/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:40, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 6000 bits/sec, 11 packets/sec
     0 packets input, 25502035 bytes, 0 no buffer
     Received 0 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     95872 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     42160 packets output, 3779710 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


8 port:
FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 0021.1cb9.da82 (bia 0021.1cb9.da82)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, media type is 10/100BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 7000 bits/sec, 11 packets/sec
  5 minute output rate 3000 bits/sec, 7 packets/sec
     49765 packets input, 4589086 bytes, 0 no buffer
     Received 46963 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     70 input errors, 3 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 22681 multicast, 0 pause input
     0 input packets with dribble condition detected
     29020 packets output, 2029895 bytes, 0 underruns
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out


Running (the above is incorrect - below is the actual running for each port):

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk

interface GigabitEthernet2/0/28
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
end
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
please provide me also with show log, as I have mentioned before.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
as for my verdict, I suppose you are dealing with bad cable, please try original stright cable instead of cross.
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Cable is fine. I have used it else where. I tried a straight through and same issue.

sho log for 8 port:

Switch#sho log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes,
 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 102 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: level debugging, 102 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    File logging: disabled
    Trap logging: level informational, 105 message lines logged
Log Buffer (4096 bytes):
stency restored.
00:51:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to down
00:51:25: %SYS-5-CONFIG_I: Configured from console by console
00:51:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to up
00:52:03: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to up
00:59:40: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to down
00:59:40: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to down
00:59:41: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down
00:59:42: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:59:54: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
01:00:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to down
01:00:13: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
01:00:14: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to up
01:00:24: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to up
to up
01:05:32: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/8, chang
ed state to down
01:05:32: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to down
01:05:33: %LINK-3-UPDOWN: Interface FastEthernet0/8, changed state to down
01:05:35: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:05:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
01:06:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to up
01:06:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to down
01:06:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to down
01:06:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
01:06:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to up
01:08:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to down
01:08:22: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to down
01:08:30: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:08:32: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
01:08:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to down
01:08:45: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
01:11:27: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:11:29: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
01:11:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to up
01:20:12: %SYS-5-CONFIG_I: Configured from console by console
01:28:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to down
01:28:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to down
01:28:47: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
01:29:19: %SYS-5-CONFIG_I: Configured from console by console
02:24:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
02:24:48: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
02:25:18: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to up
to down
02:45:48: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to down
02:45:56: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
02:45:58: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, chang
ed state to up
02:46:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan28, changed state
to up






For stack:

sho log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes,
 0 overruns, xml disabled, filtering disabled)
    Console logging: level debugging, 31187 messages logged, xml disabled,
                     filtering disabled
    Monitor logging: level debugging, 473 messages logged, xml disabled,
                     filtering disabled
    Buffer logging: level debugging, 31187 messages logged, xml disabled,
                    filtering disabled
    Exception Logging: size (4096 bytes)
    Count and timestamp logging messages: disabled
    File logging: disabled
    Trap logging: level informational, 31208 message lines logged
        Logging to 10.142.28.10, 3049 message lines logged, xml disabled,
               filtering disabled
og Buffer (4096 bytes):
INK-3-UPDOWN: Interface GigabitEthernet3/0/46, changed state to down
Jun 20 07:41:02 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/46, changed st
ate to up
Jun 20 07:41:03 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet3/0/46, changed state to up
Jun 20 07:41:05 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet3/0/46, changed state to down
Jun 20 07:41:06 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/46, changed st
ate to down
Jun 20 07:43:47 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet3/0/46, changed st
ate to up
Jun 20 07:43:48 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet3/0/46, changed state to up
Jun 20 07:53:55 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
Jun 20 07:53:56 UTC: %SYS-5-CONFIG_I: Configured from console by vty0 (10.142.28
.200)
Jun 20 07:54:05 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to up
Jun 20 07:54:34 UTC: %SYS-5-CONFIG_I: Configured from console by vty0 (10.142.28
.200)
Jun 20 07:55:28 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
Jun 20 07:55:41 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to up
Jun 20 08:05:09 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
Jun 20 08:05:23 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to up
Jun 20 08:05:41 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
Jun 20 08:05:55 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to up
Jun 20 08:07:04 UTC: %SYS-5-CONFIG_I: Configured from console by vty0 (10.142.28
.200)
Jun 20 08:11:01 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
Jun 20 08:11:06 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to up
Jun 20 08:12:14 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
Jun 20 08:12:18 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to up
Jun 20 08:13:51 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/40, changed state to down
un 20 08:13:52 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/40, changed st
ate to down
Jun 20 08:13:59 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/28, changed st
ate to up
Jun 20 08:14:00 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/28, changed state to up
Jun 20 08:14:13 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/28, changed state to down
Jun 20 08:14:14 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/28, changed st
ate to down
Jun 20 08:16:56 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/28, changed st
ate to up
Jun 20 08:16:58 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/28, changed state to up
Jun 20 08:26:11 UTC: %SYS-5-CONFIG_I: Configured from console by vty0 (10.142.28
.200)
Jun 20 08:34:15 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/28, changed state to down
Jun 20 08:34:16 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/28, changed st
ate to down
Jun 20 09:30:15 UTC: %LINK-3-UPDOWN: Interface GigabitEthernet2/0/28, changed st
ate to up
Jun 20 09:30:17 UTC: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthe
rnet2/0/28, changed state to up
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
hmm, all stuff seems strange to me
please do the following:
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
switchoprt trunk allowed vlan 28

interface GigabitEthernet2/0/28
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode trunk
switchportr trunk allowed vlan 28
end
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
I'll give it a shot. But an sho int gig 2/0/28 trunk gives:

VEC-GRE-NCS21#sho int gig 2/0/28 trunk

Port        Mode         Encapsulation  Status        Native vlan
Gi2/0/28    on           802.1q         trunking      28

Port      Vlans allowed on trunk
Gi2/0/28    1-4094

Port        Vlans allowed and active in management domain
Gi2/0/28    1-2,4,6-8,10,12,16,18-20,24,26,28-31,40,501-505

Port        Vlans in spanning tree forwarding state and not pruned
Gi2/0/28    1-2,4,6-8,10,12,16,18-20,24,26,28-31,40,501-505
VEC-GRE-NCS21#

for the 8 port:
Switch#sho int fa 0/1 trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/1       on           802.1q         trunking      28

Port        Vlans allowed on trunk
Fa0/1       1-4094

Port        Vlans allowed and active in management domain
Fa0/1       1-2,4,6-8,10,12,16,18-20,24,26,28-31,40,501-505

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1-2,4,6-8,10,12,16,18-20,24,26,28-31,40,501-505
Switch#



So they are allowed...

0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
No dice.

Didn't work.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
hm, that's realy strange...
please show this
show mac-address int gi1/0/28 and fa0/1
but before that please check that vlan 28 on 3560 is up
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Vlan 28 is up:

Switch#sho int vlan 28
Vlan28 is up, line protocol is up
  Hardware is EtherSVI, address is 0021.1cb9.dac1 (bia 0021.1cb9.dac1)
  Internet address is 10.142.28.49/24
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:28:34, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1432 packets input, 91477 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     44 packets output, 2816 bytes, 0 underruns
     0 output errors, 0 interface resets
     0 output buffer failures, 0 output buffers swappe




for the stack:

VEC-GRE-NCS21#sho mac-address int gig 2/0/28
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
VEC-GRE-NCS21#



for the 8 port:

         Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
  10    0001.e687.6148    DYNAMIC     Fa0/1
  10    0007.4d21.adb0    DYNAMIC     Fa0/1
  10    0007.4d21.b7e9    DYNAMIC     Fa0/1
  10    0007.4d21.dbf9    DYNAMIC     Fa0/1
  10    0007.4d22.2131    DYNAMIC     Fa0/1
  10    0007.4d22.5f8b    DYNAMIC     Fa0/1
  10    0007.4d22.6083    DYNAMIC     Fa0/1
  10    0007.4d22.609a    DYNAMIC     Fa0/1
  10    0007.4d22.7d54    DYNAMIC     Fa0/1
  10    0007.4d24.4620    DYNAMIC     Fa0/1
  10    0007.4d24.5d29    DYNAMIC     Fa0/1
  10    0007.4d25.68bb    DYNAMIC     Fa0/1
  10    0007.4d25.6bc8    DYNAMIC     Fa0/1
  10    0007.4d28.535c    DYNAMIC     Fa0/1
  10    0007.4d28.c66e    DYNAMIC     Fa0/1
  10    0007.4d29.9cf3    DYNAMIC     Fa0/1
  10    0007.4d29.fd6d    DYNAMIC     Fa0/1
  10    0007.4d2a.d3af    DYNAMIC     Fa0/1
10    0007.4d30.0a76    DYNAMIC     Fa0/1
  10    0008.740c.ea9c    DYNAMIC     Fa0/1
  10    000e.7fdc.861a    DYNAMIC     Fa0/1
  10    000e.7fde.ce31    DYNAMIC     Fa0/1
  10    0011.0ac8.a057    DYNAMIC     Fa0/1
  10    0014.5e2b.5fad    DYNAMIC     Fa0/1
  10    0016.e3da.b767    DYNAMIC     Fa0/1
  10    0016.e3da.baa7    DYNAMIC     Fa0/1
  10    0017.0eb3.561c    DYNAMIC     Fa0/1
  10    001b.9e17.4b7d    DYNAMIC     Fa0/1
  10    001b.9e17.4b7e    DYNAMIC     Fa0/1
  10    001b.9e17.4b8e    DYNAMIC     Fa0/1
  10    001b.9e17.4bef    DYNAMIC     Fa0/1
  10    001b.9e17.4c08    DYNAMIC     Fa0/1
  10    001b.9eb0.37b0    DYNAMIC     Fa0/1
  10    0060.b0f7.bff4    DYNAMIC     Fa0/1
  10    0090.27df.a337    DYNAMIC     Fa0/1
  12    0001.6c9d.7f70    DYNAMIC     Fa0/1
  12    0001.6c9d.86e5    DYNAMIC     Fa0/1
  12    0004.23c4.3317    DYNAMIC     Fa0/1
  12    0006.5ba4.4930    DYNAMIC     Fa0/1
  12    0006.5ba4.4a75    DYNAMIC     Fa0/1
  12    0006.5bb3.3323    DYNAMIC     Fa0/1
12    0006.5bb3.3323    DYNAMIC     Fa0/1
  12    0006.5bce.20ab    DYNAMIC     Fa0/1
  12    0008.740c.eab7    DYNAMIC     Fa0/1
  12    0008.740c.eda4    DYNAMIC     Fa0/1
  12    0008.7412.070b    DYNAMIC     Fa0/1
  12    0008.7412.09f1    DYNAMIC     Fa0/1
  12    0008.741b.240a    DYNAMIC     Fa0/1
  12    0011.4342.e634    DYNAMIC     Fa0/1
  12    0011.4342.e94d    DYNAMIC     Fa0/1
  12    0011.43a2.5832    DYNAMIC     Fa0/1
  12    0011.43a2.5d57    DYNAMIC     Fa0/1
  12    0011.43a4.8fee    DYNAMIC     Fa0/1
  12    0012.3f7b.8f5b    DYNAMIC     Fa0/1
  12    0012.3f7c.eb2b    DYNAMIC     Fa0/1
  12    0013.7271.92d6    DYNAMIC     Fa0/1
  12    0013.7272.fb1a    DYNAMIC     Fa0/1
  12    0013.72a9.4a0a    DYNAMIC     Fa0/1
  12    0013.72a9.6e92    DYNAMIC     Fa0/1
  12    0013.72a9.9e0b    DYNAMIC     Fa0/1
  12    0014.2246.80e6    DYNAMIC     Fa0/1
  12    0014.2249.43a5    DYNAMIC     Fa0/1
  12    0016.41e3.6850    DYNAMIC     Fa0/1
  12    0016.41e3.b41a    DYNAMIC     Fa0/1
  12    0017.0eb3.561c    DYNAMIC     Fa0/1
 12    0019.db7f.66cc    DYNAMIC     Fa0/1
  12    001a.a0c2.7584    DYNAMIC     Fa0/1
  12    001c.2310.71b1    DYNAMIC     Fa0/1
  12    001e.37cc.c1d8    DYNAMIC     Fa0/1
  12    001f.3b39.b9cf    DYNAMIC     Fa0/1
  16    0017.0eb3.561c    DYNAMIC     Fa0/1
  16    001c.c4fb.93de    DYNAMIC     Fa0/1
  18    0001.6c9d.8868    DYNAMIC     Fa0/1
  18    0001.6c9d.99f6    DYNAMIC     Fa0/1
  18    0013.72a9.9d14    DYNAMIC     Fa0/1
  18    0014.5e2b.5fac    DYNAMIC     Fa0/1
  18    0017.0eb3.561c    DYNAMIC     Fa0/1
  19    0017.0eb3.561c    DYNAMIC     Fa0/1
  20    0000.bc33.3301    DYNAMIC     Fa0/1
  20    0000.bc34.1161    DYNAMIC     Fa0/1
  20    0000.bc34.37e1    DYNAMIC     Fa0/1
  20    0011.43a2.081f    DYNAMIC     Fa0/1
  20    0015.c544.c7a8    DYNAMIC     Fa0/1
  20    0017.0eb3.561c    DYNAMIC     Fa0/1
  20    0020.4a66.ea17    DYNAMIC     Fa0/1
  24    0004.23c4.321c    DYNAMIC     Fa0/1
  24    0017.0eb3.561c    DYNAMIC     Fa0/1
  26    0004.23c4.321c    DYNAMIC     Fa0/1
26    0013.7274.0a49    DYNAMIC     Fa0/1
  26    0017.0eb3.561c    DYNAMIC     Fa0/1
  26    001c.230f.6e61    DYNAMIC     Fa0/1
  26    001c.2310.720d    DYNAMIC     Fa0/1
  26    001e.37cc.a4ec    DYNAMIC     Fa0/1
  28    0000.0c07.ac1c    DYNAMIC     Fa0/1
  28    0015.c7bc.9000    DYNAMIC     Fa0/1
  28    0017.0eb3.561c    DYNAMIC     Fa0/1
  28    001d.a1cc.072c    DYNAMIC     Fa0/1
  28    001d.a1cc.1b76    DYNAMIC     Fa0/1
  28    001d.a1cc.2be8    DYNAMIC     Fa0/1
  28    001d.a1cc.2e3e    DYNAMIC     Fa0/1
  28    001d.a1cc.3756    DYNAMIC     Fa0/1
  28    0050.569f.21cc    DYNAMIC     Fa0/1
  28    0050.569f.7085    DYNAMIC     Fa0/1
  28    00d0.03ab.6c00    DYNAMIC     Fa0/1
  29    0017.0eb3.561c    DYNAMIC     Fa0/1
  30    0017.0eb3.561c    DYNAMIC     Fa0/1
  31    0017.0eb3.561c    DYNAMIC     Fa0/1
  40    0017.0eb3.561c    DYNAMIC     Fa0/1
   1    0017.0eb3.561c    DYNAMIC     Fa0/1
   2    0017.0eb3.561c    DYNAMIC     Fa0/1
   4    0017.0eb3.561c    DYNAMIC     Fa0/1
6    0017.0eb3.561c    DYNAMIC     Fa0/1
   7    0017.0eb3.561c    DYNAMIC     Fa0/1
   8    0001.0328.1838    DYNAMIC     Fa0/1
   8    0009.6b09.4ee6    DYNAMIC     Fa0/1
   8    0009.6b09.4ee7    DYNAMIC     Fa0/1
   8    0009.6b09.4f9e    DYNAMIC     Fa0/1
   8    0009.6b09.f010    DYNAMIC     Fa0/1
   8    0009.6bf1.84d4    DYNAMIC     Fa0/1
   8    000d.6019.8852    DYNAMIC     Fa0/1
   8    000d.6019.f282    DYNAMIC     Fa0/1
   8    000d.6019.f283    DYNAMIC     Fa0/1
   8    000d.60eb.8ead    DYNAMIC     Fa0/1
   8    000e.0cb4.979b    DYNAMIC     Fa0/1
   8    000e.0cb4.98ae    DYNAMIC     Fa0/1
   8    000e.0cb4.98af    DYNAMIC     Fa0/1
   8    000e.0cb4.98f6    DYNAMIC     Fa0/1
   8    0010.1817.a288    DYNAMIC     Fa0/1
   8    0010.1817.a28a    DYNAMIC     Fa0/1
   8    0014.5e1b.8342    DYNAMIC     Fa0/1
   8    0014.5e2b.3567    DYNAMIC     Fa0/1
   8    0014.5e2b.5d81    DYNAMIC     Fa0/1
   8    0014.5e2b.5d8b    DYNAMIC     Fa0/1
   8    0014.5e2b.5def    DYNAMIC     Fa0/1
8    0014.5e68.5c26    DYNAMIC     Fa0/1
   8    0017.0eb3.561c    DYNAMIC     Fa0/1
   8    001a.6466.2a6a    DYNAMIC     Fa0/1
   8    0050.569f.025c    DYNAMIC     Fa0/1
   8    0050.569f.282b    DYNAMIC     Fa0/1
   8    0050.569f.4d0d    DYNAMIC     Fa0/1
   8    0050.569f.72de    DYNAMIC     Fa0/1
   8    0050.569f.7e80    DYNAMIC     Fa0/1
   8    0201.0000.0000    DYNAMIC     Fa0/1
 501    0000.0c07.ac2f    DYNAMIC     Fa0/1
 501    0002.5509.055e    DYNAMIC     Fa0/1
 501    0011.2094.0be0    DYNAMIC     Fa0/1
 501    0017.0eb3.561c    DYNAMIC     Fa0/1
 502    0017.0eb3.561c    DYNAMIC     Fa0/1
 503    0017.0eb3.561c    DYNAMIC     Fa0/1
 504    0017.0eb3.561c    DYNAMIC     Fa0/1
 505    0017.0eb3.561c    DYNAMIC     Fa0/1
Total Mac Addresses for this criterion: 150
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
can you ping please 3750 from 8 port switch and then check show mac-address int gi2/0/28 and fa0/1
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
so I see, that both ports are up and one of them fa0/1 can see traffic from 3750.

one of the reasons for this problem can be incorrect port configuration, so please provide me also with show running-config from both switches and TRIPLE check that we are dealing with fa0/1 and gi2/0/28, please.
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Still the same output.

on the 8 port fa 0/1 dropped to 128 address but the stack still shows nothing.
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
The running configs are posted. The are the exact same.

They are also plugged into the correct ports. 2/0/28 is still alternating amber/green....
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
hm...
as for cisco, amber/green indicates link errors (this we can confirm with your show int gi2/0/28 with input errors)
can you try a different port with the same configuration, please
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Yep. I tried that also... This is the third port (2/0/28)....

I am at a loss. I have no clue... I tired setting the duplex to half on the stack and i get the error:
% Duplex cannot be set to half when speed autonegotiation subset contains 1Gbps
0
NetScaler Deployment Guides and Resources

Citrix NetScaler is certified to support many of the most commonly deployed enterprise applications. Deployment guides provide in-depth recommendations on configuring NetScaler to meet specific application requirements.

 
LVL 21

Expert Comment

by:from_exp
Comment Utility
don't try to change duplex (and there is no half duplex in 1000 mbps mode, so the switch is correct).
let's try to change speed to 100 full on both devices. please configure both interfaces with:

speed 100
duplex full
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
and please also try to use gi0/1 on 8 port switch for interconnection (but without speed settings and with correct config for port gi0/1)
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Tried that.

That drops the connection completely. CDp and VTp no longer work.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
and what about gig port on 3560?
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
have you tried to configure both ports to access mode with vlan 28?
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Same issue. Nothing.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
sorry, haven't got you. can you explain what have you checked?
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
> have you tried to configure both ports to access mode with vlan 28?


I just tried to change it. config looks like this:


interface GigabitEthernet2/0/28
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 28
 switchport mode access
end
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
a bit wrong:
int gi2/0/28
switchport mode access
switchport access vlan 28
end
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
>  a bit wrong:
int gi2/0/28
switchport mode access
switchport access vlan 28
end


I made the configs look like that and same thing. The 8 port can see the stack via cdp but nothing else. Can't ping etc..
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
it is very strange....
do you have any other switch available for testing?
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
I wish. I would have made the switch long ago...

It's annoying. It should work with that config but for the life of me I can't figure it out.

Thank you for trying.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
I was thinking about placing it inbetween both ciscos.
can you plese do default reset for the 3560?
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Yea, the 8 port isn't in production yet.

I can default it.
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
please do it after that configure only two things:
gig port for interconnection (tagged) and vlan 28 with ip address
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
what are the commands you were thinking?
0
 
LVL 21

Expert Comment

by:from_exp
Comment Utility
for the initial configuration:

conf t
int gi0/1
switchport trunk enc dot
switchport mode trunk
switchportr trunk allowed vlan 28
end
int vlan 28
ip adddress 10.142.28.49 255.255.255.0
no shutdown
end
copy running-config startup-config
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
Didn't work...
0
 
LVL 21

Accepted Solution

by:
from_exp earned 500 total points
Comment Utility
and, please, take a very new one patch cord.
you see, I suppose we are dealing with some very basic problem, that we just oversee
0
 
LVL 1

Author Comment

by:drdingo21
Comment Utility
You are a stud.

I tried 5 different cables at the location all with the same issue. I walked the 8 port next to the stack and gave it shot plugged directly into the stack and it worked with out a problem.


Thanks again for all your help.
0

Featured Post

Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

Join & Write a Comment

#Citrix #Citrix Netscaler #HTTP Compression #Load Balance
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now