?
Solved

Delete & Backspace keys not working - only in Outlook

Posted on 2008-06-20
6
Medium Priority
?
4,795 Views
Last Modified: 2011-03-03
The following problem occurs In Outlook 2003, running on Vista:
When the Backspace or Delete keys are pressed, a message says, "do you want save the changes to "subject of email"? Yes /No /Cancel".  
However, pressing Shift+Backspace will delete normally, one letter at a time to the left of the curser. There appears to be no way of doing a normal forward delete.
If any text is highlighted when Delete is pressed the message appears as above.  If Cancel is then selected, the highlighted text is deleted.  The same occurs with Backspace but only the letter before the curser is deleted.

The computer is located in Switzerland and the keyboard, language and locale settings are all set to French (Switzerland).  The keyboard itself is French Swiss.

The problem does not occur in other programs in use on the computer such as MS Word, Adobe Acrobat, etc.  Only Outlook 2003 is affected.

Any idea how to return keyboard behaviour to normal in Outlook?

Thanks
0
Comment
Question by:ColinH
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 97

Accepted Solution

by:
war1 earned 1000 total points
ID: 21831815
Hello ColinH,

1. Reset the Outlook toolbar template. With Outlook close, do a search for and rename outcmd.dat file. Restart Outlook.  Do the same for frmcache.dat and outlprnt files. Restart Outlook.

In Windows Vista, file is located in C:\<user>\AppData\Roaming\Microsoft\Outlook folder. It is a hidden file, so you have to unhide hidden files. Go to any folder and select Tools > Folders Options > View. Check "Show hidden files and folders". Click OK.

2. Register two important Outlook files. If using Windows xP, go to Start > Run and type regsvr32 OLE32.DLL and hit OK.  Do the same for INETCOMM.DLL

If using Vista and you get an error, run regsvr32.exe from an elevated command prompt. To get an elevated command prompt, right-click on the "Command Prompt" shortcut and select "Run as Administrator".

3. If no joy, an addin could be corrupt. Disable Outlook Addins.  Go to Tools > Options > Other > Advanced Options > Add-in Manager or COMM/Add-ins and disable the add-ins.

If Outlook does not open, go to Start > Run - and type outlook /safe

4. Check if an external program running in the background is interfering with Outlook. Check Firewall, antivirus and other security programs, Yahoo and Google toolbars, and desktop search programs. Disable these programs one at a time.

5. Create a new Outlook profile.
http://support.microsoft.com/kb/829918

6. If no joy, reinstall Outlook.  Go to Add/Remove Programs and highlight Microsoft Office. Click on Install/Uninstall.  A menu will pop allowing you to choose repair or reinstall.

Hope this helps!
war1
0
 

Author Closing Comment

by:ColinH
ID: 31469161
Your directions were clear and accurate and cured the problem without having to  create a new outlook profile.  
Thanks war1
0
 
LVL 97

Expert Comment

by:war1
ID: 21856704
ColinH, glad the problem is fixed.  Which step fixed the problem?
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 

Author Comment

by:ColinH
ID: 21857179
It was disabling the add-ons.  I re-started after that and all was OK.  I then re-enabled the add-ons and it was still OK.

Thanks again
0
 

Expert Comment

by:fonderia
ID: 22563326
I followed the tips down to point 4 but no luck.

When hitting backspace or cancel I got the same message popping up about save or cancel but noticed that its a Microsoft Word warning, not Outlook, so clearly to do with the Word/Office interaction.
I fixed it by Outlook - Options - Mail format tab and removing the 'Use Microsoft Word to Edit email messages'
At least this stopped the problem.

If I select this option again then the problem returns, so clearly there's a hitch in my Outlook/Word set up somewhere.

Thanks


0
 
LVL 97

Expert Comment

by:war1
ID: 22563363
fonderia, you may want to ask a new question.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Large Outlook files lead to various unwanted errors and corruption issues. Furthermore, large outlook files can also make Outlook take longer to start-up, search, navigate, and shut-down. So, In this article, i will discuss a method to make your Out…
This article describes how to import Lotus Notes Contacts into Outlook 2016, 2013, 2010 and 2007 etc. with a few manual steps. You can easily export and migrate Lotus Notes contacts into Microsoft Outlook without having to use any third party tools.
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…
Suggested Courses

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question