Solved

Push Mail suddenly stopped working - Exchange 2003

Posted on 2008-06-20
31
1,601 Views
Last Modified: 2012-08-13
Exchange has suddenly stopped "Pushing" email out to smartphone users.
Situation as follows:

Users can successfully send mail from smartphones.

Smartphone looks like it has synced successfully - ie runs through the noraml "syncing folders" routine and then says "connected" however no new mail is actually there after the sync.

I have rebooted the server but it made no difference - I can't find anything obviously wrong.

Exchange 2003 SP2
Smartphones: HTC S710 / S730

0
Comment
Question by:grahamsmyth
  • 15
  • 11
  • 5
31 Comments
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21831874
Is OWA functioning?
Has the SSL cert (if used) expired?

Both of those have caused me grief in the past, but not to the extent you are experiencing.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21831922
OWA is working perfectly

No SSL cert is being used.
0
 
LVL 15

Expert Comment

by:LegendZM
ID: 21831949
Are there any errors in the event log of the exchange server? If so, paste error / event ID
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21831985
Can we also assume that outbound mail is working correctly for the desktop users?
Are there any mails in your queue that were sent from the phones?
Check your IIS logs as well.
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21831991
Correction.....inbound mail to the desktop users.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21836924
Inbound mail is working fine for Desktop Users.

Extraxt from IIS Log as follows:(sorry this does not mean much to me)

2008-06-19 10:00:04 W3SVC1 192.168.10.18 PROPFIND /exchange/Graham.Smyth@antrim.gov.uk/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/SmartPhone/401EFC8D840503A5BEE3D1CFF9734A52 - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 PROPFIND /exchange/Graham.Smyth@antrim.gov.uk/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/SmartPhone/401EFC8D840503A5BEE3D1CFF9734A52 - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 207 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 GET /exchange/Graham.Smyth@antrim.gov.uk/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/SmartPhone/401EFC8D840503A5BEE3D1CFF9734A52/FolderSyncFile - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 200 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/SmartPhone/401EFC8D840503A5BEE3D1CFF9734A52/FolderHierarchySearch - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/SmartPhone/401EFC8D840503A5BEE3D1CFF9734A52/FolderHierarchySearch - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 207 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 207 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 207 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 207 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/ - 80 ANTRIMBC\SmythG 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 207 0 0
2008-06-19 10:00:04 W3SVC1 192.168.10.18 POST /Microsoft-Server-ActiveSync User=smythg&DeviceId=401EFC8D840503A5BEE3D1CFF9734A52&DeviceType=SmartPhone&Cmd=FolderSync&Log=V4TNASSC:0A0C0D0FS:0A0C0D0SP:1C7I5131S134568R0S0L0H0P 80 antrimbc\smythg 212.183.136.194 MSFT-SPhone/5.2.404 200 0 0


Just to Clarify the above sync did not return any new mail to the phone.

I can see no related errors in the event logs
0
 
LVL 15

Expert Comment

by:LegendZM
ID: 21838278
Have you checked the smart phones to make sure they're not out of space?
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21838312
Yeah still plenty of space - my own has 100+MB free
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21841038
It now appears that the phone in syncing howver only pully mail in up until the previous day - ie

Today is Sunday  - no mail synced that received today but mail received Yestreday has now been updated on the phone !!

Just gets stranger !!!
0
 
LVL 15

Expert Comment

by:LegendZM
ID: 21841452
Have you tried power cycling the handhelds?  Windows mobile 5 or 6?
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21841540
Yeah - tried power cycling.

1 handset is Mobile 5
All others are Mobile 6
All affected.

0
 
LVL 15

Expert Comment

by:LegendZM
ID: 21841629
As Rikketyrik said, are there any mails queuing up in your ESM?

ESM -> Servers -> expand server -> Queues
0
 
LVL 15

Expert Comment

by:LegendZM
ID: 21841657
Also, do users have a lot of mail/attachments in their inbox? Have them try moving to a sub folder in outlook, and then see if Activesync starts syncing back up.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21841720
No Mail in the Queue
My own inbox only has 87 mails (the rest are in sub folders)  but still not syncing properly.
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21847085
Can you check to see if their passwords have expired? If they have not expired, I would suggest resetting one of them to see if that helps. The logs that you attached are throwing error 401

2008-06-19 10:00:04 W3SVC1 192.168.10.18 SEARCH /exchange/Graham.Smyth@antrim.gov.uk/NON_IPM_SUBTREE/Microsoft-Server-ActiveSync/SmartPhone/401EFC8D840503A5BEE3D1CFF9734A52/FolderHierarchySearch - 80 - 192.168.10.18 Microsoft-Server-ActiveSync/6.5.7638.1 401 1 0

Here is a link to view other errors:
http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 2

Author Comment

by:grahamsmyth
ID: 21847307
I reset my own password - but still noting !
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21847398
Can you force a synch, and send a snip of the IIS log files that are generated for your sync?

Did you set the new password on the device as well?
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21848192
Forced Sync Log Snippet :

2008-06-23 16:58:02 W3SVC1 192.168.10.18 GET /exchange/graham.smyth - 80 - 192.168.99.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 401 1 0
2008-06-23 16:58:02 W3SVC1 192.168.10.18 GET /exchange/graham.smyth - 80 antrimbc\administrator 192.168.99.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 302 0 0
2008-06-23 16:58:03 W3SVC1 192.168.10.18 GET /exchange/graham.smyth/ - 80 antrimbc\administrator 192.168.99.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 200 0 0
2008-06-23 16:58:03 W3SVC1 192.168.10.18 GET /exchange/graham.smyth/Inbox/ Cmd=contents 80 - 192.168.99.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 401 2 2148074254
2008-06-23 16:58:03 W3SVC1 192.168.10.18 GET /exchange/graham.smyth/ Cmd=navbar 80 antrimbc\administrator 192.168.99.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1) 200 0 0
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21848712
Are there any service accounts that may have expired passwords?
Any recent changes?
Have you tired wiping one of the phones and setting it up again?
Can you double check the event logs for any errors? Make sure you don't have any filters running.
Any errors on the phone itself?

Everywhere I look, the 401 error is pointing to an authentication problem of some kind. It may even be and NTFS permission on an IIS folder.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21853657
Have Started seeing some information come through in the event logs:

Event Type:      Information
Event Source:      MSExchangeTransport
Event Category:      Routing Engine/Service
Event ID:      994
Date:            24/06/2008
Time:            09:36:42
User:            N/A
Computer:      ANTRIM8
Description:
Following connector's linkstate is suppressed because it either points to or comes from a leaf RG node. <CN=WebMarshal SMTP Connector,CN=Connections,CN=First Routing Group,CN=Routing Groups,CN=First Administrative Group,CN=Administrative Groups,CN=Antrim Borough Council,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=antrim,DC=gov,DC=uk>

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


------------------------------------


Event Type:      Information
Event Source:      MSExchangeTransport
Event Category:      Routing Engine/Service
Event ID:      966
Date:            24/06/2008
Time:            09:45:06
User:            N/A
Computer:      ANTRIM8
Description:
This master server received a one level (Connector) call back. Specific DS change has been detected and major version increase will occur as a result. This should result in reset route or updated routing packets being sent out to its subordinate servers and neighboring routing groups.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21857742
Some more erros coming through:

Event Type:      Error
Event Source:      Server ActiveSync
Event Category:      None
Event ID:      3005
Date:            24/06/2008
Time:            17:43:07
User:            ANTRIMBC\mcmullani
Computer:      ANTRIM8
Description:
Unexpected Exchange mailbox Server error: Server: [antrim8.antrim.gov.uk] User: [Ivor.McMullan@antrim.gov.uk] HTTP status code: [503]. Verify that the Exchange mailbox Server is working correctly.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


-------------------


Event Type:      Error
Event Source:      MSExchangeFBPublish
Event Category:      General
Event ID:      8197
Date:            24/06/2008
Time:            17:37:00
User:            N/A
Computer:      ANTRIM8
Description:
Error initializing session for virtual machine ANTRIM8. The error number is 0x8004011d. Make sure Microsoft Exchange Store is running.

For more information, click http://www.microsoft.com/contentredirect.asp.
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21857969
Found a KB article for you to look at:

http://support.microsoft.com/kb/937635/en-us
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21858597
Thanks Rikketyrik - everything is setup as per the article above.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21858983
I am begining to wonder if this prob is related to a time sync issue between DC

Event Type:      Warning
Event Source:      W32Time
Event Category:      None
Event ID:      24
Date:            24/06/2008
Time:            15:24:17
User:            N/A
Computer:      ANTRIM8
Description:
Time Provider NtpClient: No valid response has been received from domain controller Antrim01.antrim.gov.uk after 8 attempts to contact it. This domain controller will be discarded as a time source and NtpClient will attempt to discover a  new domain controller from which to synchronize.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21859062
That could be....do the times appear to be in synch on the machines?
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21859120
The actual server times (ie the clock bottom right) all appear to be fine.  However if I log on to the PDC and run w32tm /monitor I get the following result:


C:\Documents and Settings\administrator.ANTRIMBC>w32tm /monitor
Antrim01.antrim.gov.uk *** PDC *** [192.168.10.4]:
    ICMP: 0ms delay.
    NTP: +0.0000000s offset from Antrim01.antrim.gov.uk
        RefID: (unknown) [207.46.197.32]
antrim5.antrim.gov.uk [192.168.10.5]:
    ICMP: 4ms delay.
    NTP: +0.0112286s offset from Antrim01.antrim.gov.uk
        RefID: Antrim01.antrim.gov.uk [192.168.10.4]
ANTRIM02.antrim.gov.uk [192.168.10.10]:
    ICMP: 0ms delay.
    NTP: +0.0040528s offset from Antrim01.antrim.gov.uk
        RefID: Antrim01.antrim.gov.uk [192.168.10.4]

I am interested in the 207.46.197.32 - should I be able to ping this? I would of thought so but can't

0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21859534
Not necessarily. they may be blocking ICMP. I wo uld find a different NTP server though...just to be safe and get them all synched.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21859617
Any idea how I change the NTP used by the PDC?
0
 
LVL 3

Accepted Solution

by:
Rikketyrik earned 500 total points
ID: 21860102
net time /setsntp:(NTP Server IP address)
Restart the w32time service after.
0
 
LVL 2

Author Comment

by:grahamsmyth
ID: 21860192
Forced resync using by running -

w32tm /resync /rediscover

All back up and Running !!!!!!!!!!!!!!!! - Syncing perfectly !!
0
 
LVL 3

Expert Comment

by:Rikketyrik
ID: 21860605
Excellent!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now