Solved

can you pu dial back up on Serial line PVC that has 2 DLCI's?

Posted on 2008-06-20
7
758 Views
Last Modified: 2013-12-12
I have a remote site that has one cisco router with 1 CSU/DSU connecting to the S1 interface.  On that I have two DLCI's that go to the Frame cloud.  I have DDR backup dial interface, but it is married to the s1.1 interface.  I want to use the dialbackup on the S1 interface so that when the whole circuit goes down, it will activate.  Now when only one of the DLCI's goes down the dialback up activates.  I have tried to move the dailbackup statement to the S1 interface with no luck.....thoughts guru's?
Here is a drawing and the config file....
Editied config.....
clock timezone pst -8
clock summer-time pdt recurring
ip subnet-zero
no ip domain-lookup
!
chat-script dialit "" "ATH" TIMEOUT 10 OK "ATDT\T" TIMEOUT 60 CONNECT
chat-script rusr "" "ATV1E0&Q1" TIMEOUT "OK" ""
!
!
!
interface Ethernet0
 description Lan in KENT
 ip address 128.3.250.0 255.255.0.0
 ip helper-address 128.1.0.29
 ip helper-address 128.1.0.26
 ip helper-address 128.1.0.96
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
!
interface Serial1.1 point-to-point
 description WAN CONNECTION TO NORFOLK DHEC.577331
 backup delay 30 30
 backup interface Async1
 ip address 128.203.0.2 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 frame-relay class vcfif
 frame-relay interface-dlci 100  
!
interface Serial1.2 point-to-point
 description WAN Connection to Chester MCI
 ip address 128.103.0.2 255.255.0.0
 no ip route-cache
 no ip mroute-cache
 frame-relay interface-dlci 225  
!
interface Async1
 ip address 128.200.0.5 255.255.0.0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 keepalive 10
 dialer in-band
 dialer idle-timeout 300
 dialer wait-for-carrier-time 120
 dialer map ip 128.200.0.1 name MDVBACKUP modem-script dialit broadcast 17578574052
 dialer map ipx BAC0001.0004.2714.dbc0 name MDVBACKUP modem-script dialit broadcast 17578574052
 dialer-group 1
 async default routing
 async dynamic address
 async dynamic routing
 async mode dedicated
 ppp authentication chap
!
router eigrp 500
 redistribute connected
 network 128.3.0.0
 network 128.103.0.0
 network 128.200.0.0
 network 128.203.0.0
 no auto-summary
!
no ip classless
ip route 0.0.0.0 0.0.0.0 128.103.0.1
ip route 0.0.0.0 0.0.0.0 128.203.0.1 50
ip route 128.1.0.0 255.255.0.0 128.203.0.1
ip route 128.1.0.0 255.255.0.0 128.103.0.1 50
no ip http server
!
!
map-class frame-relay vcfif
 frame-relay end-to-end keepalive mode request
logging 128.3.0.3
access-list 60 permit 128.1.50.2
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit



fife-router-issue.jpg
0
Comment
Question by:redcell5
  • 3
  • 2
7 Comments
 
LVL 28

Expert Comment

by:Jan Springer
ID: 21845869
Do your two frame-relay interfaces terminate to the same router at the other end?

Have you looked at frame-relay multilink?  You set the IP address on the multilink (ppp) interface at both ends and specify the dialer backup on that same interface.

I haven't tried it but, if you can do this, logically it should work.
0
 

Author Comment

by:redcell5
ID: 21846853
no.....the DLCI's go to different parts of the country.  
0
 
LVL 12

Expert Comment

by:Freya28
ID: 21857249
why dont you just use an ISDN backup
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 28

Expert Comment

by:Jan Springer
ID: 21857394
The point is to failover to a 3rd option only after the first two are in a down state.

If the circuits were terminating to the same router, a multilink interface with the failover would work -- which is what is needed, a single interface to handle both serial interfaces.  I can't find any documentation that provides for a primary and secondary backup interface.
0
 

Author Comment

by:redcell5
ID: 21858331
feya28, no help.
jesper...It is one physical interface with 2 sub interfaces "DLCI's"   So the question remains:
How to put the backup on the S1 so that if both DLCI's go down, the dialback will kick in...
0
 
LVL 28

Accepted Solution

by:
Jan Springer earned 500 total points
ID: 21858868
A subinterface is an interface.  They are both layer 3 (routed) and terminating at two different routers.  Because of that, you can't do frame-relay multilink.

Logically, you would need to bind both interfaces to a single interface and when both T1s when down, that single interface would go down initiating the dial backup.

Your only other option would be to have a monitoring script on a server that could initiate the dialup when it determined that both circuits were down.
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
EIGRP Multicast vs Unicast 7 64
VirtualBOX on GNS3 11 116
VIRL IP adress 3 69
Do you think below two ipv6 routes are the same thing? 4 32
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question