Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1133
  • Last Modified:

Changed disk to dynamic in bootcamp, now apple bootloader cannot detect partitions.

Under XP in bootcamp, I changed the disk to dynamic and now the apple bootloader cannot read my MBR or partition table. I boot from my OSX cd and try to see if I can mount it in Terminal and cannot. Obviously diskutil will not work. I bought a new HDD and installed leopard on it. Now my problem is that all my information is on my dynamic disk, and I need to recover it to my new HDD or an external. I used a SATA to USB converter to see if i could get Ubuntu to mount the drive and it worked. So I navigated to the User folder and found that permissions had been set to lock me out. Only the owner/creator of the files can read/write. I tried chmod 775 <folder> with no success. How do I take ownership or change permissions? Or is there a better way to read/write these files?
0
m3thical
Asked:
m3thical
  • 2
1 Solution
 
rindiCommented:
You could try connecting the disk to an XP PC and change permissions there, or make a ubcd4win, boot the PC with that and try changing permissions / copying files that way. If that is of no help, and you have norton's ghost, image the disk, then restore the image, or use the copy function. That should restore it as a basic disk. After that your original setup might work again.

http://ubcd4win.com
0
 
m3thicalAuthor Commented:
Well, the problem is that through the Dynamic Disk conversion, it messed with the MBR. My OSX partition is HFS, which cannot be natively read by windows, so mounting it in XP is out of the question. So linux is the middle man who can read both HFS and NTFS. I am going to try to execute chown or chgrp on the folder, which should change ownership. Those are my next steps and I will update on the status of the issue. If I restore the image, the MBR will still be messed up, and I have no idea how to edit an OSX bootloader or MBR to point it in the right direction of my partitions. If it were LILO or GRUB, I could stand a chance ;).
0
 
walsellersCommented:
Intel-based Macs can only boot from GUID- or Apple Partition Map- formatted drives (FireWire or USB externals).  PowerPC-based Macs only boot from Apple Partition Map-formatted drives (Firewire externals only).   Neither will boot from an MBR-formatted disk.

(For the nit-picky, I know that the OSX installers for Intel-based Macs will only allow GUID drives, but OSX can later be copied to an APM drive and work.  I've done it.)

To change which installation of OSX to use at startup, press and hold down the "Option" key immediately on startup.  A grey screen will be shown with all acceptable OSX installations being displayed. (This can take a while on a PowerPC-based Mac.)  Pick a volume and press return or the arrow button on the right. (Depending on what your computer shows you.)

As for the permissions problem when accessing via Linux, I can't say why you couldn't change them.  Since the Mac OS uses User ID numbers underneath, it could be that they are mis-matched.  I've seen this happen between two installs of Mac OS when the account name is the same on two disks, but the user id is different underneath.

In Mac OS X, you can select the icon of an external, go to the File menu and select "Get Info".  At the bottom of the window should be a button marked "Ignore permissions on this drive."  With that checked, you might be able to access all its files.  (Will not work on the boot drive.)

0
 
m3thicalAuthor Commented:
chown root <file> seemed to work and reset the permissions allowing me to copy. But then the drive stopped spinning after I powered it down.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get 10% Off Your First Squarespace Website

Ready to showcase your work, publish content or promote your business online? With Squarespace’s award-winning templates and 24/7 customer service, getting started is simple. Head to Squarespace.com and use offer code ‘EXPERTS’ to get 10% off your first purchase.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now