?
Solved

Clear Old RSA Keys on VmWare server

Posted on 2008-06-21
6
Medium Priority
?
831 Views
Last Modified: 2008-06-22
I'm connecting to my VMware server using Putty my server is cashing the old server's RSA key. How do I clear the RSA key's from my server?
0
Comment
Question by:compdigit44
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 14

Expert Comment

by:agriesser
ID: 21838408
What machine does cache what RSA key?
Could you be a bit more precise, please?

The RSA key for SSH connections on VMware server is generated once after the ssh package has been installed. Usually you don't need to change this key (only if the hostname changes). Is this the case?
0
 
LVL 20

Author Comment

by:compdigit44
ID: 21838993
I'm connecting to my remote vmware server via Putty from my Windows XP workstation. I had to do a format reinstall on this vmware server it has the same name but the key has changed
0
 
LVL 14

Expert Comment

by:agriesser
ID: 21839062
And now you're getting a warning about a potential security breach when PuTTY tries to connect to your VMware server? Usually clicking on "Yes, I'm sure" or something like this when this warnings arrives fixes this issue as it'll automatically overwrite the old key.

To clear PuTTY's keys, you have to delete them out of the registry.
To do that, click "Start" -> "Run" and type "regedit".

Go to HKEY_CURRENT_USER\Software\SimonTatham\PuTTY\SshHostKeys and delete the keys in question.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 20

Author Comment

by:compdigit44
ID: 21839117
I just tried it but it didn't work. This is the messge that I'm getting on the remote system:
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending key in /root/.ssh/known_hosts:1
0
 
LVL 14

Accepted Solution

by:
agriesser earned 2000 total points
ID: 21839132
Ah, ok, you're getting this message on a linux machine.
Open the file /root/.ssh/known_hosts with your favourite editor and delete the first line (sometimes you also need to delete the second line too, depending on the OpenSSH version used).

Save the changes to this file and try again.
0
 
LVL 20

Author Comment

by:compdigit44
ID: 21841223
IT WORKED!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will giveā€¦
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Teach the user how to join ESXi hosts to Active Directory domains Open vSphere Client: Join ESXi host to AD domain: Verify ESXi computer account in AD: Configure permissions for domain user in ESXi: Test domain user login to ESXi host:
This video shows you how easy it is to boot from ISO images for virtual machines with the ISO images stored on a local datastore on the ESXi host.

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question