[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Flash video not seen in Firefox iframe embed (sound works)

Posted on 2008-06-21
3
Medium Priority
?
1,352 Views
Last Modified: 2013-12-08
References:

1. View main page here:  http://www.trishah.com/test/
2. Problem is with the page that loadw into the iframe (to the right of menu) from the 3rd link down on the left side accordion menu titled "Flex Protex Advanced Formula".
3. Original flash movie page can be found at: http://itvventures.com/FlexProtex.aspx?ID=www
4. Link to the flash movie that I'm using is: http://mediafiles.itvventures.com/ventures-shows/flex.swf
5. Page works correctly in FF2 when not in iframs: http://trishah.com/test/flex_protects_advanced.html

The movie runs fine in IE, however, in FF2 I can hear the sound but there is no visual.

The ISP server hosting the pages is on Linux.

FYI: I know nothing about flash so please be clear with any explanations.  Thanks.
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width="300" height="250" id="header_home" align="left">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="http://mediafiles.itvventures.com/ventures-shows/flex.swf" /><param name="loop" value="false" wmode="transparent" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" /><embed src="http://mediafiles.itvventures.com/ventures-shows/flex.swf" loop="false" quality="high" bgcolor="#ffffff" width="300" height="250" name="header_home" align="left" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" wmode="transparent" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>

Open in new window

0
Comment
Question by:trishahdee
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 14

Expert Comment

by:agriesser
ID: 21838784
Try to make the video smaller or the region in the middle broader so that the video has place to show.
To me it looks like as if there's not enough place in the iframe for the video to show (that might be a firefox issue, but it's worth a try).
0
 
LVL 14

Expert Comment

by:agriesser
ID: 21838801
Oh, another thing I found out:

There's a syntax error in your flash parameters. Currently it reads:

<param name="loop" value="false" wmode="transparent" />

But it should read:

<param name="loop" value="false" />
<param name="wmode" value="transparent" />

but I don't think that this is the reason why firefox refuses to play this video when it's in the iframe...
0
 

Accepted Solution

by:
trishahdee earned 0 total points
ID: 21842257
I figured it out!  It was a problem with DocType.  I needed to use 1.0 Strict for the accordion menu but 4.0 transitional for the flash.  So I put the accordion menu in an iframe so each page would have it's own doctype and now the flash movie works in Firefox.

thanks for your help agriesser.
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently found myself in a Corporate Situation where the client had requested blocking access to any and all websites except his own Domain? Easy? I am sure this would be your answer but their requirement was, this has to be done without using…
Several part series to implement Internet Explorer 11 Enterprise Mode
The goal of the tutorial is to teach the user how to use the auto adjust feature and what the different options do. When your video is not working right you can choose the auto adjust feature to help choose your settings.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question