Solved

Images and Style Sheets not loading in Localhost after PHP install on IIS 5.1

Posted on 2008-06-21
5
464 Views
Last Modified: 2013-12-13
I just installed PHP 5.2 on my Windows XP Pro machine running IIS.  After the configuration, I found that my websites are no longer loading images and style sheets in Localhost.  They're fine on the remote webserver and all the file paths are correct, but in localhost mode the pages display with no styles and the images are broken place holders.

I get this issue on both Firefox and IE.
Any suggestions?
0
Comment
Question by:amar556
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 49

Expert Comment

by:Roonaan
ID: 21838587
Hello amar556,

PHP shouldn't affect your stylesheets and images. Can you call the images and stylesheets directly?

Regards,

Roonaan
0
 

Author Comment

by:amar556
ID: 21838602
Hi Roonaan,

No I can not.  when I try to access the images directly, I get the following error:

HTTP 403.2 - Forbidden: Read Access Forbidden
Internet Information Services

Technical Information (for support personnel)

    * Background:
      This error can be caused if there is no default page available and directory browsing has not been enabled for the directory, or if you are trying to display an HTML page that resides in a directory marked for Execute or Script
0
 
LVL 49

Accepted Solution

by:
Roonaan earned 125 total points
ID: 21838616
Are you sure your files are accessible to the IIS server? Does your IIS run on the correct account?
I'm have very little experience in IIS security, so not sure what the other options for this platform are.
0
 

Author Comment

by:amar556
ID: 21838670
Yes, things were working beautifully before I installed PHP (and Firefox 3).  My IIS is running under the IUSR_* account with "Anonymous access" checked for the Directory Security setting.

I only made two changes to my IIS configuration when I installed PHP:
1) For my Default Website I changed the Execute Permissions to "Scripts Only"
2) I added the PHP5isapi.dll to the Mappings configuration.

After that I noticed my local sites weren't loading at all giving the 403.2 error I described above.  So I changed the Execute Permissions to "Scripts and Executables".  This resulted in the pages loading, but neither the style sheets nor the images would load.

NOTE: all my local sites are *.asp applications.  Traditional ASP 3.0 sites.
0
 

Author Comment

by:amar556
ID: 21838736
I figured it out!
Looks like I need to have the "Read" box checked in the Home Directory tab of the Default Website in IIS.  Once I did that, everything loaded just fine.
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article discusses four methods for overlaying images in a container on a web page
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.
Saved searches can save you time by quickly referencing commonly searched terms on any topic. Whether you are looking for questions you can answer or hoping to learn about a specific issue, a saved search can help you get the most out of your time o…

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question