Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 837
  • Last Modified:

Screen saver password prompt, even though setting is off.

   I am seeing several user accounts on company machines that are having this particular problem with the welcome screen being displayed after the screen saver closes, even though the checkbox for displaying the welcome screen, in the screensaver tab,  is not checked off. I also tried disabling the screensaver password protect by using the group policy item:
-> User Configuration -> Administrative Templates -> Control Panel
-> Display -> [Password protect the screen saver]
The screensaver in question is the My Picture Slideshow one.
If you've seen this before, how did you solve it?
0
tau161
Asked:
tau161
  • 2
  • 2
1 Solution
 
blimsterCommented:
Check that the following value on the local machine isn't set to 1

HKCU\Control Panel\Desktop\ScreenSaverIsSecure

if it is set to 1 try setting it to 0.

If it is, it might be taking precedence over Group policy.

Do an RSOP.MSC on the local machine to check if the policy that you set is actually being taken by the local host.
The Local Group Policy of the workstations might have them set to enable and again may be taking precedence over Group Policy.

Again look "RSOP.MSC" to see if it's taking the applied policy
0
 
tau161Author Commented:
Thank you for the reply.

HKCU\Control Panel\Desktop\ScreenSaverIsSecure  is set to 0.

RSOP.msc:
"User Configuration/Administrative Templates/Control Panel/ Display/Password protect the screen saver"
shows up as Disabled.
0
 
blimsterCommented:
Humm..  Are those mchines running maditory profiles?
0
 
McKnifeCommented:
This problem drove me mad, too. In my case it was the other way round  (did not lock the screen) and just on a few computers.
What you could do as a workaround is distribute a registry setting that prevents the screen from being locked immediately after the screen saver starts:
--
1. Click Start, click Run, type regedit, and then click OK.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
3. On the Edit menu, point to New, and then click String Value.
4. Type ScreenSaverGracePeriod, and then press ENTER.
5. Double-click ScreenSaverGracePeriod.
6. Click Decimal under the Base heading, and then enter a number in the Value data box that represents the password activation delay in seconds.
You can enter any whole number between 0 and 2,147,483 (approximately 24 days). A value of zero indicates no password protection delay. There is no default entry.
7. Click OK, and then exit Registry Editor.
--
To distribute it, you could use a startup script, an msi package or group policy preferences.
0
 
tau161Author Commented:
I ended up making my own solution involving loading a registry hive, but I love the novelty of your solution so I'm giving you the points anyway.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now