• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3257
  • Last Modified:

VBSCRIPT Not Working

Something has disabled vbscript amd windows scripting on my xp machine.  Can someone tell me how to enable/disable these associations?

Thanks,
Howard
0
Howard Bash
Asked:
Howard Bash
  • 6
  • 5
  • 3
  • +1
2 Solutions
 
cybrexusCommented:
try Start > Run > type "regsvr32 vbscript.dll" (without quotes) and hit enter
See if it solves your problem
0
 
Howard BashSenior Software EngineerAuthor Commented:
The regsvr32 succeeded in registering the dll, but it still opens in notepad when i double click on it.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
orangutangCommented:
0
 
Howard BashSenior Software EngineerAuthor Commented:
I tried the first URL.  It instructed me to set the file association for vbscript to be : C:\WINDOWS\System32\WScript.exe %13 %*

I thought the program was named vbscript.exe.  But,  I made the change as instructed and it did not work.

The error mesage is :

there is no file extension in "C:\Documents and Settings\My User Name\Desktop\"C:\Documents".

0
 
sramesh2kCommented:
Hi hbash,

Run the .vbs fix for Windows XP from here.

VBScript Files Open With Notepad - The Winhelponline Blog:
http://www.winhelponline.com/blog/vbscript-files-open-with-notepad/

0
 
cybrexusCommented:
yep tried the link above, works well for me, should definitely solve the issue
well found
0
 
Howard BashSenior Software EngineerAuthor Commented:
This fixed the VBS files but the wfs files are still launching notepad.
0
 
cybrexusCommented:
make sure your extension is wsf and not wfs
0
 
Howard BashSenior Software EngineerAuthor Commented:
It is wsf.  It shows an associated icon (same as .vbs).
0
 
cybrexusCommented:
right click on the file > Open With > Choose Program > browse Windows\System32\wscript.exe
check Always use the selected program to open this kind of file
click OK
0
 
sramesh2kCommented:
0
 
Howard BashSenior Software EngineerAuthor Commented:
I am running Windows XP Pro.   Will this vista reg patch work there also?
Thanks,
Howard
0
 
cybrexusCommented:
did you try to set wscript as default program as in my previous comment?
0
 
sramesh2kCommented:
Sorry! The XP version of the fix is here:
http://windowsxp.mvps.org/reg/wsffix_xp.zip
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 6
  • 5
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now