Solved

Remote desktop wont work after changing provider

Posted on 2008-06-22
10
588 Views
Last Modified: 2013-11-21
I recently changed from verizon to Comcast business as my Internet provider.  I successfully change the verizon modem to the Comcast modem and everything seemed to be working fine.  However when I try to use remote desktop connection from home to access the windows 2003 server I'm no longer able to do it as I have for the past three years.  I am able to access the server from a client computer using rdp but can no longer do it from home.  I am able to ping the server IP address from home.

Any suggestions as to why I can no longer connect to the server from home
0
Comment
Question by:DrFred2004
  • 4
  • 2
  • 2
  • +2
10 Comments
 
LVL 12

Accepted Solution

by:
WallD earned 100 total points
ID: 21840641
is your router blocking TCP port 3389 that RDP uses ? or even your service providor

there are details here about changing the port you use for fdphttp://www.petri.co.il/change_terminal_server_listening_port.htm

Dont know if it will help
0
 
LVL 14

Assisted Solution

by:agriesser
agriesser earned 200 total points
ID: 21840785
You should check if any ports are open on the public ip address your router @work uses. A tool to do a port scan f.ex. would be `nmap` f.ex. There are also some websites that offer online portscans.
If you tell me the IP, I can do a portscan for you, if desired.
0
 

Author Comment

by:DrFred2004
ID: 21840808
is that safe to do
0
 
LVL 14

Expert Comment

by:agriesser
ID: 21840832
That depends on how much you trust the router/firewall at work.
The safest way (e.g. no other possible bad people involved) is to do the portscan on your own or ask your provider to check if port 3389 is open and forwarded to your terminal server correctly if you don't have access to the router yourself.
0
 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 100 total points
ID: 21840931
Was the modem changed at the business/server network or home?

If home:
-Do you connect using a VPN?  If so either the modem is a combined modem and router unit and you have another router (VPN's do not like dual routers at one end), or the service provider does not support the VPN traffic. Comcast does not support VPN's in some areas.

If work:
 -were you connecting to an IP address or domain name. That will have changed with the new modem
 -If the new modem is a combined modem and router, port forwarding of port 3389 to the next device (server or another router) will need to be reconfigured
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 

Author Comment

by:DrFred2004
ID: 21840946
I called Comcast and they needed to do something from their end to forward the port. There went four hours of my morning.  They fixed it in 10 seconds
0
 
LVL 1

Assisted Solution

by:sgerling
sgerling earned 100 total points
ID: 21840953
As a side note, it's really not a good idea to use RDP over the public Internet.  Using some form of VPN tunnel is much safer.  The Cisco VPN client (if you use Cisco hardware) is a great simple solution, and the Citrix Access Gateway is a more robust option that uses a web-based login to create an SSL VPN.  There are also other options out there, but Cisco and Citrix are both popular choices for VPNs.
0
 
LVL 14

Expert Comment

by:agriesser
ID: 21840959
Good to hear that it works now for you. I figured that it must have had something todo with the port forwarding respectively the new firewall/router.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 21840982
>>"I am able to ping the server IP address from home."
If you are not using a VPN and referring to pinging the private IP, this should be fixed as well. As a security measure routers should be set to deny ICMP requests  (pings). If not you are exposed to Denial Of Service attacks.

I assumed it was the home router. If so I would be curious as to what they did, as there is no port forwarding at that end. If the office they probably put it in bridge mode. They will not normally configure port forwarding as that requires knowledge of your private network.
0
 
LVL 14

Assisted Solution

by:agriesser
agriesser earned 200 total points
ID: 21924206
Please don't forget to close this question if it has already been solved.
0

Featured Post

Are your end users making ugly email signatures?

Have you left it up to your end users to create their own email signatures? Are they forgetting to add the company logo or using garish font colors? Take control and ensure all users have the same email signature.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Server 2008 Cluster Fail-over Errors 5 81
Group Policy Question 7 64
2003 File Server upgrade 11 54
Auditing domain account logon attempt, failure, lockout 2 29
Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Migrating to Microsoft Office 365 is becoming increasingly popular for organizations both large and small. If you have made the leap to Microsoft’s cloud platform, you know that you will need to create a corporate email signature for your Office 365…
With the power of JIRA, there's an unlimited number of ways you can customize it, use it and benefit from it. With that in mind, there's bound to be things that I wasn't able to cover in this course. With this summary we'll look at some places to go…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now