Solved

Trying to config a Cisco 2800

Posted on 2008-06-22
15
1,106 Views
Last Modified: 2008-07-31
Greeting,
I have a Cisco 2600 currently in place and I am trying to replace it with a Cisco 2800 because the 2600 only has enough slots for 2 csu/dsu cards and we are adding a new T1 we currently have 2,
So I thought I could just copy the config from the 2600 and apply it to the 2800 and then add the third interface for the new T1, but when I ordered the 2800 I recived 2 T1 controller cards and 1 csu/dsu card
so now Im faced with the challenge of configing this new 2800 with 2 T1 controllers cards and one csu/dsu card.
The 3 interfaces are part of a multilink group,
any Ideas on how to config this ?
Thanks
0
Comment
Question by:Smaxon
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 7
15 Comments
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21841600
If you post your 2600 & 2800 config, it'll be easier.
0
 

Author Comment

by:Smaxon
ID: 21841981
here is the current config on the 2600.
Current configuration : 2452 bytes
!
version 12.1
service tcp-keepalives-in
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3
!
logging buffered 16000 debugging
enable secret 5 .
enable password 7 94D
!
!
!
!
!
ip subnet-zero
no ip source-route
ip cef
!
no ip bootp server
!
!
!
interface Multilink1
 ip address xxx.xxx.xx.xxx 255.255.255.252
 no ip redirects
 no ip unreachables
 no cdp enable
 ppp multilink
 multilink-group 1
!
interface GigabitEthernet0/0
 ip address xxx.xxx.xx.xxx 255.255.255.240
 ip verify unicast reverse-path
 no ip proxy-arp
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 ip verify unicast reverse-path
 no ip redirects
 no ip proxy-arp
 encapsulation ppp
 no fair-queue
 service-module t1 timeslots 1-24
 ppp multilink
 multilink-group 1
!
interface Serial0/1
 no ip address
 ip verify unicast reverse-path
 no ip proxy-arp
 encapsulation ppp
 no fair-queue
 service-module t1 timeslots 1-24
 ppp multilink
 multilink-group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 0.0.0.0 0.0.0.0 Multilink1
no ip http server
!
access-list 102 permit tcp any any eq telnet
access-list 102 permit icmp host xxx.xxx.xxx.xx host xx.xx.xx.xxx
access-list 102 permit icmp host 203.167.75.41 host xx.xxx.xx.xxx
access-list 102 permit udp host 203.167.75.41 host xx.xxx.xx.xxx eq 4500
access-list 102 permit udp host 203.167.75.41 host xx.xxx.xx.xxx eq isakmp
access-list 102 permit esp host 203.167.75.41 host xx.xxx.xx.xxx
access-list 102 permit udp any any eq isakmp
access-list 102 permit udp any any eq 4500
access-list 102 permit esp any any
access-list 102 permit ip any any
banner motd ^CC
**********************************************
**********************************************
***                                        ***
***          ***
***                                        ***
**********************************************
**********************************************
^C
!
line con 0
 password 7
 login
line aux 0
 password 7
 login
line vty 0 4
 password 7
 login
!
no scheduler allocate
end
0
 

Author Comment

by:Smaxon
ID: 21841986
I thought I could just copy and paste this config in the 2800 and add the third interface but its not working out that way..
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 50

Expert Comment

by:Don Johnston
ID: 21842195
You can. You just have to specify the correct ports. That's why I suggested posting the configs of both routers.
0
 

Author Comment

by:Smaxon
ID: 21842207
I copied this config into the 2800 but it did not work so I did a write erase and reload so now there isnt a config for the 2800.
All I have to go on is this config for the 2600.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21842252
Please post the results of a "show run" on the 2800.
0
 

Author Comment

by:Smaxon
ID: 21842268
here is a copy of the config I tried to use on the 2800 I modified it from the orginal one from th 2600 but this didnt work . I will get you that sh run a.s.a.p


Current configuration : 2429 bytes
!
version 12.1
service tcp-keepalives-in
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3
!
logging buffered 16000 debugging
enable secret 5 $.
enable password 7
!
!
!
!
!
ip subnet-zero
no ip source-route
ip cef
!
no ip bootp server
!
!
!
interface Multilink1
ip address xxx.xxx.xxx.xxx 255.255.255.252
ppp multilink
ppp fragmentation disable        
ppp multilink group 1       
!
interface GigabitEthernet0/0
 ip address xxx.xxx.xxx.xxx 255.255.255.240
 ip verify unicast reverse-path
 no ip proxy-arp
 duplex auto
 speed auto
!
interface controller T1 0/1/0
 no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 1
!
interface controller T1 0/2/0
 no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
ppp multilink group 1
!
interface Serial0/0/0
no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
ppp multilink group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
no ip http server
!
access-list 102 permit tcp any any eq telnet
access-list 102 permit icmp host xxxx.xxx.xxx.xxxhost xxx.xx.xxx.xxx
access-list 102 permit icmp host xxx.xx.xxx.xxx host xxx.xx.xxx.xxx
access-list 102 permit udp host xxx.xx.xxx.xxx host xxx.xx.xxx.xxx eq 4500
access-list 102 permit udp host xxx.xx.xxx.xxx host xxx.xx.xxx.xxx eq isakmp
access-list 102 permit esp host xxx.xx.xxx.xxx host xxx.xx.xxx.xxx
access-list 102 permit udp any any eq isakmp
access-list 102 permit udp any any eq 4500
access-list 102 permit esp any any
access-list 102 permit ip any any
banner motd ^C
**********************************************
**********************************************
***                                        ***
***  !         ***
***                                        ***
**********************************************
**********************************************
^C
!
line con 0
 password 7
 login
line aux 0
 password 7 F
 login
line vty 0 4
 password 7 F
 login
!
end
0
 

Author Comment

by:Smaxon
ID: 21842330
Router#sh run            
Building configuration...                        

Current configuration : 826 bytes                                
!
version 12.4            
service timestamps debug datetime msec                                      
service timestamps log datetime msec                                    
no service password-encryption                              
!
hostname Router              
!
boot-start-marker                
boot-end-marker              
!
!
no aaa new-model                
!
resource policy              
!
no network-clock-participate wic 0                                  
no network-clock-participate wic 1                                  
ip subnet-zero              
!
!
ip cef      
!
!
!
!
!
!
!
!
controller T1 0/0/0                  
 framing esf            
 linecode b8zs              
!
controller T1 0/1/0                  
 framing esf            
 linecode b8zs              
!
!
!
!
interface GigabitEthernet0/0                            
 no ip address              
 shutdown        
 duplex auto            
 speed auto          
!
interface GigabitEthernet0/1                            
 no ip address              
 shutdown        
 duplex auto            
 speed auto          
!
interface Serial0/2/0                    
 no ip address              
 shutdown
 no fair-queue
!
ip classless
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
!
end
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21842413
Here you go. I'm assuming the new link is connected to serial 0/2/0.

controller T1 0/0/0                  
 framing esf            
 linecode b8zs  
 channel-group 0 timeslots 1-24            
!
controller T1 0/1/0                  
 framing esf            
 linecode b8zs              
 channel-group 0 timeslots 1-24            
!
int serial 0/0/0:0
 no ip address
 ppp multilink
 multilink-group 1
!
int serial 0/1/0:0
 no ip address
 ppp multilink
 multilink-group 1
!
interface Serial0/2/0                    
 no ip address              
 ppp multilink
 multilink-group 1
! 
interface Multilink1
 ip address xxx.xxx.xx.xxx 255.255.255.252
 multilink-group 1

Open in new window

0
 

Author Comment

by:Smaxon
ID: 21842587
thanks for that, when I put that into the router it is telling me that my serial interfaces are up but the line protocol is down ,gigabit ethernet is up and line protocol is up but multilink is down line protocol is down
and serials are all up but the line protocol is down. how do I bring the line protocol up?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21842755
Are all the serial ports UP/DOWN?
0
 

Author Comment

by:Smaxon
ID: 21842843
yes  the serials are up but line protocol is down,
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 21843053
In that case, I'd break the multilink group and troubleshoot the serial lines to determine the problem. Once you remove the multilink, shutdown all but one of the serial links and do a "debug ppp neg" on the serial interface that's up.
0
 

Author Comment

by:Smaxon
ID: 21846647
Here is the config I used. mby I am misssing something.



Current configuration : 2452 bytes
!
version 12.1
service tcp-keepalives-in
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3
!
logging buffered 16000 debugging
enable secret 5 4n.
enable password 7
!
!
!
!
!
ip subnet-zero
no ip source-route
ip cef
!
no ip bootp server
!
!
!
controller T1 0/0/0                  
 framing esf            
 linecode b8zs  
 channel-group 0 timeslots 1-24            
!
controller T1 0/1/0                  
 framing esf            
 linecode b8zs              
 channel-group 0 timeslots 1-24            
!
int serial 0/0/0:0
 no ip address
 ppp multilink
 multilink-group 1
!
int serial 0/1/0:0
 no ip address
 ppp multilink
 multilink-group 1
!
interface Serial0/2/0                    
 no ip address              
 ppp multilink
 multilink-group 1
!
interface Multilink1
 ip address xxx.xxx.xxx.xxx 255.255.255.252
 multilink-group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
no ip http server
!
access-list 102 permit tcp any any eq telnet
access-list 102 permit icmp host xxx.xxx.xxx.xxx host xxx.xxx.xxx.xxx
access-list 102 permit icmp host xxx.xxx.xxx.xxx host xxx.xxx.xxx.xxx
access-list 102 permit udp host xxx.xxx.xxx.xxx host xxx.xxx.xxx.xxx
access-list 102 permit udp host xxx.xxx.xxx.xxx host xxx.xxx.xxx.xxx

isakmp
access-list 102 permit esp host xxx.xxx.xxx.xxx host xxx.xxx.xxx.xxx
access-list 102 permit udp any any eq isakmp
access-list 102 permit udp any any eq 4500
access-list 102 permit esp any any
access-list 102 permit ip any any
banner motd ^CC
**********************************************
**********************************************
***                                        ***
***        ***
***                                        ***
**********************************************
**********************************************
^C
!
line con 0
 password 7 1
 login
line aux 0
 password 7 0
 login
line vty 0 4
 password 7 030
 login
!
no scheduler allocate
end
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 21846761
Nope. Looks good. You'll need to troubleshoot the serial links individually to figure out the problem.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

687 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question