?
Solved

Moving vlans from 3560 to 3750.

Posted on 2008-06-22
8
Medium Priority
?
310 Views
Last Modified: 2010-04-12
I have vlans that were configured on a Cisco 3560 but now we are taking it out of commission and want to move those to a new 3750. Can I just copy and paste that part of the 3560 config into the 3750?
0
Comment
Question by:backbiter1019
  • 3
  • 3
  • 2
8 Comments
 
LVL 29

Expert Comment

by:Jan Springer
ID: 21841517
The 3560 configurations should be portable to the 3750.  I can't think of anything off-hand that would cause a problem.

If you can provide a sanitized copy of the config, I can verify that for you.
0
 

Author Comment

by:backbiter1019
ID: 21842571
This is the 3560 config with the 24 port settings removed. I'll post the 3750 config also below. It is in production currently and has been for about a year now.
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
service sequence-numbers
 
clock timezone CST -6
clock summer-time CDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
ip routing
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
 
!
interface GigabitEthernet0/1
 description ##### Trunk to 2970 #####
 switchport trunk encapsulation dot1q
 switchport mode dynamic desirable
 no ip address
!
interface GigabitEthernet0/2
 description ##### Trunk to 2950 Below #####
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 ip address 10.0.1.1 255.255.255.0
!
interface Vlan2
 ip address 10.0.2.1 255.255.255.0
!
interface Vlan3
 ip address 10.0.3.1 255.255.255.0
!
interface Vlan6
 ip address 10.0.6.1 255.255.255.0
!
interface Vlan10
 ip address 10.0.10.1 255.255.255.0
 ip helper-address 172.16.11.4
!
interface Vlan11
 ip address 10.1.1.1 255.255.255.0
 ip helper-address 172.16.11.4
!
interface Vlan16
 ip address 172.16.11.1 255.255.255.0
 ip helper-address 172.16.11.4
!
interface Vlan22
 ip address 10.2.2.1 255.255.255.0
 ip helper-address 172.16.11.4
!
interface Vlan23
 ip address 10.2.3.1 255.255.255.0
 ip helper-address 172.16.11.6
!
interface Vlan33
 ip address 10.3.3.1 255.255.255.0
 ip helper-address 172.16.11.4
!
interface Vlan44
 ip address 10.4.4.1 255.255.255.0
 ip helper-address 172.16.11.4
!
interface Vlan45
 ip address 10.4.5.1 255.255.255.0
 ip helper-address 172.16.11.6
!

Open in new window

0
 

Author Comment

by:backbiter1019
ID: 21842588
Here is the 3750 config.
Current configuration : 1645 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
 
!
no aaa new-model
switch 1 provision ws-c3750g-12s
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet1/0/1
 description ***** NOT IN USE ******
!
interface GigabitEthernet1/0/2
 description ***** Trunk to MRE 2970 ******
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 description ####### TRUNK TO JR HIGH  #######
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/4
 description ####### TRUNK HIGH SCHOOL  #######
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
 description ####### TRUNK TO ADM-MDF1-2970-2 #######
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/0/12
 description ####### TRUNK TO ADM-MDF1-2970 #######
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 ip address 10.0.1.5 255.255.255.0
!
ip default-gateway 10.0.1.1
ip classless
ip http server
!
!
!
control-plane
!
!
 
 
adm-MDF3-3750#

Open in new window

0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 
LVL 16

Expert Comment

by:Aaron Street
ID: 21844358
yes you can copy between them with a simple copy and past..

the vlan comands on both are identical.
0
 
LVL 16

Accepted Solution

by:
Aaron Street earned 200 total points
ID: 21844379
notice the interface VLAN X commands on both switchs are identical?

In fact they do use a slightly different IOS 12.1 and 12.2 but these are still about 99% compatable when it comes to VLAn's

You could infact probable run 12.2 on the 3650. but there is no need to. as long as the major version number is the same between switchs. then configs between switchs will be portable.

There may be minor differences. but you are running basic VLAN commands. so this will be identical for all recent and current Cisco switchs.
0
 
LVL 29

Expert Comment

by:Jan Springer
ID: 21845634
It looks pretty generic.  I expect that the port will go without problems.
0
 
LVL 16

Expert Comment

by:Aaron Street
ID: 21846014
do rember that different HArdware version can all run the same IOS.

These are both running IOS version 12. (as i mentioned) therefor they will have the same basic command structure.
and between build there are only minor version number  there are only minor differences and often specifice to different areas. but for all basic switch commands they are the same on all switches.

 
0
 

Author Comment

by:backbiter1019
ID: 21846203
Thanks for the help folks. I appreciate it.
0

Featured Post

Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I see many questions here on Experts Exchange regarding switch port configurations and trunks. This article is meant for beginners in the subject to help to get basic knowledge about Virtual Local Area Network (VLAN (http://en.wikipedia.org/wiki/Vir…
As dyndns has reduced the capabilities of the free service, I looked around for other free providers of Dynamic DNS service. After testing several I decided to move my DNS hosting to Hurricane Electric as then domains that require dynamic hostnam…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Suggested Courses
Course of the Month16 days, 15 hours left to enroll

862 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question