Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5424
  • Last Modified:

MSSQL$MICROSOFT##SSEE high memory usage SBS 2003 R2

I am running an SBS 2003 R2 server with Xeon 3050 and 2GB RAM.  The system was obtained from Dell a few months back and SBS was already installed out-of-the-box.

I am using SBS monitoring and have consistently received high memory allocation warnings from the outset.  I came across this article: http://msmvps.com/blogs/bradley/archive/2005/02/04/34984.aspx and was able to identify MSSQL$MICROSOFT##SSEE as the main culprit with about 415MB RAM usage. However, the procedure to control the SQL processes does not appear to work for MSSQL$MICROSOFT##SSEE, which I understand is an embedded SQL server.

Why is this process running and why is it taking up so much memory?  Can it be limited?
0
Lord_Lovatt
Asked:
Lord_Lovatt
1 Solution
 
Toni UranjekConsultant/TrainerCommented:
Hi!

This is expected or maybe even desirable behaviour. Databases consume large ammounts RAM to optimize their perfomance. I believe that MSSQL$MICROSOFT##SSEE instance is running because SBS has Windows SharePoint Services included. You can access SharePoint webpage on the following address "http://companyweb". Next process which will start to consume your RAM is store.exe (Exchange). What's the point of having large amount of RAM if nobody uses it?

You can change threshold by using the Change Alert Notifications task in the Server Management Monitoring and Reporting taskpad if notifications are anoying.

HTH

Toni
0
 
Lord_LovattAuthor Commented:
Thanks Toniur, I was aware that store.exe is meant to consume RAM by default, but not the MSSQL$MICROSOFT##SSEE instance.  I will just change the alert notification.
0
 
ProfWilliamWangCommented:
Hello,

I'm having the same thing but my server has 4GB RAM.

The process MSSQL$MICROSOFT##SSEE in my case is using 600-800MB RAM.

I believe that this link provides information on how to limit the amount of RAM used by an SQL process:

http://msmvps.com/blogs/bradley/archive/2005/02/04/34984.aspx.

Not sure of the level you'd want to restrict it to though.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
stewartdaveCommented:
Just wanted you to know that MSSQL$MICROSOFT##SSEE is the database for WSUS 3. I just upgraded to WSUS 3 sp2 and it is using 1.4G of my ram!
0
 
DJNafeyCommented:
Microsoft##SSEE is the Windows Internal Database, rather than a typical MSDE or SQL Server Express instance.  

I have a client with SBS 2003 Premium who has separate SQL Server instances for both Sharepoint and WSUS (contradicting earlier posts in this thread) so maybe it's only actually used in SBS 2003 Standard?  Despite this, the client's server with 3GB RAM has Microsoft##SSEE regularly using around 1GB RAM, pushing the RAM usage 10-20% beyond what's installed and affecting performance (despite being a quad-core Xeon with only 5-10 light users).  

After a bit of fiddling around, I have just found that you CAN configure the maximum amount of RAM that it uses through SQL Server 2005 Management Studio (for SBS Premium) or through SQL Server 2005 Express Management Studio (free download from Microsoft), just like you can with regular SQL Server instances.  It's not enabled by default though, which is why it needed a bit of playing around with.

You'll need to go into SQL Server Configuration Manager.  Go into the 'Protocols for Microsoft##SSEE' section and enable the 'Named Pipes' protocol.  Go into the 'SQL Server 2005 services' section and restart the Microsoft##SSEE service.  

Then go into SQL Server Management Studio and connect to the Microsoft##SSEE database instance (you can use Windows Authentication with the Administrator login).  When the instance is connected, right-click on it and go to Properties.  Go into the Memory section.  Set a 'Maximum server memory in MB' value that you feel is appropriate - for my particular client's circumstances, I set it to 256 but, if you need it for Sharepoint or WSUS, then you might need more RAM.

Once you're done, go back to SQL Server Configuration Manager and disable the Named Pipes protocol again - Microsoft left it off for a reason.

I hope this helps someone out because it's been a minor irritation for me for about 3 years but the solution is actually pretty simple!
0
 
stewartdaveCommented:
Hey, thanks for the tip. I have srted out my problem by uninstalling Symantec Backup Exec on the the server... it was not working correctly. Bus I still notice that SBS 2003 databases... the WSUS, sbsd monitoring, and sharepoint seem to grow over time. I sometimes will just stop those services and it claims back memory, but now I can use your method to limit memory
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now