?
Solved

Page not found (HTTP 404) error on Outlook Mobile Access OMA website

Posted on 2008-06-23
10
Medium Priority
?
2,316 Views
Last Modified: 2012-05-05
Hi Experts,

I'm having the following issue with a recently installed server running Small Business Server 2003 at one of our customers.
The employees need to sync with Outlook Mobile Access (OMA) with their Nokia E90 phones. We've done this a lot lately so nothing special until I encountered the following problem which I cannot resolve.

When Accessing the OMA website I get a "Page cannot be found" error (HTTP 404). I tried the following things in order to resolve this but the problem still persists:
"      Deleting exchange-oma (used for SSL redirection) folder and appropriate registry key
"      Disabling and enabling SSL (OMA website won't work either way)
"      Rebuilding Exchange Virtual folders in IIS with Metabase Explorer

The Exchange Web Access is working fine by the way on either normal HTTP or with form based authentication through HTTPS.

I hope someone can help me on this one.
0
Comment
Question by:dynamation
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
10 Comments
 
LVL 14

Expert Comment

by:plug1
ID: 21844788
OMA is a pain in the proverbial but heres a link to to member SEMBEE's fixes for it. I think hes taken time out this year so I dont think he'll mind me posting it up.

http://www.amset.info/exchange/mobile-85010014.asp
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 21845645
In IIS Manager, do you still see the Virtual Directory named OMA ?  Are you able to right-click it, and select 'Browse...' ?
0
 
LVL 1

Author Comment

by:dynamation
ID: 21845709
@plug1:
I'm affraid that website only tells me how to setup OMA synchronisation with Exchange which I already knew. But thanks for your reply.

@LeeDerbyshire:
Yes I can. The location (Program Files\Exchsrv\OMA) exists and the OMA.ASPX file is in there. In the documents tab of IIS the "enable default content" is checked and oma.aspx is added properly.

The thing is, when I go to http(s)://servername/oma I get an authentication box popped up to authenticate. When I do, then "Page cannot be found" message appears.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 21845729
It would help to see the IIS log file entries generated by the requests for OMA that result in the 404 response.
0
 
LVL 14

Expert Comment

by:plug1
ID: 21845732
That sounds to me to be a problem with the security on the actual folders themselves where the html files live.
0
 
LVL 14

Expert Comment

by:plug1
ID: 21845741
Can you check that the authenticated users have access to the OMA folder and subfolders.
0
 
LVL 1

Author Comment

by:dynamation
ID: 21845797
@LeeDerbyshire:
This is a piece of the logfile located in "WINDOWS\system32\LogFiles\W3SVC1". But it doesn't makes much sense to me. I'm not very familiar with webservers like Apache and IIS. Normally this just works out of the box.

@plug1
Yes, "Authenticated Users" have read permissions.
#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2008-06-23 13:06:46
#Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status 
2008-06-23 13:06:46 W3SVC1 192.168.20.1 GET /oma - 80 - 192.168.20.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 401 2 2148074254
2008-06-23 13:06:52 W3SVC1 192.168.20.1 GET /oma - 80 Administrator 192.168.20.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 401 1 1326
2008-06-23 13:06:55 W3SVC1 192.168.20.1 GET /oma - 80 Administrator 192.168.20.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 301 0 0
2008-06-23 13:06:55 W3SVC1 192.168.20.1 GET /oma/oma.aspx - 80 Administrator 192.168.20.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 404 2 0

Open in new window

0
 
LVL 31

Accepted Solution

by:
LeeDerbyshire earned 2000 total points
ID: 21845927
Okay, thanks.  The last line is relevant - you can see the 404;2 status near the end which in IIS means 'Not Found due to Lockdown Policy'.  Which is odd.  You said you found the OMA VDir in IIS Manager, but did you try right-clicking it and Browsing it?  Did it show your messages okay?  If not, then the server might not be able to handle files with the .aspx extension.  Maybe because on the ASP.Net tab of OMA, no version is selected from the drop-down list.
0
 
LVL 1

Author Comment

by:dynamation
ID: 21846166
I'm sorry I tried "explorer" before instead of "browse". When I "browse" I get the same authentication request and after that the same "Page cannot be found" error.

I checked the ASP.NET tab on OMA and it shows a pull-down list with boh versions 1.1.4322 and 2.0. I selected 1.1.4322 and now it works!

How is it possible that the default ASP.NET version is wrong? You should expect the I not the only one with this problem. I couldn't find a solution elsewhere.

Thanks for your time and help!!
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 21846254
I know that IIS responds with a 404;2 when a document type handler is not configured, so it was a safe enough guess on my part.  And yes, I'm sure you're not the only one to encounter this problem.  As to why it was not set, well we can only guess.  If it used to work okay, then something has changed it - maybe something you recently installed.  If it never worked, then the Exchange setup probably assumed that the .Net version had been correctly set for the server's Default Web Site, and that it could safely inherit the setting.  In your case it is probably not set for the Default Web Site, and because you have no other .Net web applications on the server, you'd never noticed a problem before.
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question