Not Permitting Terminal Services Logon

Good morning,
Our servers are not letting our users logon via terminal services.  We're running Windows Server 2003 in a terminal services environment.  Administrators can logon.  No other user can.  Where would I address this problem and how.
Thanks for your help.
cclausen1Asked:
Who is Participating?
 
Henrik JohanssonConnect With a Mentor Systems engineerCommented:
Yes
Local policy has lowest priority and will be overruled if the policy is set through a GPO in the domain.
0
 
dblake15Commented:
So your users are trying to RDP in??  If that is the case then you need to make sure that the users are part of the remote desktop users group or in My Computer properties, under the remote tab, you can add the group that you have the users in, with regards to AD.
0
 
Henrik JohanssonSystems engineerCommented:
Normally the users nead to be added to the local group "Remote Desktop Users".
The groups allowed to log on through TS is controlled by the policy "Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Allow log on through Terminal Services" (default Administrators and Remote Desktop Users).
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
cclausen1Author Commented:
Users are part of the Remote Desktop Users group.  I think a Group Policy was changed affecting this.  Is that possible?
0
 
Henrik JohanssonSystems engineerCommented:
Yes, it's the user rights assignment in my previous post that has been changed through GPO or local policy.
Use rsop.msc (Resultant Set Of Policies) to analyze what GPO is setting the policy.
Create a new GPO to set the "...\User Rights\Allow log on through Terminal Services" to allow TS-access for both Administrators and Remote Desktop Users. Link the GPO to the OU containing the TS-server.
0
 
cclausen1Author Commented:
The policy "Allow logon through Terminal Services" shows only administrators and the option of "adding" or "removing" users is greyed-out for all our servers.
0
 
cclausen1Author Commented:
I have also enabled the group policy "Allow users to connect remotely using Terminal Services" at the domain and domain controller level.  This has had no effect unfortunately.
0
 
Henrik JohanssonSystems engineerCommented:
The reason for it's grayed out is that a GPO is affecting the server. Run rsop.msc to see what GPO is applying the setting. If you were able to modify the setting, it would be overriden by the GPO.
You nead to modify the GPO (or create a new linked to the OU containing the server) to allow both Administrators and Remote Desktop Users.
Your last posts make me wonder if the server also is a DC?
0
 
cclausen1Author Commented:
A DC is affected, but the two servers running as TSs are the ones we're focused on.  

I ran rsop.msc, but it wasn't evident.  Where would the policy blocking this most likely reside?  Under Users or Computer Config?

Thanks.
0
 
Henrik JohanssonSystems engineerCommented:
User rights assignment is a part of computer configuration.

Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Allow log on through Terminal Services

rsop.msc is just for analyzing to find out what GPO is configuring the policy setting.

To solve the problem:
Place the TS-servers in their own OU.
Create a new GPO configuring the user right to log on through TS.
Link the GPO to the OU with the TS-servers.
0
 
cclausen1Author Commented:
Is this done via the Group Policy Management tool?  If local policies are changed via the process you've outlined, will it propogate to all the servers.
0
 
cclausen1Author Commented:
Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.