update Netapp firmware from 7.1 to 7.2.4

Posted on 2008-06-23
Last Modified: 2013-11-14
I need help updating firmware on an R200 that's currently at 7.1.  I tried the 7.2.4 exe then did the download/reboot.  I got the "successfully copied to disks..." message, did a reboot and it booted back to 7.1 ( it also broke the gui) cli only now. I tried the download -d; update-flash; rebooted. and still at 7.1 on the os and via the version -b command I get 7.1 as primary and backup versions on the flash.

any ideas? I need to be at 7.2.4
Question by:jaybruce
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3

Author Comment

ID: 21846079
also, besides the http part, the filer is still working, snapmirrors are still replicating.

Author Comment

ID: 21863230
Thanks Vee_Mod
It's on a Network Appliance (NetApp) filer. The model is an R200. It's a network storage device. The OS is DataOnTap 7.1 and Im trying to upgrade it to 7.2.4. It's basicly going to be a storage admin who can help.
LVL 30

Expert Comment

by:Duncan Meyers
ID: 21872198
What firmware and diagnostics version are you running? Latest is Firmware: 4.3.1, Diagnostics 4.9.5.
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

LVL 30

Expert Comment

by:Duncan Meyers
ID: 21872220
Another possibility is that the upgrade process did not complete cleanly. Try the following:

Issue the command: options httpd.admin.enable off
Issue the command: software install <install_file>
Download as advised in the message after the software install process finished.
Reboot the machine.
Issue the command: options httpd.admin.enable on

Author Comment

ID: 21914949
Meyersd, thanks for the suggestions, turns out, I was being stupid. I still had a 7.1 firmware in the /etc/boot folder so, even though I had the 7.2.4 also, it kept choosing the 7.1 and "updating" with that. I had to delete that, then also rename the 7.2.4 to just netapp-x86 and it worked fine.
LVL 30

Accepted Solution

Duncan Meyers earned 500 total points
ID: 21915215

No worries! Glad it worked out.
LVL 30

Expert Comment

by:Duncan Meyers
ID: 21921154
Oops! Sorry 'bout that...

Featured Post

Comparison of Amazon Drive, Google Drive, OneDrive

What is Best for Backup: Amazon Drive, Google Drive or MS OneDrive? In this free whitepaper we look at their performance, pricing, and platform availability to help you decide which cloud drive is right for your situation. Download and read the results of our testing for free!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Extending VM Disk to be larger than 2 TB ? 11 181
Optimizing SAN 16 54
Server 2008 R2 has no more space on C: (OS) drive 21 92
Creating a partition in VMware 20 46
Having issues meeting security compliance criteria because of those pesky USB drives? Then I can help you! This article will explain how to disable USB Mass Storage devices in Windows Server 2008 R2.
The question appears often enough, how do I transfer my data from my old server to the new server while preserving file shares, share permissions, and NTFS permisions.  Here are my tips for handling such a transfer.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question