Solved

Citrix connection does not connect after remote machine was moved and renamed.

Posted on 2008-06-23
4
460 Views
Last Modified: 2012-05-05
We have a user who replaced their machine at a remote site with a machine that was previosuly at another remote site.  Both the replaced (98) and the new machine (xp) were once able to connect to the Citrix server at the home office.  The machine that was moved to the new site was renamed and given a static internal IP and is able to connect to the network and internet there normally.  The Citrix client setup is the same as before, but the user gets "Network or dial-up problems are preventing communication with the Citrix MetaFrame server. If the problem persists, please contact your network administrator.
Number of failed reconnection attempts: 0"  each time they try to connect.  I have tested connecting to the same Citrix connection from a 2000 machine for the first time and it worked fine with the same settings.  It looks like on the Citrix server that when this user connects, an error "terminal services cannot issue a client license" shows up in the event viewer.  I see a license in the list for the test machine that worked, but not for the new machine that does not, though we know if used to connect at the other site.  Do we need to clear the old license from it since the machine was renamed and moved, or is there something else going on?  If so how is that done?  Also the Terminal Services Licensing service on the Citrix server is not on, that service runs on the domain controllor if that helps.

Thanks,
0
Comment
Question by:IndyNCC
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 1

Expert Comment

by:pooky73
ID: 21847685
Is port 1494 open on the Windows Firewall?
0
 

Author Comment

by:IndyNCC
ID: 21848139
Not sure, are you talking about the firewall on the pc that is trying to connect, or the firewall on their network, or the one at the main office?  I can connect to Citrix fine from another outside location so I don't think it is anything where the server is.
Thanks.
0
 
LVL 14

Accepted Solution

by:
Craig Roberds earned 500 total points
ID: 21848959
On the client PC go into regedit and delete the following folder:  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing

That will clear the licensing on that PC.  If that doesn't work look at some of the other suggestions here:    http://www.thomaskoetzing.de/index.php?option=com_simplefaq&task=display&catid=24&search=MSLicensing
0
 

Author Comment

by:IndyNCC
ID: 21849473
That did, it, actually you don't want to delete the whole folder, just the software\microsoft\ms licensing\store\License000 folder for the License 000 (or whatever the numbers are), then it creates a new license when she connected and it is now working.
Thanks,
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

#Citrix #Citrix Policies #XenDesktop #VDI #POC #Citrix Univeral Printer Driver #Citrix UPD
NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question