• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 610
  • Last Modified:

PC's using Internet Explorer 7 cannot resolve DNS quickly

As we use Firefox more and more we find that too many web-sites that we use on a daily basis are not compatible.  I have found that if I type the IP address of a site into the address bar in Internet Explorer the sites loads as quickly as it should.  So here is summary of the problem.

Using IE with a wireless circuit pages load extremely slowly.
Using IE with a backup DSL line they load fine.
Using IE right at the DNS server with the wireless circuit pages load quickly.
Using Firefox at the PC with the wireless circuit pages load quickly

Something at the PC level in IE is hindering DNS resolving.

I am stumped.

0
krlseidl
Asked:
krlseidl
  • 7
  • 6
  • 2
1 Solution
 
PaperTigerCommented:
Go to Tools, Internet Option, Connections, LAN Setting, make sure everything there is cleared. nothing needs to be checked.
0
 
krlseidlAuthor Commented:
Did that already
0
 
agriesserCommented:
Have you tried to disable the automatic phishing filter already? Maybe that is causing the problem...
Does starting IE without Add-Ons (Right Click the icon on the desktop, click "Start without addons") cure this issue?

Is there any "Internet Security" software installed? I recall that some versions of Kaspersky Internet Security and Norton 360 mainly caused slow DNS lookups in IE because they installed some addons to IE that checked web-addresses against a phishing database...
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
krlseidlAuthor Commented:
Don;t have Start without add-ons as an option when I right click.

Disabled Symantec Endpoint Security on my PC with no difference.
0
 
PaperTigerCommented:
you would have to remove the Symantec crap to make it work. if fiefox works fine, the issue is with IE.
0
 
agriesserCommented:
OK, then the Internet Explorer icon on your desktop is a shortcut and not the real Internet Explorer icon (there's a difference, yes).

To start IE without addons, use "Start" -> "Run" -> "iexplore -extoff"

or click on

Start Menu -> Programs -> Accessories -> System Tools

There you should see an icon to start IE without addons.
0
 
krlseidlAuthor Commented:
Ran without addons.  Performance a little better but not what it should be.  The bugger here is that the DSL line works fine.  Gee I love computers :)
0
 
agriesserCommented:
I just tested that the phishing filter is still active (even when running without addons), so you could still try to disable the phishing filter.

To disable it, go to "Tools" -> "Internet options" -> "Advanced" and in the category "Security" you can disable the phishing filter.
0
 
krlseidlAuthor Commented:
Never have the phishing filter active.  The more I think about it.  I think the DNS issue is probably showing in Firefox as well.  But because it is so much more efficient that IE it seems to be faster.
0
 
agriesserCommented:
I did some testing here at home using a wireless internet connection (HSDPA) and my wired internet connection.
Yes, I know, HSDPA is not comparable to WLAN but hey, it's wireless ;)

In my testings, when downloading files both connections are comparable, but when doing many small requests where a lot of new connections need to be created and many DNS resolutions get started, the wireless connection feels much slower than the wired one.

Conclusion: wireless networks suck (and of course, IE sucks too).

Firefox seems to compensate this issue quite well as you've already seen and I can reproduce this on my systems here too. Firefox feels faster than IE, but I don't think that my testings are very unbiased ;)
0
 
krlseidlAuthor Commented:
What I am going to do Wenesday is to plug my PC right into what they call the "radio"  which will bypass my entire network and see what happens.
0
 
agriesserCommented:
Did it work? Should be already Wednesday at your site :)
0
 
krlseidlAuthor Commented:
Plugging right into the radio speed was ok but not what I expected.  Then took the exact same PC and plugged into the T1 line that the wireless replaced (It's still runnig because the telephone company is very slow in processing disconnections)  T1 at 1.5Mb was blazing fast compared to the 3mb wireless.

Decision has been made to pull the wireless and go back to T1.
0
 
agriesserCommented:
Good idea.
0
 
krlseidlAuthor Commented:
Thanks for the help.
0

Featured Post

A Cyber Security RX to Protect Your Organization

Join us on December 13th for a webinar to learn how medical providers can defend against malware with a cyber security "Rx" that supports a healthy technology adoption plan for every healthcare organization.

  • 7
  • 6
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now