Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Failover Possible?

Posted on 2008-06-23
3
Medium Priority
?
889 Views
Last Modified: 2010-05-18
Hello,
I was wondering if there is a way to have a Cisco 2811 do auto failover when a circuit drops out.  Here's my situation:

We are switching from an in-house IP PBX (on PRI) to a hosted VoIp solution (I wouldn't recommend!), and in doing so we've ditched our old PRI T1 in place for a new VoiceT1 (well data, but carrying voice).  We also have another full data T1 we use for Citrix traffic to our parent company . Over the past 3 weeks (and I kid you not) the phone company has been troubleshooting the new T1.  It comes up for an hour, or day, and drops out by the next morning.  I currently have all my phones  on two Cisco switches, on their own Voice Vlan.  When ever line drops (daily) I have go back and patch the switches into the data network and switch the Vlans of the ports. The router has a serial T1 card and two Fastethernet ports, only one of which is currently in use.  My Data T1 has a router with 8 ethernet ports on the back, and only one is currently being use.

What I want to do:
If the new T1 fails, I'd like the router to failover to the open enet port, assigned with a public IP of the data T1m, and start pushing the calls over the old data T1.  We are already placing calls over this T1 as I have no confidence in the new T1 (we sacrifice quality of phone calls, and gumm up the rest of out bandwidth).

Although I am not formally trained, I am VERY comfortable with the IOS CLI.
Any Suggestions?
Thanks
JJ
0
Comment
Question by:JamesonJendreas
  • 2
3 Comments
 
LVL 15

Accepted Solution

by:
wingatesl earned 1500 total points
ID: 21848453
This should help you get started.
http://www.inacom-sby.net/Shawn/post/2007/11/Cisco-IP-SLA-for-failover.aspx

Can you post a copy of your running config?
Shawn
0
 
LVL 1

Author Comment

by:JamesonJendreas
ID: 21848886
Here's the running config:

Building configuration...

Current configuration : 3666 bytes
!
! Last configuration change at 18:22:00 UTC Mon Jun 23 2008
! NVRAM config last updated at 10:33:09 UTC Mon Jun 23 2008
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NP/RL-RTR
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
logging buffered 4096 debugging
enable secret 5 *******************************
!
no aaa new-model
no network-clock-participate wic 0
!
!
ip cef
!
!
ip name-server 63.216.0.5
ip name-server 63.216.0.6
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0/0
 framing esf
 linecode b8zs
 channel-group 0 timeslots 1-24
!
class-map match-all L3-to-L2_VoIP-Cntrl
 match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
 match ip dscp ef
class-map match-all voice-signaling
 match ip dscp af31
class-map match-all sip-in
 match access-group 186
class-map match-all voice
 match ip dscp ef
!
!
policy-map BTNA_Out
 class voice
  priority 1024
 class voice-signaling
  bandwidth 128
 class class-default
  fair-queue
  random-detect
policy-map output_L3-to-L2
 class L3-to-L2_VoIP-RTP
  set cos 5
 class L3-to-L2_VoIP-Cntrl
  set cos 3
policy-map BTNA_In
 class voice
  priority 3000
 class sip-in
  bandwidth 1024
 class class-default
  fair-queue
  random-detect
!
!
!
!
interface FastEthernet0/0
 ip address 65.72.48.130 255.255.255.128
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 67.100.113.229 255.255.255.0
 ip nat enable
 duplex auto
 speed auto
!
interface Serial0/0/0:0
 description To PCCWGlobal var02.sjo01:Serial2/0/4:0 // 86HCGS664404PT // NAT021-22776-I3E
 ip unnumbered FastEthernet0/0
 no fair-queue
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0:0
!
!
no ip http server
no ip http secure-server
!
ip access-list extended infilter
 remark anti-spoofing and block other nasties
 deny   icmp any any redirect
 deny   icmp any any source-quench
 deny   ip 127.0.0.0 0.255.255.255 any
 deny   ip 224.0.0.0 31.255.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 permit ip 192.168.254.0 0.0.0.255 any
 permit ip 192.168.255.0 0.0.0.255 any
 permit ip 63.121.107.0 0.0.0.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 evaluate my-packets
 remark anti-spoofing and block other nasties
ip access-list extended outfilter
 remark punch return holes for outgoing tcp and udp
 permit tcp any any reflect my-packets
 permit udp any any reflect my-packets
 remark but allow anything at all out
 permit ip any any
 remark punch return holes for outgoing tcp and udp
 remark but allow anything at all out
!
access-list 10 permit 12.32.13.128 0.0.0.13
access-list 20 permit 192.168.11.0 0.0.0.255
access-list 60 permit 209.8.25.32 0.0.0.15
access-list 101 permit ip any any precedence critical tos 12
access-list 102 deny   tcp any eq ftp-data any
access-list 102 deny   tcp any any eq ftp-data
access-list 102 permit ip any any
access-list 103 permit ip any any
access-list 110 permit ip 63.121.0.0 0.0.255.255 any
access-list 110 deny   ip any any
access-list 186 permit ip 206.161.122.0 0.0.0.255 any
access-list 186 permit ip host 63.216.0.172 any
access-list 186 permit ip host 63.216.0.170 any
priority-list 1 protocol ip high list 101
priority-list 1 protocol ip normal list 102
priority-list 1 protocol ip low list 103
priority-list 1 queue-limit 100 40 60 80
snmp-server community feedme RO 60
snmp-server enable traps tty
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 password ****
line aux 0
 password *****
line vty 0 4
 password *****
 no login
!
scheduler allocate 20000 1000
ntp clock-period 17180009
ntp server 132.163.4.103
ntp server 18.26.4.105
ntp server 69.228.59.2
!
end
0
 
LVL 1

Author Comment

by:JamesonJendreas
ID: 21849849
Ok, so it looks like my main issue is the following:
The phones on the new T1 are assigned a public IP, via a DHCP server, and we have a full 254 block.  The data T1 (failover circuit) only gives us 5 public IP's.  These are with a different carrier, therefore different block.  Is there a way to assign NAT on a single interface?
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question