• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 23339
  • Last Modified:

Authorization: Cannot verify access to path (C:\Projects\projectName)


I have Vista Ultimate in My laptop. I have IIS 7.0 in it. I wish to run ASP site in it.

While creating a site There is a Test button if we test configuration by clicking on that site I get the error message

Authorization: Cannot verify access to path (C:\Projects\projectName)
The server is configured to use pass-through authentication with a built-in
account to access the specified physical path. However, IIS Manager cannot
verify whether the built-in account has access. Make sure that the
application pool identity has Read access to the physical path. If this
server is joined to a domain, and the application pool identity is
NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has
Read access to the physical path. Then test these settings again.

This is a standalone machine. The default web is showing up fine and Network
Service and System both have ACL access to the path.

And When I try to run the asp site I get the error message

HTTP Error 404.3 - Not Found

Description: The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

Please guide

Many Thanks
2 Solutions
As your error message suggest, from IIS 6.0 onwards, your IIS application pool identity plays an important role.

Launch IIS manager, find out the application pool running your application.
Find out the identity of the application pool, change it to a appropriate windows/domain account with access to your folders.
tia_kamakshiAuthor Commented:
Hi JuckMan,

Thanks for your reply.

I am sorry, I did not understood what exactly you want me to do. I have added mimetypewith extension .asp and MimeType as application/x-asp

Also, I found the appliation pool link and now what and where you want me to do settings. I did not able to find that.

Also, In .net framework version, It is set to framework2.0, but ASP is not using .net framework.

Also, when I have added Mimetype, now I am able to see my page on browser, but I can see all my scriptlets as it is on browser.

I mean my string is displaying <%=stringValue%> as it is. It is not displaying any value. I mean it is not executing it.

Please help me in more detail

Many Thanks

Test change the application pool's manage pipeline from integrated to classic and browse the site again. Mind the test error...

Let me know.
I know this has been accepted, however, I'm having the same issue.

I've done this... given the computer read access to the directory, but am still getting this error.
Eprs_AdminSystem ArchitectCommented:
Hi, if you still have the message, try this

In ADD VIRTUAL DIRECTORY, select CONNECT AS and enter your administrator and the pass.
Then all should be allowed.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now