Cannot ping in between host and guest...................

Hi All:

I've VmWare installed on Wndows Server 2003. I installed Red Hat Enterprise addition of Linux on VmWare workstation. I cannot ping from 10.238.138.121 host to the Linux installation 10.238.138.131.

They both have internet connectivity.  Please let me know in details steps to make this work. I tried network properties and netsh without success. VmWare vitual network settings did not help much either.

Look forward to your response.

Regards

-sunnybrad
sunnybradAsked:
Who is Participating?
 
sunnybradConnect With a Mentor Author Commented:
Hi All:

Network adapter was not selected properly in network settings in VmWare.
One had to just select the right adapter for box.

Thanks

Sunnybrad
0
 
larstrCommented:
Try the following command on the host server:
netsh int ip set chimney DISABLED

This command will disable hw acceleration on the hosts nics.
0
 
sunnybradAuthor Commented:
Hi larstr:

I don't know how this will help ???????????

Regards

sunnybrad
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
jfields71Commented:
Is the Linux VM set up in bridged mode networking?  It appears so, but just checking.  Did you check for a firewall impeding ICMP traffic on the Linux VM?  
0
 
sunnybradAuthor Commented:
Hi jfields71 :

I have checked firewall on Windows server 2003 and it allows icmp traffic.
So you can ping outside world.
On Linux Vmware installation you can ping outside world. You cannot ping between the two.

Regards

sunnybrad
0
 
larstrConnect With a Mentor Commented:
sunnybrad,
If hw acceleration is enabled (TSO, TOE, etc) on the host nic and you're using bridged networking the networking performance between host<->guest will be very bad. If you run the command I gave you above from the cmd shell it will disable this hw acceleration. Alternatively you can also disable this setting from the advanced settings on the Nic driver.

Lars
0
 
jfields71Connect With a Mentor Commented:
Two more things you could check.  One is to enable firewall logging, to see if the packets are being received by the machine.  Go to the firewall settings and enable logging on the Advanced tab for all packets.  Then you can view the firewall log.  More info here, if needed: http://ecross.mvps.org/howto/pfirewall.htm.

Or you can install Wireshark on the VM and sniff packets on the VM.
0
 
sunnybradAuthor Commented:
Thanks jfields will try you suggestions and would let you know.

Regards
-sunnybrad
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.