Solved

Site to Site VPN Setup Instructions and Troubleshooting

Posted on 2008-06-23
1
1,610 Views
Last Modified: 2008-06-27
I had a site to site vpn setup between two Cisco PIX 501 routers but now I can't get them to reconnect.  Could someone provide me with some sets to take to test the connection between the two?  I will attach the configurations of the two PIX firewalls.

Also, if anyone has instructions on setting up a site to site vpn between two PIX 501 firewalls that would be great.  

Main Office PIX

Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd  encrypted
hostname
domain-name
clock timezone CST -6
clock summer-time CDT recurring 1 Sun Apr 0:00 last Sun Oct 0:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit icmp any any echo-reply
access-list outside_access_in permit tcp any host XX.XXX.XXX.XXX eq smtp
access-list outside_access_in permit tcp any host XX.XXX.XXX.XXX eq www
access-list outside_access_in permit tcp any host XX.XXX.XXX.XXX eq https
access-list outside_access_in permit tcp any host XX.XXX.XXX.XXX eq 3389
access-list outside_access_in permit tcp any host XX.XXX.XXX.XXX eq 6050
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.5.0 255.255.255.0
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.7.0 255.255.255.0
pager lines 24
logging on
logging timestamp
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside XX.XXX.XXX.XXX 255.255.255.240
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool POOL 192.168.1.225-192.168.1.235
pdm location 192.168.1.2 255.255.255.255 inside
pdm location 192.168.1.4 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.0 outside
pdm location 192.168.2.0 255.255.255.0 outside
pdm location 192.168.5.0 255.255.255.0 outside
pdm location 192.168.7.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 192.168.1.0 255.255.255.0 0 0
static (inside,outside) XX.XXX.XXX.XXX 192.168.1.2 netmask 255.255.255.255 0 0
static (inside,outside) XX.XXX.XXX.XXX 192.168.1.4 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 XX.XXX.XXX.XXX 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server RADIUS (inside) host 192.168.1.2 eWrmzw58odIuYwy2 timeout 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set APTSET esp-aes-256 esp-sha-hmac
crypto dynamic-map APTDYNMAP 10 set transform-set APTSET
crypto map APTMAP 10 ipsec-isakmp dynamic APTDYNMAP
crypto map APTMAP client authentication RADIUS
crypto map APTMAP interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup XXX idle-time 1800
vpngroup XXX_VPN_USERS idle-time 1800
vpngroup XXX idle-time 1800
vpngroup XXX_VPN_USERS address-pool POOL
vpngroup XXX_VPN_USERS dns-server 192.168.1.2
vpngroup XXX_VPN_USERS wins-server 192.168.1.2
vpngroup XXX_VPN_USERS default-domain aptllc.local
vpngroup XXX_VPN_USERS split-tunnel nonat
vpngroup XXX_VPN_USERS idle-time 1800
vpngroup XXX_VPN_USERS password ********
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.10-192.168.1.20 inside
dhcpd dns 68.94.156.1 68.94.157.1
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain
dhcpd auto_config outside
username rklemme password encrypted privilege 2
terminal width 80
Cryptochecksum:4fdd09e7f704e7286d3e4e19f46aafa6
: end
[OK]


Remote Office

: Saved
: Written by enable_15 at 18:49:22.017 CST Thu Dec 31 1992
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password  encrypted
passwd  encrypted
hostname
domain-name
clock timezone CST -6
clock summer-time CDT recurring 1 Sun Apr 0:00 last Sun Oct 0:00
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list inside_nat0_outbound permit ip 192.168.7.0 255.255.255.0 192.168.1.0
 255.255.255.0
pager lines 24
logging on
logging timestamp
logging buffered warnings
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.7.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.7.0 255.255.255.0 0 0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-AES-256 esp-aes-256 esp-sha-hmac
crypto map outside_map 24 ipsec-isakmp
crypto map outside_map 24 match address inside_nat0_outbound
crypto map outside_map 24 set peer XX.XXX.XXX.XXX
crypto map outside_map 24 set transform-set ESP-AES-256
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address XX.XXX.XXX.XXX netmask 255.255.255.255
isakmp keepalive 60 5
isakmp policy 24 authentication pre-share
isakmp policy 24 encryption aes-256
isakmp policy 24 hash sha
isakmp policy 24 group 2
isakmp policy 24 lifetime 86400
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.7.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
vpdn group ppoe-sbc request dialout pppoe
vpdn group ppoe-sbc localname johnsp@xxx.co.za
vpdn group ppoe-sbc ppp authentication pap
vpdn username johnsp@xxx.co.za password
dhcpd address 192.168.7.10-192.168.7.20 inside
dhcpd dns 192.168.1.2 196.43.46.190
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username dustin password  encrypted privilege 2
username rklemme password  encrypted privilege 2
terminal width 80
Cryptochecksum:012b5561c9c1e6dd45dadbce6fe8bdbe
apt-john-remote#
0
Comment
Question by:bkeating13
1 Comment
 
LVL 3

Accepted Solution

by:
dextermain earned 500 total points
Comment Utility
Hi,

What type of VNP do you want to setup.
IPSEC ?

Here is a link with a config,

http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_configuration_example09186a0080094761.shtml

Sections that you must look at is

isakmp policy ( Must be the same on both sides )
crypto IPSec transform-set chevelle esp-des esp-md5-hmac ( Must be the same on both sides )
crypto map transam 1 set transform-set chevelle  ( Must be the same on both sides )
crypto map transam 1 set peer 172.22.112.12 (will point to each other )
crypto map transam 1 match address 101 ( Must be the same on both sides but IP's turn around )
Incomming on the one will be outgoing on the other.
eg
A side
access-list 101 permit ip 10.1.1.0 255.255.255.0 172.16.1.0 255.255.255.0
B site
access-list 101 permit ip 172.16.1.0 255.255.255.0 10.1.1.0 255.255.255.0

Let me know if this helps.

D ;)


0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Juniper VPN devices are a popular alternative to using Cisco products. Last year I needed to set up an international site-to-site VPN over the Internet, but the client had high security requirements -- FIPS 140. What and Why of FIPS 140 Federa…
This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now