?
Solved

Mass Storage devices not showing up on Windows Explorer

Posted on 2008-06-23
29
Medium Priority
?
1,917 Views
Last Modified: 2013-11-14
I have repaired a Windows XP Sp2 Instalation, but after that, I cannot get USB Mass storage devices (USB MSD)to work. Everytime I plug in a USB MSD I hear the sound that I pluged in a new device, the remove safely icon shows up, the pendrive lights Up but no drive apears on Windows Explorer.
If I go to the Disk Management, I can see the Device, but when I try to assign a drive letter, it fails (nothing happens). With some devices I can click on the partition and then click OPEN, and that works.
0
Comment
Question by:tarcis
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 16
  • 8
  • 4
  • +1
29 Comments
 
LVL 22

Expert Comment

by:orangutang
ID: 21850891
I don't know anything about partitioning or Disk Management but here are some possible USB solutions:

Remove all USB drivers with:
https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip
, let it reinstall them, delete the "UpperFilters" and "LowerFilters" registry values from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
, check:
http://support.microsoft.com/kb/925196
and the "SIMILAR PROBLEMS AND SOLUTIONS" section, and run:
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
0
 
LVL 2

Author Comment

by:tarcis
ID: 21851118
After doing that, problem persists.
On device manager, there is a USB MASS STORAGE DEVICE with a exclamation mark, If I double click it and on descriptions it says  the device cannot be started
0
 
LVL 2

Author Comment

by:tarcis
ID: 21851205
I was surfing on EE and found someone with a similar problem (usb modem) and I suggested that he used a diferent USB port. So I thought to myself, to try too.
The problem persisted, but after installing a PCI USB CARD, it worked!!
I would like to fix the problem for the onboard USBs though, since before the windows repair they worked fine.
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 
LVL 22

Expert Comment

by:orangutang
ID: 21851980
Did you try uninstalling the driver and reinstalling it?
0
 
LVL 22

Expert Comment

by:orangutang
ID: 21851987
It might be a driver problem. Did you go to the website and look for driver updates?
0
 
LVL 4

Accepted Solution

by:
BGTSLLC earned 400 total points
ID: 21852051
Have you tried reinstalling Windows XP?
0
 
LVL 2

Author Comment

by:tarcis
ID: 21852191
I dont want to reinstall because there are too many softwares and configs.
0
 
LVL 22

Expert Comment

by:orangutang
ID: 21852200
Maybe try upgrading to SP3.
0
 
LVL 92

Expert Comment

by:nobus
ID: 21853245
try updating the chipset driver
these can help too :

3- run this from the run box (you can copy the command) :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
or :start>run>services.msc
look for Removable Storage Service. Is it set to Auto, and if not started, click the Start link in the top left...
In c:\windowsc:\windows\inf.  look for usbstor.inf -  If not found, copy from another PC. If you find it, right click it and select Install
See if it rebuilds the USB support...  normally located at c:\windows\system32\drivers
4-Start the Registry Editor (Run -> Regedit). Check if under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion the item 'DevicePath' points to '%SystemRoot%\inf'. Additional items, separated by semicolons, are ok but '%SystemRoot%\inf' has to be one of them.
Then delete the file C:\WINDOWS\inf\infcache.1 - XP will recreate it.
The INF folder and the infcache.1 file are 'hidden'. To see them in the Windows Explorer:
Menu 'Tools' -> 'Folder Options' Tab 'View', mark 'show hidden files and folders'
5-The registry keys reside in the registry (click start, run, regedit) under the following keys:
 
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetEnum
edit: (Slashes may not appear in this forum for some stupid reason...)
It is: HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Enum
 
Under the headings USB, and USBSTOR. Right click "USB", click "permissions" click the "Allow Full Control" checkbox, and OK. Once you have completed this, right click the "USB" key, and click delete. Do the same for the "USBSTOR" key, delete both.
 Restart the PC, . After this has completed, plug your USB Jumpdrive back in, and it should recognize.

If it still doesn't work after a restart, the files in C:\WINDOWS\inf might be corrupt. A Windows repair install should correct this.
0
 
LVL 2

Author Comment

by:tarcis
ID: 21879514
Sorry I have been absent for a few days, I want feeling well for the past couple of days
I will try nobus´s ideas and return to you guys
0
 
LVL 2

Author Comment

by:tarcis
ID: 21895634
Tried nobus solution but it did not work.
The motherboard is an AM37 and uses VIA chipset.
I have tried updating the drivers, I tried the newest VIA 4in1 driver, and I it was Windows Repair that started this mess in the first place.
Nothing works.
I remember seeying somewhere that some botherboard have a jumper to set a diferent voltage for the usb +5. Does anyone know what that is and if it aplies here ?
0
 
LVL 92

Expert Comment

by:nobus
ID: 21897081
>>   a jumper to set a diferent voltage for the usb +5.   <<   as far as i know there is no other voltage possible - the standard is  +5
can you still use a system restore? that can help too, if the restore points are not wiped by the repair..
otherwise, a fresh install always cures this problem
0
 
LVL 2

Author Comment

by:tarcis
ID: 21898004
I cant use system restore cause I turn it off for better performance.
I am avoing a fresh install because there is too many stuff to save configurations, software to reinstall that I dont even have the CDs anymore, and games with saved data....
0
 
LVL 92

Assisted Solution

by:nobus
nobus earned 200 total points
ID: 21898044
everybody tries to avoid a fresh install; but it is not necessary.
you do it once, and sacrifice the time needed to install all programs, updates, and whatevers
THEN you make an image of your disk, that you can restore in 10 minutes !
0
 
LVL 2

Author Comment

by:tarcis
ID: 21977752
Well, I tried a XP REPAIR and here are the results :
Right after the repair my onboard usb started working again
But the problem with the drive letter persisted.
AND my AGP Geforce 2 was not detected (during the repair it asked for a viaagp.sys which I didnt have)So I tried installing the old via 4in1 driver.
By doing so, my geforce was detected but the USB stopped working (everything I plug in, detects as unkown device)

If I remove the VIA CPU TO AGP from device manager, the USB works again but I am left without my AGP Geforce!

Seems there is a problem with the via chipset driver.  (a conflict with the AGP driver and the usb) HOW IS THIS POSSIBLE ?
I Tried the new Hyperion drivers, but USB does not work at ALL with any of the via drivers.

HELP!!
0
 
LVL 2

Author Comment

by:tarcis
ID: 21978226
Ok, I think the conflict is with my geforce nvidia driver.
If I use the onboard video, usb and sound drivers work fine.
After pluging in my geforce, not only the USB but the sound stops working also.
I understand this might be a new question, but the problem with drive letters persist excluding my geforce problem.
0
 
LVL 2

Author Comment

by:tarcis
ID: 21978258
The correct word is DESPITE, not excluding.
I am using the latest nvidia driver available : 93.71_forceware_winxp2k_international_whql

But I have tried older drivers with no luck
Here are the ones I also tried:
84.21_forceware_winxp2k_international_whql
53.03_winxp2k_international_whql
4523_whql_WinXP-2K

The mainboard is a FIC AM37.
its an Athlon XP 2000+
with 1gb memory SAMSUNG (memtest passed)
40gb MAXTOR HD (seatools long test passed)

I am currently using an offboard
PCI Sound Card (since sound is not working)
PCI USB CARD (VIA)
0
 
LVL 2

Author Comment

by:tarcis
ID: 21978263
oh, forgot to mention my GEFORCE 2 MX 400 AGP card.
0
 
LVL 92

Expert Comment

by:nobus
ID: 21980365
the usb driver is included in the chipset driver
you can try this for restoring the usb :

Remove all USB drivers with: https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
0
 
LVL 2

Author Comment

by:tarcis
ID: 22011935
I managed to get the AGP and the USB working by enabling the Onboard sound (sound is not working), and using the sound from my PCI card.
I have discovered another thing
If I assign a drive letter in disk manager to my pendrive, I still wont see it in the Windows Explorer or "My computer", and even if I type V:\ in the address bar (V: being the assigned letter) it gives me a cant find file:///V://............
BUT if i go to the Command Console and type V:
I can "dir" and see all my pen drive contents.
Weird or what ?
0
 
LVL 2

Author Comment

by:tarcis
ID: 22011950
by the way
There is NO upper and LOWER keys under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
0
 
LVL 92

Expert Comment

by:nobus
ID: 22016495
did you remove, or install the AGP card?  if not remove the software - test usb, reinstall agp card again and test
0
 
LVL 2

Author Comment

by:tarcis
ID: 22016577
The problem with the drive letters is not related to the AGP (it persists on all cases)
But I was having a problem with the AGP and USB, in that case, the USB woudnt work at all.
0
 
LVL 2

Author Comment

by:tarcis
ID: 22170601
Any more ideas ?
Problem persists...
When I plug in a USB Stick, it recognizes but no icon is created on MY computer, or windows explorer.
The only way to access it is be disk management, but even after assigning a drive letter, the drive does not appear. I am able to access the files in it by right clicking the partition in diskmanagement and selecting OPEN
0
 
LVL 92

Expert Comment

by:nobus
ID: 22170990
try this then :
2- check  also  :   http://support.microsoft.com/kb/925196      +   the "SIMILAR PROBLEMS AND SOLUTIONS" section.
3- run this from the run box (you can copy the command) :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
or :start>run>services.msc
look for Removable Storage Service. Is it set to Auto, and if not started, click the Start link in the top left...
In c:\windowsc:\windows\inf.  look for usbstor.inf -  If not found, copy from another PC. If you find it, right click it and select Install
See if it rebuilds the USB support...  normally located at c:\windows\system32\drivers
4-Start the Registry Editor (Run -> Regedit). Check if under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion the item 'DevicePath' points to '%SystemRoot%\inf'. Additional items, separated by semicolons, are ok but '%SystemRoot%\inf' has to be one of them.
Then delete the file C:\WINDOWS\inf\infcache.1 - XP will recreate it.
The INF folder and the infcache.1 file are 'hidden'. To see them in the Windows Explorer:
Menu 'Tools' -> 'Folder Options' Tab 'View', mark 'show hidden files and folders'
5-The registry keys reside in the registry (click start, run, regedit) under the following keys:
 
HKEY_LOCAL_MACHINESYSTEMCurrentControlSetEnum
edit: (Slashes may not appear in this forum for some stupid reason...)
It is: HKEY_LOCAL_MACHINE, SYSTEM, CurrentControlSet, Enum
 
Under the headings USB, and USBSTOR. Right click "USB", click "permissions" click the "Allow Full Control" checkbox, and OK. Once you have completed this, right click the "USB" key, and click delete. Do the same for the "USBSTOR" key, delete both.
 Restart the PC, . After this has completed, plug your USB Jumpdrive back in, and it should recognize.

If it still doesn't work after a restart, the files in C:\WINDOWS\inf might be corrupt. A Windows repair install should correct this.
0
 
LVL 2

Author Closing Comment

by:tarcis
ID: 31623518
Thank you all for helping, none of the solutions worked, only a fresh install will correct this, but that wasnt the answer I was looking for. I have split points for those who were correct and who helped most. Thanks
0
 
LVL 92

Expert Comment

by:nobus
ID: 22260248
i expected at least a B grade !  :-((
0
 
LVL 2

Author Comment

by:tarcis
ID: 22261055
I know you put a lot of effort and stayed with me till the end, but my problem was not solved. =[
0
 
LVL 92

Expert Comment

by:nobus
ID: 22261395
check the grading on EE please : http://www.experts-exchange.com/help.jsp#hi97
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question